From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from mail-yw1-f67.google.com ([209.85.161.67]:33418 "EHLO mail-yw1-f67.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1725306AbfAGHkM (ORCPT ); Mon, 7 Jan 2019 02:40:12 -0500 MIME-Version: 1.0 References: <20181202113826.32133-1-amir73il@gmail.com> <20181202113826.32133-16-amir73il@gmail.com> <20190104105709.GJ22409@quack2.suse.cz> <20190104121853.GP22409@quack2.suse.cz> In-Reply-To: <20190104121853.GP22409@quack2.suse.cz> From: Amir Goldstein Date: Mon, 7 Jan 2019 09:40:00 +0200 Message-ID: Subject: Re: [PATCH v4 15/15] fanotify: report FAN_ONDIR to listener with FAN_REPORT_FID To: Jan Kara Cc: Matthew Bobrowski , linux-fsdevel , linux-api@vger.kernel.org Content-Type: text/plain; charset="UTF-8" Sender: linux-fsdevel-owner@vger.kernel.org List-ID: > > > > +/* Events types that may be reported from vfs */ > > > > +#define FANOTIFY_EVENT_TYPES (FANOTIFY_EVENTS | \ > > > > + FANOTIFY_PERM_EVENTS) > > > > + > > > > /* Extra flags that may be reported with event or control handling of events */ > > > > #define FANOTIFY_EVENT_FLAGS (FAN_EVENT_ON_CHILD | FAN_ONDIR) > > > > > > > > /* Events that may be reported to user */ > > > > -#define FANOTIFY_OUTGOING_EVENTS (FANOTIFY_EVENTS | \ > > > > - FANOTIFY_PERM_EVENTS | \ > > > > - FAN_Q_OVERFLOW) > > > > +#define FANOTIFY_OUTGOING_EVENTS (FANOTIFY_EVENT_TYPES | \ > > > > + FAN_Q_OVERFLOW | FAN_ONDIR) > > > > > > > > #define ALL_FANOTIFY_EVENT_BITS (FANOTIFY_OUTGOING_EVENTS | \ > > > > FANOTIFY_EVENT_FLAGS) > > > > > > I don't like this renaming. FAN_ONDIR essentially becomes the same type of > > > thing as FAN_EVENT_ON_CHILD - i.e., an event flag. So I'd just leave these > > > defines as is... > > > > > > > Sorry. I don't understand what you mean. > > FAN_EVENT_ON_CHILD is not in FANOTIFY_OUTGOING_EVENTS > > FAN_ONDIR is in FANOTIFY_OUTGOING_EVENTS after this change. > > copy_event_to_user() masks out with FANOTIFY_OUTGOING_EVENTS. > > Do you not like the new group definition FANOTIFY_EVENT_TYPES? > > Sorry, I've got confused and thought that FAN_EVENT_ON_CHILD gets reported > to userspace. I don't like the FANOTIFY_EVENT_TYPES name and > FANOTIFY_OUTGOING_EVENTS becomes somewhat a misnomer after adding FAN_ONDIR > there. So how about renaming FANOTIFY_OUTGOING_EVENTS to > FANOTIFY_OUTGOING_MASK and have FANOTIFY_OUTGOING_EVENTS what your > FANOTIFY_EVENT_TYPES is? > Jan, I decided to avert this specific bikeshed and my updated version does not use any new defined. Thanks, Amir.