From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754514AbcDMWER (ORCPT ); Wed, 13 Apr 2016 18:04:17 -0400 Received: from mail-io0-f172.google.com ([209.85.223.172]:35888 "EHLO mail-io0-f172.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753079AbcDMWEP (ORCPT ); Wed, 13 Apr 2016 18:04:15 -0400 MIME-Version: 1.0 X-Originating-IP: [67.51.76.21] In-Reply-To: <1452602781-22424-7-git-send-email-lee.jones@linaro.org> References: <1452602781-22424-1-git-send-email-lee.jones@linaro.org> <1452602781-22424-7-git-send-email-lee.jones@linaro.org> Date: Wed, 13 Apr 2016 15:04:13 -0700 Message-ID: Subject: Re: [PATCH v5 6/7] ARM: STiH407: Add nodes for RemoteProc From: Olof Johansson To: Lee Jones Cc: "linux-arm-kernel@lists.infradead.org" , "linux-kernel@vger.kernel.org" , "kernel@stlinux.com" , Maxime Coquelin , Ohad Ben-Cohen , "devicetree@vger.kernel.org" , Nathan Lynch , Florian Fainelli , ludovic.barre@st.com, Suman Anna Content-Type: text/plain; charset=UTF-8 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi, On Tue, Jan 12, 2016 at 4:46 AM, Lee Jones wrote: > Signed-off-by: Ludovic Barre > Signed-off-by: Lee Jones > --- > arch/arm/boot/dts/stih407-family.dtsi | 40 +++++++++++++++++++++++++++++++++++ > 1 file changed, 40 insertions(+) > > diff --git a/arch/arm/boot/dts/stih407-family.dtsi b/arch/arm/boot/dts/stih407-family.dtsi > index 1e4e01925..15c20b6 100644 > --- a/arch/arm/boot/dts/stih407-family.dtsi > +++ b/arch/arm/boot/dts/stih407-family.dtsi > @@ -650,5 +650,45 @@ > mbox-name = "st231_audio_video"; > status = "okay"; > }; > + > + st231_gp0: st231-gp0@40000000 { These node names seem odd. Should probably be more generic "remoteproc@40000000". > + compatible = "st,st231-rproc"; > + reg = <0x40000000 0x01000000>; This isn't what the binding says, it uses a memory region instead. -Olof From mboxrd@z Thu Jan 1 00:00:00 1970 From: Olof Johansson Subject: Re: [PATCH v5 6/7] ARM: STiH407: Add nodes for RemoteProc Date: Wed, 13 Apr 2016 15:04:13 -0700 Message-ID: References: <1452602781-22424-1-git-send-email-lee.jones@linaro.org> <1452602781-22424-7-git-send-email-lee.jones@linaro.org> Mime-Version: 1.0 Content-Type: text/plain; charset=UTF-8 Return-path: In-Reply-To: <1452602781-22424-7-git-send-email-lee.jones@linaro.org> Sender: linux-kernel-owner@vger.kernel.org To: Lee Jones Cc: "linux-arm-kernel@lists.infradead.org" , "linux-kernel@vger.kernel.org" , "kernel@stlinux.com" , Maxime Coquelin , Ohad Ben-Cohen , "devicetree@vger.kernel.org" , Nathan Lynch , Florian Fainelli , ludovic.barre@st.com, Suman Anna List-Id: devicetree@vger.kernel.org Hi, On Tue, Jan 12, 2016 at 4:46 AM, Lee Jones wrote: > Signed-off-by: Ludovic Barre > Signed-off-by: Lee Jones > --- > arch/arm/boot/dts/stih407-family.dtsi | 40 +++++++++++++++++++++++++++++++++++ > 1 file changed, 40 insertions(+) > > diff --git a/arch/arm/boot/dts/stih407-family.dtsi b/arch/arm/boot/dts/stih407-family.dtsi > index 1e4e01925..15c20b6 100644 > --- a/arch/arm/boot/dts/stih407-family.dtsi > +++ b/arch/arm/boot/dts/stih407-family.dtsi > @@ -650,5 +650,45 @@ > mbox-name = "st231_audio_video"; > status = "okay"; > }; > + > + st231_gp0: st231-gp0@40000000 { These node names seem odd. Should probably be more generic "remoteproc@40000000". > + compatible = "st,st231-rproc"; > + reg = <0x40000000 0x01000000>; This isn't what the binding says, it uses a memory region instead. -Olof From mboxrd@z Thu Jan 1 00:00:00 1970 From: olof@lixom.net (Olof Johansson) Date: Wed, 13 Apr 2016 15:04:13 -0700 Subject: [PATCH v5 6/7] ARM: STiH407: Add nodes for RemoteProc In-Reply-To: <1452602781-22424-7-git-send-email-lee.jones@linaro.org> References: <1452602781-22424-1-git-send-email-lee.jones@linaro.org> <1452602781-22424-7-git-send-email-lee.jones@linaro.org> Message-ID: To: linux-arm-kernel@lists.infradead.org List-Id: linux-arm-kernel.lists.infradead.org Hi, On Tue, Jan 12, 2016 at 4:46 AM, Lee Jones wrote: > Signed-off-by: Ludovic Barre > Signed-off-by: Lee Jones > --- > arch/arm/boot/dts/stih407-family.dtsi | 40 +++++++++++++++++++++++++++++++++++ > 1 file changed, 40 insertions(+) > > diff --git a/arch/arm/boot/dts/stih407-family.dtsi b/arch/arm/boot/dts/stih407-family.dtsi > index 1e4e01925..15c20b6 100644 > --- a/arch/arm/boot/dts/stih407-family.dtsi > +++ b/arch/arm/boot/dts/stih407-family.dtsi > @@ -650,5 +650,45 @@ > mbox-name = "st231_audio_video"; > status = "okay"; > }; > + > + st231_gp0: st231-gp0 at 40000000 { These node names seem odd. Should probably be more generic "remoteproc at 40000000". > + compatible = "st,st231-rproc"; > + reg = <0x40000000 0x01000000>; This isn't what the binding says, it uses a memory region instead. -Olof