From mboxrd@z Thu Jan 1 00:00:00 1970 From: Simon Glass Date: Thu, 29 Nov 2018 14:26:59 -0700 Subject: [U-Boot] [PATCH v16 0/4] efi_loader: Code refactoring and improvement In-Reply-To: <20181126031439.202582-1-sjg@chromium.org> References: <20181126031439.202582-1-sjg@chromium.org> Message-ID: List-Id: MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: u-boot@lists.denx.de Hi Alex, On Sun, 25 Nov 2018 at 20:14, Simon Glass wrote: > > This collects the patches previously sent to break up the very large > functions in efi_loader into smaller pieces. Now that the other sandbox > stuff is applied, perhaps it is time to apply these patches. > > This also adds a few new patches to fix more recent breakages. > Unfortunately we still cannot enable the efi loader tests since one of > the tests fails. Thus we should expect additional failures to appear > until that is resolved. > > Changes in v16: > - Add new patch to check for failure to create objects in selftest > - Drop comments about efi_save_gd() being called in efi_init_obj_list() > > Changes in v15: > - Add a comment about a leaked device path > - Add check for return values to bootefi_test_prepare() > - Drop call to efi_save_gd() in bootefi_test_prepare() > - Drop patch already applied > - Fix minor checkpatch nit with bracket > > Changes in v14: > - Go back to the horrible long variable names > - Hopefully correct error paths in do_bootefi_exec() > > Changes in v13: > - Drop 'efi_loader: Drop setup_ok' as we have an existing patch for that > - Drop patches previously applied > - Rebase to efi/efi-next > > Changes in v12: > - Rename image to image_prot > > Changes in v11: > - Drop patches previously applied > > Changes in v9: > - Add comments to bootefi_test_prepare() about the memset()s > > Changes in v7: > - Drop patch "efi: Init the 'rows' and 'cols' variables" > - Drop patches previous applied > > Changes in v5: > - Drop call to efi_init_obj_list() which is now done in do_bootefi() > - Introduce load_options_path to specifyc U-Boot env var for load_options_path > - Rebase to master > > Changes in v4: > - Rebase to master > > Changes in v3: > - Add new patch to rename bootefi_test_finish() to bootefi_run_finish() > - Add new patch to split out test init/uninit into functions > - Add patch to create a function to set up for running EFI code > > Simon Glass (4): > efi: Check for failure to create objects in selftest > efi: Split out test init/uninit into functions > efi: Create a function to set up for running EFI code > efi: Rename bootefi_test_finish() to bootefi_run_finish() > > cmd/bootefi.c | 118 +++++++++++++++++++++++++++++++++++++------------- > 1 file changed, 89 insertions(+), 29 deletions(-) Any thoughts on this latest version? Regards, Simon