From mboxrd@z Thu Jan 1 00:00:00 1970 From: Simon Glass Date: Thu, 7 May 2015 22:01:36 -0600 Subject: [U-Boot] Please pull u-boot-dm Message-ID: List-Id: MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: u-boot@lists.denx.de Hi Tom, This includes the real-time-clock uclass, a driver model test suite speed-up and part of Han's USB work (the rest need to wait for some patch respins). The following changes since commit 905e8f9e53766e606bd4a0ed46d804889e613f32: Prepare v2015.07-rc1 (2015-05-05 19:52:15 -0400) are available in the git repository at: http://git.denx.de/u-boot-dm.git for you to fetch changes up to a5e1bcdeebebabdc5d013fbd488f87a4e62ff411: dm: sf: Update default name of spi flash in structure udevice (2015-05-06 14:00:35 -0600) ---------------------------------------------------------------- Axel Lin (1): dm: i2c-gpio: Remove redundant dm_gpio_set_value() call Haikun.Wang at freescale.com (1): dm: sf: Update default name of spi flash in structure udevice Hans de Goede (16): dm: usb: Do not use bus->seq before device_probe(bus) dm: usb: Make usb_get_bus easier to use for callers dm: usb: Copy over usb_device values from usb_scan_device() to final usb_device dm: usb: Use usb_get_bus in dm ehci code dm: usb: Fix finding of first upstream usb-2 hub in the ehci dm code dm: usb: Set desc_before_addr from ehci dm code usb: Fix maxpacketsize for first descriptor read for low-speed usb devs usb: ohci: Remove unused devgone global variable usb: ohci: Pass around a pointer to ohci_t rather then accessing global vars usb: ohci: Move the ohci_dev struct to inside the main ohci struct usb: ohci: Move the td array struct to inside the ohci_dev struct usb: ohci: Remove unnecessary phcca variable usb: ohci: Move static func and var declarations from ohci.h to ohci-hcd.c usb: ohci: Fix ctrl in messages with a data-len of 0 usb: ohci: Add proper cache flushing / invalidating for non cache coherent cpus usb: ohci: Don't log an error on interrupt packet timeout Joe Hershberger (3): sandbox: Add test function to advance time sandbox: eth: Add a function to skip ping timeouts test: dm: eth: Skip timeouts on ping tests Simon Glass (26): dm: spi: Avoid setting the speed with every transfer cros_ec: Show the protocol version in the debug message cros_ec: Handle the single duplex requirement in cros_ec dm: spi: Correct the comment on spi_get_ops() dm: i2c: sandbox: Add debugging to the speed limit dm: i2c: Add functions to read and write a register dm: i2c: Add an explicit test mode to the sandbox I2C driver fdt: Correct warning in fdt_setup_simplefb_node() dm: rtc: Rename gregorian day function dm: rtc: Rename to_tm() to rtc_to_tm() and add error code dm: rtc: Rename mktime() and reduce the number of parameters dm: Remove unnecessary types in bcd.h dm: rtc: Split structure definition into its own file dm: sandbox: Add os_localtime() to obtain the system time dm: rtc: Add a uclass for real-time clocks dm: rtc: sandbox: Add an emulated I2C RTC device dm: rtc: sandbox: Add a driver for the sandbox I2C RTC dm: rtc: Convert 'date' command to support driver model dm: net: rtc: Support using driver model for rtc in sntp dm: sandbox: dts: Add a real-time clock attached to I2C dm: rtc: sandbox: Enable real-time clock support dm: test: dts: Sort the aliases in the test device tree file dm: rtc: Add tests for real-time clocks test: Add a simple time test sandbox: Enable time unit test command dm: usb: exynos: Drop legacy USB code Sjoerd Simons (1): sandbox: Don't try distro_bootcmd by default arch/sandbox/cpu/cpu.c | 5 - arch/sandbox/cpu/os.c | 18 +++ arch/sandbox/cpu/start.c | 20 ++- arch/sandbox/dts/sandbox.dts | 12 +- arch/sandbox/include/asm/eth.h | 2 + arch/sandbox/include/asm/rtc.h | 28 ++++ arch/sandbox/include/asm/state.h | 1 + arch/sandbox/include/asm/test.h | 39 +++++ board/sandbox/sandbox.c | 11 +- common/cmd_date.c | 57 +++++-- common/fdt_support.c | 2 +- common/image.c | 2 +- common/usb.c | 17 +- configs/sandbox_defconfig | 2 + drivers/i2c/i2c-gpio.c | 13 +- drivers/i2c/i2c-uclass.c | 19 +++ drivers/i2c/sandbox_i2c.c | 34 ++-- drivers/misc/cros_ec.c | 3 +- drivers/misc/cros_ec_spi.c | 23 ++- drivers/mtd/spi/sf-uclass.c | 4 +- drivers/net/sandbox.c | 17 ++ drivers/rtc/Kconfig | 8 + drivers/rtc/Makefile | 4 + drivers/rtc/at91sam9_rtt.c | 5 +- drivers/rtc/bfin_rtc.c | 5 +- drivers/rtc/date.c | 38 +++-- drivers/rtc/ds1306.c | 5 +- drivers/rtc/ds1374.c | 6 +- drivers/rtc/ftrtc010.c | 5 +- drivers/rtc/i2c_rtc_emul.c | 236 ++++++++++++++++++++++++++++ drivers/rtc/imxdi.c | 5 +- drivers/rtc/mc13xxx-rtc.c | 5 +- drivers/rtc/mcfrtc.c | 2 +- drivers/rtc/mpc8xx.c | 5 +- drivers/rtc/mx27rtc.c | 5 +- drivers/rtc/mxsrtc.c | 5 +- drivers/rtc/pl031.c | 5 +- drivers/rtc/rtc-uclass.c | 96 ++++++++++++ drivers/rtc/sandbox_rtc.c | 106 +++++++++++++ drivers/spi/spi-uclass.c | 9 +- drivers/usb/host/ehci-exynos.c | 117 -------------- drivers/usb/host/ehci-hcd.c | 46 +++--- drivers/usb/host/ohci-hcd.c | 327 +++++++++++++++++++++++++++------------ drivers/usb/host/ohci.h | 136 ++++------------ drivers/usb/host/usb-uclass.c | 63 ++++---- drivers/usb/host/xhci-exynos5.c | 108 ------------- include/bcd.h | 8 +- include/configs/sandbox.h | 3 + include/dm/uclass-id.h | 1 + include/fdtdec.h | 2 - include/i2c.h | 22 +++ include/os.h | 11 ++ include/rtc.h | 197 +++++++++++++++++++---- include/rtc_def.h | 36 +++++ include/spi.h | 5 +- include/usb.h | 24 +-- lib/fdtdec.c | 2 - net/sntp.c | 14 +- post/drivers/rtc.c | 28 +++- test/Kconfig | 8 + test/Makefile | 1 + test/dm/Makefile | 1 + test/dm/eth.c | 2 + test/dm/i2c.c | 8 + test/dm/rtc.c | 175 +++++++++++++++++++++ test/dm/test.dts | 26 +++- test/time_ut.c | 137 ++++++++++++++++ 67 files changed, 1743 insertions(+), 649 deletions(-) create mode 100644 arch/sandbox/include/asm/rtc.h create mode 100644 drivers/rtc/i2c_rtc_emul.c create mode 100644 drivers/rtc/rtc-uclass.c create mode 100644 drivers/rtc/sandbox_rtc.c create mode 100644 include/rtc_def.h create mode 100644 test/dm/rtc.c create mode 100644 test/time_ut.c Regards, Simon