All of lore.kernel.org
 help / color / mirror / Atom feed
From: Sriram Dash <sriram.dash@nxp.com>
To: u-boot@lists.denx.de
Subject: [U-Boot] [PATCH v5 3/4] drivers:usb:common:fsl-dt-fixup: Add device-tree fixup support for xhci controller
Date: Wed, 23 Mar 2016 08:30:56 +0000	[thread overview]
Message-ID: <DB4PR04MB05588FA6012A49ACA812381DF5810@DB4PR04MB0558.eurprd04.prod.outlook.com> (raw)
In-Reply-To: <56F0F2F3.5060305@denx.de>



>-----Original Message-----
>From: Marek Vasut [mailto:marex at denx.de]
>Sent: Tuesday, March 22, 2016 12:54 PM
>To: Sriram Dash <sriram.dash@nxp.com>; u-boot at lists.denx.de
>Cc: york sun <york.sun@nxp.com>; Ramneek Mehresh
><ramneek.mehresh@nxp.com>; Rajesh Bhagat <rajesh.bhagat@nxp.com>
>Subject: Re: [PATCH v5 3/4] drivers:usb:common:fsl-dt-fixup: Add device-tree fixup
>support for xhci controller
>
>On 03/22/2016 08:10 AM, Sriram Dash wrote:
>> Enables usb device-tree fixup code to incorporate xhci controller
>>
>> Signed-off-by: Ramneek Mehresh <ramneek.mehresh@nxp.com>
>> Signed-off-by: Sriram Dash <sriram.dash@nxp.com>
>> ---
>> Changes in v5:
>>   - Make the array static const
>> Changes in v4:
>>   - Use a terminating entry in the array for getting node type for
>> controller Changes in v3:
>>   - Modify the Makefile to remove comparison
>>   - Put the supported controllers in array and checking from array
>> Changes in v2:
>>   - Remove the #defines from the patch and adding controller support
>>
>>  drivers/usb/common/Makefile       |  1 +
>>  drivers/usb/common/fsl-dt-fixup.c | 33 +++++++++++++++++----------------
>>  include/fdt_support.h             |  4 ++--
>>  3 files changed, 20 insertions(+), 18 deletions(-)
>>
>> diff --git a/drivers/usb/common/Makefile b/drivers/usb/common/Makefile
>> index a38ee4a..2f3d43d 100644
>> --- a/drivers/usb/common/Makefile
>> +++ b/drivers/usb/common/Makefile
>> @@ -4,3 +4,4 @@
>>  #
>>
>>  obj-$(CONFIG_USB_EHCI_FSL) += fsl-dt-fixup.o
>> +obj-$(CONFIG_USB_XHCI_FSL) += fsl-dt-fixup.o
>> diff --git a/drivers/usb/common/fsl-dt-fixup.c
>> b/drivers/usb/common/fsl-dt-fixup.c
>> index eb13f12..13f9fb8 100644
>> --- a/drivers/usb/common/fsl-dt-fixup.c
>> +++ b/drivers/usb/common/fsl-dt-fixup.c
>> @@ -19,27 +19,28 @@
>>  #define CONFIG_USB_MAX_CONTROLLER_COUNT 1  #endif
>>
>> +static const char compat_usb_fsl[] = {
>> +	"fsl-usb2-mph" "\0"
>> +	"fsl-usb2-dr" "\0"
>> +	"snps,dwc3" "\0"
>> +};
>
>This is supposed to be static constant array of strings. Can you tell me, based on
>your knowledge of the C language, what is wrong with this construct ?
>

IMO, above construct is correct. Originally, we proposed array of strings but later we changed to 
character array with terminating NULL entry for each element to incorporate your below review 
comment given in v3. 
"My opinion is to use a terminating NULL entry and iterate over the array until you reach it."

>Best regards,
>Marek Vasut

  reply	other threads:[~2016-03-23  8:30 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-03-22  7:10 [U-Boot] [PATCH v5 0/4] Make usb device-tree fixup independent of USB controller Sriram Dash
2016-03-22  7:10 ` [U-Boot] [PATCH v5 1/4] drivers:usb:common:fsl-dt-fixup: Move device-tree fixup framework to common file Sriram Dash
2016-03-22  7:24   ` Marek Vasut
2016-03-22  7:10 ` [U-Boot] [PATCH v5 2/4] drivers:usb:common:fsl-dt-fixup: Remove code duplication for fdt_usb_get_node_type Sriram Dash
2016-03-22  7:24   ` Marek Vasut
2016-03-22  7:10 ` [U-Boot] [PATCH v5 3/4] drivers:usb:common:fsl-dt-fixup: Add device-tree fixup support for xhci controller Sriram Dash
2016-03-22  7:23   ` Marek Vasut
2016-03-23  8:30     ` Sriram Dash [this message]
2016-03-23  8:41       ` Marek Vasut
2016-03-23  8:43         ` Marek Vasut
2016-03-22  7:10 ` [U-Boot] [PATCH v5 4/4] drivers:usb:common:fsl-dt-fixup: fix return value of fdt_usb_get_node_type Sriram Dash
2016-03-22  7:25   ` Marek Vasut
2016-03-23  8:31     ` Sriram Dash
2016-03-23  8:42       ` Marek Vasut

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=DB4PR04MB05588FA6012A49ACA812381DF5810@DB4PR04MB0558.eurprd04.prod.outlook.com \
    --to=sriram.dash@nxp.com \
    --cc=u-boot@lists.denx.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.