All of lore.kernel.org
 help / color / mirror / Atom feed
From: hpa@zytor.com
To: Nadav Amit <namit@vmware.com>,
	linux-kernel@vger.kernel.org, x86@kernel.org
Cc: Thomas Gleixner <tglx@linutronix.de>,
	Ingo Molnar <mingo@redhat.com>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Kate Stewart <kstewart@linuxfoundation.org>,
	Philippe Ombredanne <pombredanne@nexb.com>
Subject: Re: [PATCH v3 9/9] x86: jump-labels: use macros instead of inline assembly
Date: Sun, 10 Jun 2018 18:29:54 -0700	[thread overview]
Message-ID: <FF974700-F60D-4083-836C-0D4A2557FA16@zytor.com> (raw)
In-Reply-To: <20180610141911.52948-10-namit@vmware.com>

On June 10, 2018 7:19:11 AM PDT, Nadav Amit <namit@vmware.com> wrote:
>Use assembly macros for jump-labels and call them from inline assembly.
>This not only makes the code more readable, but also improves
>compilation decision, specifically inline decisions which GCC base on
>the number of new lines in inline assembly.
>
>As a result the code size is slightly increased.
>
>   text	   data	    bss	    dec	    hex	filename
>18163528 10226300 2957312 31347140 1de51c4 ./vmlinux before
>18163608 10227348 2957312 31348268 1de562c ./vmlinux after (+1128)
>
>And functions such as intel_pstate_adjust_policy_max(),
>kvm_cpu_accept_dm_intr(), kvm_register_read() are inlined.
>
>Cc: Thomas Gleixner <tglx@linutronix.de>
>Cc: Ingo Molnar <mingo@redhat.com>
>Cc: "H. Peter Anvin" <hpa@zytor.com>
>Cc: x86@kernel.org
>Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
>Cc: Kate Stewart <kstewart@linuxfoundation.org>
>Cc: Philippe Ombredanne <pombredanne@nexb.com>
>
>Signed-off-by: Nadav Amit <namit@vmware.com>
>---
> arch/x86/include/asm/jump_label.h | 65 ++++++++++++++++++-------------
> arch/x86/kernel/macros.S          |  1 +
> 2 files changed, 39 insertions(+), 27 deletions(-)
>
>diff --git a/arch/x86/include/asm/jump_label.h
>b/arch/x86/include/asm/jump_label.h
>index 8c0de4282659..ea0633a41122 100644
>--- a/arch/x86/include/asm/jump_label.h
>+++ b/arch/x86/include/asm/jump_label.h
>@@ -2,19 +2,6 @@
> #ifndef _ASM_X86_JUMP_LABEL_H
> #define _ASM_X86_JUMP_LABEL_H
> 
>-#ifndef HAVE_JUMP_LABEL
>-/*
>- * For better or for worse, if jump labels (the gcc extension) are
>missing,
>- * then the entire static branch patching infrastructure is compiled
>out.
>- * If that happens, the code in here will malfunction.  Raise a
>compiler
>- * error instead.
>- *
>- * In theory, jump labels and the static branch patching
>infrastructure
>- * could be decoupled to fix this.
>- */
>-#error asm/jump_label.h included on a non-jump-label kernel
>-#endif
>-
> #define JUMP_LABEL_NOP_SIZE 5
> 
> #ifdef CONFIG_X86_64
>@@ -28,18 +15,27 @@
> 
> #ifndef __ASSEMBLY__
> 
>+#ifndef HAVE_JUMP_LABEL
>+/*
>+ * For better or for worse, if jump labels (the gcc extension) are
>missing,
>+ * then the entire static branch patching infrastructure is compiled
>out.
>+ * If that happens, the code in here will malfunction.  Raise a
>compiler
>+ * error instead.
>+ *
>+ * In theory, jump labels and the static branch patching
>infrastructure
>+ * could be decoupled to fix this.
>+ */
>+#error asm/jump_label.h included on a non-jump-label kernel
>+#endif
>+
> #include <linux/stringify.h>
> #include <linux/types.h>
> 
>static __always_inline bool arch_static_branch(struct static_key *key,
>bool branch)
> {
>-	asm_volatile_goto("1:"
>-		".byte " __stringify(STATIC_KEY_INIT_NOP) "\n\t"
>-		".pushsection __jump_table,  \"aw\" \n\t"
>-		_ASM_ALIGN "\n\t"
>-		_ASM_PTR "1b, %l[l_yes], %c0 + %c1 \n\t"
>-		".popsection \n\t"
>-		: :  "i" (key), "i" (branch) : : l_yes);
>+	asm_volatile_goto("STATIC_BRANCH_GOTO l_yes=\"%l[l_yes]\" key=\"%c0\"
>"
>+			  "branch=\"%c1\""
>+			: :  "i" (key), "i" (branch) : : l_yes);
> 
> 	return false;
> l_yes:
>@@ -48,13 +44,8 @@ static __always_inline bool
>arch_static_branch(struct static_key *key, bool bran
> 
>static __always_inline bool arch_static_branch_jump(struct static_key
>*key, bool branch)
> {
>-	asm_volatile_goto("1:"
>-		".byte 0xe9\n\t .long %l[l_yes] - 2f\n\t"
>-		"2:\n\t"
>-		".pushsection __jump_table,  \"aw\" \n\t"
>-		_ASM_ALIGN "\n\t"
>-		_ASM_PTR "1b, %l[l_yes], %c0 + %c1 \n\t"
>-		".popsection \n\t"
>+	asm_volatile_goto("STATIC_BRANCH_JUMP_GOTO l_yes=\"%l[l_yes]\"
>key=\"%c0\" "
>+			  "branch=\"%c1\""
> 		: :  "i" (key), "i" (branch) : : l_yes);
> 
> 	return false;
>@@ -108,6 +99,26 @@ struct jump_entry {
> 	.popsection
> .endm
> 
>+.macro STATIC_BRANCH_GOTO l_yes:req key:req branch:req
>+1:
>+	.byte STATIC_KEY_INIT_NOP
>+	.pushsection __jump_table, "aw"
>+	_ASM_ALIGN
>+	_ASM_PTR 1b, \l_yes, \key + \branch
>+	.popsection
>+.endm
>+
>+.macro STATIC_BRANCH_JUMP_GOTO l_yes:req key:req branch:req
>+1:
>+	.byte 0xe9
>+	.long \l_yes - 2f
>+2:
>+	.pushsection __jump_table, "aw"
>+	_ASM_ALIGN
>+	_ASM_PTR 1b, \l_yes, \key + \branch
>+	.popsection
>+.endm
>+
> #endif	/* __ASSEMBLY__ */
> 
> #endif
>diff --git a/arch/x86/kernel/macros.S b/arch/x86/kernel/macros.S
>index bf8b9c93e255..161c95059044 100644
>--- a/arch/x86/kernel/macros.S
>+++ b/arch/x86/kernel/macros.S
>@@ -13,3 +13,4 @@
> #include <asm/paravirt.h>
> #include <asm/asm.h>
> #include <asm/cpufeature.h>
>+#include <asm/jump_label.h>

If the code size increases, do you have any metrics for improvement?

That being said, I do like the readability improvements and the ability to use gas macros in assembly as opposed to cpp macros wrapped in different ways for C and assembly.
-- 
Sent from my Android device with K-9 Mail. Please excuse my brevity.

  reply	other threads:[~2018-06-11  1:30 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-06-10 14:19 [PATCH v3 0/9] x86: macrofying inline asm for better compilation Nadav Amit
2018-06-10 14:19 ` Nadav Amit
2018-06-10 14:19 ` [PATCH v3 1/9] Makefile: Prepare for using macros for inline asm Nadav Amit
2018-06-10 14:19   ` Nadav Amit
2018-06-10 14:19 ` [PATCH v3 2/9] x86: objtool: use asm macro for better compiler decisions Nadav Amit
2018-06-10 14:19   ` Nadav Amit
2018-06-10 14:19 ` [PATCH v3 3/9] x86: refcount: prevent gcc distortions Nadav Amit
2018-06-10 14:19 ` [PATCH v3 4/9] x86: alternatives: macrofy locks for better inlining Nadav Amit
2018-06-11  8:03   ` Peter Zijlstra
2018-06-10 14:19 ` [PATCH v3 5/9] x86: bug: prevent gcc distortions Nadav Amit
2018-06-10 14:19 ` [PATCH v3 6/9] x86: prevent inline distortion by paravirt ops Nadav Amit
2018-06-11  7:45   ` Peter Zijlstra
2018-06-11  7:45     ` Peter Zijlstra
2018-06-12  3:49     ` Nadav Amit
2018-06-10 14:19 ` [PATCH v3 7/9] x86: extable: use macros instead of inline assembly Nadav Amit
2018-06-10 14:19 ` [PATCH v3 8/9] x86: cpufeature: " Nadav Amit
2018-06-10 14:19 ` [PATCH v3 9/9] x86: jump-labels: " Nadav Amit
2018-06-11  1:29   ` hpa [this message]
2018-06-11  3:47     ` Nadav Amit
2018-06-11  7:50   ` Peter Zijlstra

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=FF974700-F60D-4083-836C-0D4A2557FA16@zytor.com \
    --to=hpa@zytor.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=kstewart@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=namit@vmware.com \
    --cc=pombredanne@nexb.com \
    --cc=tglx@linutronix.de \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.