All of lore.kernel.org
 help / color / mirror / Atom feed
From: Alan Stern <stern@rowland.harvard.edu>
To: Petr Mladek <pmladek@suse.cz>
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Tejun Heo <tj@kernel.org>,
	Joe Lawrence <joe.lawrence@stratus.com>,
	Jiri Kosina <jkosina@suse.cz>, <linux-usb@vger.kernel.org>,
	<linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v2 4/4] usb: hub: rename khubd to hub_wq in documentation and comments
Date: Wed, 17 Sep 2014 13:36:26 -0400 (EDT)	[thread overview]
Message-ID: <Pine.LNX.4.44L0.1409171333310.1579-100000@iolanthe.rowland.org> (raw)
In-Reply-To: <1410967150-25240-5-git-send-email-pmladek@suse.cz>

On Wed, 17 Sep 2014, Petr Mladek wrote:

> USB hub has started to use a workqueue instead of kthread. Let's update
> the documentation and comments here and there.
> 
> This patch mostly just replaces "khubd" with "hub_wq". There are only few
> exceptions where the whole sentence was updated. These more complicated
> changes can be found in the following files:
> 
> 	   Documentation/usb/hotplug.txt
> 	   drivers/net/usb/usbnet.c
> 	   drivers/usb/core/hcd.c
> 	   drivers/usb/host/ohci-hcd.c
> 	   drivers/usb/host/xhci.c

Okay, here's a real issue.

> @@ -2042,7 +2042,7 @@ static void choose_devnum(struct usb_device *udev)
>  	int		devnum;
>  	struct usb_bus	*bus = udev->bus;
>  
> -	/* If khubd ever becomes multithreaded, this will need a lock */
> +	/* If hub_wq ever becomes multithreaded, this will need a lock */
>  	if (udev->wusb) {
>  		devnum = udev->portnum + 1;
>  		BUG_ON(test_bit(devnum, bus->devmap.devicemap));

You probably didn't notice when changing this comment.  But in fact,
workqueues _are_ multithreaded.  Therefore you need to add a lock to 
this routine.

Still, apart from these relatively minor issues, the series looks good.

Alan Stern


  reply	other threads:[~2014-09-17 17:36 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-09-17 15:19 [PATCH v2 0/4] usb: hub: convert khubd into workqueue Petr Mladek
2014-09-17 15:19 ` [PATCH v2 1/4] " Petr Mladek
2014-09-17 17:31   ` Alan Stern
2014-09-17 15:19 ` [PATCH v2 2/4] usb: hub: remove obsolete while cycle in hub_event() Petr Mladek
2014-09-17 17:33   ` Alan Stern
2014-09-17 15:19 ` [PATCH v2 3/4] usb: hub: rename usb_kick_khubd() to usb_kick_hub_wq() Petr Mladek
2014-09-17 15:19 ` [PATCH v2 4/4] usb: hub: rename khubd to hub_wq in documentation and comments Petr Mladek
2014-09-17 17:36   ` Alan Stern [this message]
2014-09-17 21:22     ` Tejun Heo
2014-09-18 14:24       ` Alan Stern
2014-09-18 16:15         ` Petr Mládek
2014-09-18 16:31           ` Tejun Heo
2014-09-18 17:21           ` Alan Stern

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=Pine.LNX.4.44L0.1409171333310.1579-100000@iolanthe.rowland.org \
    --to=stern@rowland.harvard.edu \
    --cc=gregkh@linuxfoundation.org \
    --cc=jkosina@suse.cz \
    --cc=joe.lawrence@stratus.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    --cc=pmladek@suse.cz \
    --cc=tj@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.