From mboxrd@z Thu Jan 1 00:00:00 1970 From: Fabrizio Castro Subject: RE: [RFC v4 13/26] watchdog: renesas_wdt: Add restart handler Date: Mon, 12 Feb 2018 11:38:41 +0000 Message-ID: References: <1517423070-24236-1-git-send-email-fabrizio.castro@bp.renesas.com> <1517423070-24236-14-git-send-email-fabrizio.castro@bp.renesas.com> <20180207230309.goxig2irkpxrw5el@katana> <20180212105456.3zejp3j7hfuzyc3c@ninjato> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: quoted-printable Return-path: In-Reply-To: <20180212105456.3zejp3j7hfuzyc3c@ninjato> Content-Language: en-US Sender: devicetree-owner-u79uwXL29TY76Z2rM5mHXA@public.gmane.org To: Wolfram Sang Cc: Philipp Zabel , Rob Herring , Mark Rutland , Wim Van Sebroeck , Russell King , Catalin Marinas , Will Deacon , Michael Turquette , Stephen Boyd , Simon Horman , Magnus Damm , Geert Uytterhoeven , Wolfram Sang , Guenter Roeck , "devicetree-u79uwXL29TY76Z2rM5mHXA@public.gmane.org" , "linux-watchdog-u79uwXL29TY76Z2rM5mHXA@public.gmane.org" , "linux-renesas-soc-u79uwXL29TY76Z2rM5mHXA@public.gmane.org" l List-Id: devicetree@vger.kernel.org > > > I used to have this simpler version (back then for the UP case): > > > > > > +rwdt_start(wdev); > > > +rwdt_write(priv, 0xffff, RWTCNT); > > > +return 0; > > > > > > It should still work probably... > > > > It should still work, but it would be slower, I would stick with the > > version I have submitted if you don't mind. > > Actually, I do mind. Because of code duplication reasons. We have a fix > in the works for rwdt_start() and it would be too easy to overlook the > same fix will be needed for a restart. The code is very similar indeed, but not exactly duplicated as it sets the = registers in order to reset the system as quickly as possible. But since you have strong feelings about this I'll reuse this other version= for the next submission. Thanks, Fabrizio Renesas Electronics Europe Ltd, Dukes Meadow, Millboard Road, Bourne End, B= uckinghamshire, SL8 5FH, UK. Registered in England & Wales under Registered= No. 04586709. -- To unsubscribe from this list: send the line "unsubscribe devicetree" in the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org More majordomo info at http://vger.kernel.org/majordomo-info.html From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from relmlor4.renesas.com ([210.160.252.174]:42036 "EHLO relmlie3.idc.renesas.com" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S934036AbeBLLis (ORCPT ); Mon, 12 Feb 2018 06:38:48 -0500 From: Fabrizio Castro To: Wolfram Sang CC: Philipp Zabel , Rob Herring , Mark Rutland , Wim Van Sebroeck , Russell King , Catalin Marinas , Will Deacon , "Michael Turquette" , Stephen Boyd , Simon Horman , Magnus Damm , "Geert Uytterhoeven" , Wolfram Sang , Guenter Roeck , "devicetree@vger.kernel.org" , "linux-watchdog@vger.kernel.org" , "linux-renesas-soc@vger.kernel.org" , "linux-arm-kernel@lists.infradead.org" , "linux-clk@vger.kernel.org" , Chris Paterson , Biju Das , Ramesh Shanmugasundaram Subject: RE: [RFC v4 13/26] watchdog: renesas_wdt: Add restart handler Date: Mon, 12 Feb 2018 11:38:41 +0000 Message-ID: References: <1517423070-24236-1-git-send-email-fabrizio.castro@bp.renesas.com> <1517423070-24236-14-git-send-email-fabrizio.castro@bp.renesas.com> <20180207230309.goxig2irkpxrw5el@katana> <20180212105456.3zejp3j7hfuzyc3c@ninjato> In-Reply-To: <20180212105456.3zejp3j7hfuzyc3c@ninjato> Content-Language: en-US Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: quoted-printable MIME-Version: 1.0 Sender: linux-watchdog-owner@vger.kernel.org List-Id: linux-watchdog@vger.kernel.org > > > I used to have this simpler version (back then for the UP case): > > > > > > +rwdt_start(wdev); > > > +rwdt_write(priv, 0xffff, RWTCNT); > > > +return 0; > > > > > > It should still work probably... > > > > It should still work, but it would be slower, I would stick with the > > version I have submitted if you don't mind. > > Actually, I do mind. Because of code duplication reasons. We have a fix > in the works for rwdt_start() and it would be too easy to overlook the > same fix will be needed for a restart. The code is very similar indeed, but not exactly duplicated as it sets the = registers in order to reset the system as quickly as possible. But since you have strong feelings about this I'll reuse this other version= for the next submission. Thanks, Fabrizio Renesas Electronics Europe Ltd, Dukes Meadow, Millboard Road, Bourne End, B= uckinghamshire, SL8 5FH, UK. Registered in England & Wales under Registered= No. 04586709. From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: From: Fabrizio Castro To: Wolfram Sang CC: Philipp Zabel , Rob Herring , Mark Rutland , Wim Van Sebroeck , Russell King , Catalin Marinas , Will Deacon , "Michael Turquette" , Stephen Boyd , Simon Horman , Magnus Damm , "Geert Uytterhoeven" , Wolfram Sang , Guenter Roeck , "devicetree@vger.kernel.org" , "linux-watchdog@vger.kernel.org" , "linux-renesas-soc@vger.kernel.org" , "linux-arm-kernel@lists.infradead.org" , "linux-clk@vger.kernel.org" , Chris Paterson , Biju Das , Ramesh Shanmugasundaram Subject: RE: [RFC v4 13/26] watchdog: renesas_wdt: Add restart handler Date: Mon, 12 Feb 2018 11:38:41 +0000 Message-ID: References: <1517423070-24236-1-git-send-email-fabrizio.castro@bp.renesas.com> <1517423070-24236-14-git-send-email-fabrizio.castro@bp.renesas.com> <20180207230309.goxig2irkpxrw5el@katana> <20180212105456.3zejp3j7hfuzyc3c@ninjato> In-Reply-To: <20180212105456.3zejp3j7hfuzyc3c@ninjato> Content-Type: text/plain; charset="us-ascii" MIME-Version: 1.0 List-ID: > > > I used to have this simpler version (back then for the UP case): > > > > > > +rwdt_start(wdev); > > > +rwdt_write(priv, 0xffff, RWTCNT); > > > +return 0; > > > > > > It should still work probably... > > > > It should still work, but it would be slower, I would stick with the > > version I have submitted if you don't mind. > > Actually, I do mind. Because of code duplication reasons. We have a fix > in the works for rwdt_start() and it would be too easy to overlook the > same fix will be needed for a restart. The code is very similar indeed, but not exactly duplicated as it sets the = registers in order to reset the system as quickly as possible. But since you have strong feelings about this I'll reuse this other version= for the next submission. Thanks, Fabrizio Renesas Electronics Europe Ltd, Dukes Meadow, Millboard Road, Bourne End, B= uckinghamshire, SL8 5FH, UK. Registered in England & Wales under Registered= No. 04586709. From mboxrd@z Thu Jan 1 00:00:00 1970 From: fabrizio.castro@bp.renesas.com (Fabrizio Castro) Date: Mon, 12 Feb 2018 11:38:41 +0000 Subject: [RFC v4 13/26] watchdog: renesas_wdt: Add restart handler In-Reply-To: <20180212105456.3zejp3j7hfuzyc3c@ninjato> References: <1517423070-24236-1-git-send-email-fabrizio.castro@bp.renesas.com> <1517423070-24236-14-git-send-email-fabrizio.castro@bp.renesas.com> <20180207230309.goxig2irkpxrw5el@katana> <20180212105456.3zejp3j7hfuzyc3c@ninjato> Message-ID: To: linux-arm-kernel@lists.infradead.org List-Id: linux-arm-kernel.lists.infradead.org > > > I used to have this simpler version (back then for the UP case): > > > > > > +rwdt_start(wdev); > > > +rwdt_write(priv, 0xffff, RWTCNT); > > > +return 0; > > > > > > It should still work probably... > > > > It should still work, but it would be slower, I would stick with the > > version I have submitted if you don't mind. > > Actually, I do mind. Because of code duplication reasons. We have a fix > in the works for rwdt_start() and it would be too easy to overlook the > same fix will be needed for a restart. The code is very similar indeed, but not exactly duplicated as it sets the registers in order to reset the system as quickly as possible. But since you have strong feelings about this I'll reuse this other version for the next submission. Thanks, Fabrizio Renesas Electronics Europe Ltd, Dukes Meadow, Millboard Road, Bourne End, Buckinghamshire, SL8 5FH, UK. Registered in England & Wales under Registered No. 04586709.