From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-15.8 required=3.0 tests=BAYES_00,DKIM_SIGNED, DKIM_VALID,DKIM_VALID_AU,HEADER_FROM_DIFFERENT_DOMAINS,INCLUDES_CR_TRAILER, INCLUDES_PATCH,MAILING_LIST_MULTI,SPF_HELO_NONE,SPF_PASS autolearn=unavailable autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id B957AC433DB for ; Thu, 24 Dec 2020 12:56:21 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id 83A66224B1 for ; Thu, 24 Dec 2020 12:56:21 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1728365AbgLXM4G (ORCPT ); Thu, 24 Dec 2020 07:56:06 -0500 Received: from perceval.ideasonboard.com ([213.167.242.64]:46316 "EHLO perceval.ideasonboard.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1728355AbgLXM4F (ORCPT ); Thu, 24 Dec 2020 07:56:05 -0500 Received: from pendragon.ideasonboard.com (62-78-145-57.bb.dnainternet.fi [62.78.145.57]) by perceval.ideasonboard.com (Postfix) with ESMTPSA id 89B6CA1D; Thu, 24 Dec 2020 13:55:22 +0100 (CET) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ideasonboard.com; s=mail; t=1608814522; bh=vdQrgqNa1TiikvlUXAcbMyAF84ZPZrALP2GLp8KKG18=; h=Date:From:To:Cc:Subject:References:In-Reply-To:From; b=hsNkO0Ehz7i1XDTGj0XDsADHRkgLU+aASLzYqYmQ/el3C8JR5UeK1QpF80Jhcp8Pk ofM7145UVyy7I9eyYhBHIA2yj1FTKSj0g8LcynBD4e9RGWSzyYzrGhLxVhSoWD+DP5 ZVM77eK7f+Vqo5czQfTENomCT+/D+aIJdyBgQNcs= Date: Thu, 24 Dec 2020 14:55:14 +0200 From: Laurent Pinchart To: Andy Shevchenko Cc: Daniel Scally , Linux Kernel Mailing List , ACPI Devel Maling List , Linux Media Mailing List , devel@acpica.org, "Rafael J. Wysocki" , Len Brown , Greg Kroah-Hartman , Yong Zhi , Sakari Ailus , Bingbu Cao , Tian Shu Qiu , Mauro Carvalho Chehab , Robert Moore , Erik Kaneda , Petr Mladek , Steven Rostedt , Sergey Senozhatsky , Andy Shevchenko , Rasmus Villemoes , Laurent Pinchart , Jacopo Mondi , kieran.bingham+renesas@ideasonboard.com, Hans Verkuil , Marco Felsch , niklas.soderlund+renesas@ragnatech.se, Steve Longerbeam , "Krogerus, Heikki" , Linus Walleij Subject: Re: [PATCH v3 07/14] software_node: Add support for fwnode_graph*() family of functions Message-ID: References: <20201224010907.263125-1-djrscally@gmail.com> <20201224010907.263125-8-djrscally@gmail.com> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline In-Reply-To: Precedence: bulk List-ID: X-Mailing-List: linux-acpi@vger.kernel.org Hi Andy, On Thu, Dec 24, 2020 at 02:24:12PM +0200, Andy Shevchenko wrote: > On Thu, Dec 24, 2020 at 3:14 AM Daniel Scally wrote: > > > > From: Heikki Krogerus > > > > This implements the remaining .graph_* callbacks in the > > .graph_* ==> ->graph_*() ? > > > fwnode operations structure for the software nodes. That makes > > the fwnode_graph*() functions available in the drivers also > > graph*() -> graph_*() ? > > > when software nodes are used. > > > > The implementation tries to mimic the "OF graph" as much as > > possible, but there is no support for the "reg" device > > property. The ports will need to have the index in their > > name which starts with "port@" (for example "port@0", "port@1", > > > ...) > > Looks not good, perhaps move to the previous line, or move port@1 example here? > > > and endpoints will use the index of the software node > > that is given to them during creation. The port nodes can > > also be grouped under a specially named "ports" subnode, > > just like in DT, if necessary. > > > > The remote-endpoints are reference properties under the > > endpoint nodes that are named "remote-endpoint". > > Few nitpicks here and there, after addressing them, > Reviewed-by: Andy Shevchenko > > > Signed-off-by: Heikki Krogerus > > Co-developed-by: Daniel Scally > > Signed-off-by: Daniel Scally > > --- > > Changes in v3 > > - Changed software_node_get_next_endpoint() to drop the variable > > named "old" > > - Used the macros defined in 06/14 instead of magic numbers > > - Added some comments to explain behaviour a little where it's unclear > > > > drivers/base/swnode.c | 112 +++++++++++++++++++++++++++++++++++++++++- > > 1 file changed, 111 insertions(+), 1 deletion(-) > > > > diff --git a/drivers/base/swnode.c b/drivers/base/swnode.c > > index 2d07eb04c6c8..ff690029060d 100644 > > --- a/drivers/base/swnode.c > > +++ b/drivers/base/swnode.c > > @@ -540,6 +540,112 @@ software_node_get_reference_args(const struct fwnode_handle *fwnode, > > return 0; > > } > > > > +static struct fwnode_handle * > > +swnode_graph_find_next_port(const struct fwnode_handle *parent, > > + struct fwnode_handle *port) > > +{ > > + struct fwnode_handle *old = port; > > + > > + while ((port = software_node_get_next_child(parent, old))) { > > + /* > > + * ports have naming style "port@n", so we search for children > > + * that follow that convention (but without assuming anything > > + * about the index number) > > + */ > > > + if (!strncmp(to_swnode(port)->node->name, "port@", > > You may use here corresponding _FMT macro. > > > + FWNODE_GRAPH_PORT_NAME_PREFIX_LEN)) > > + return port; > > + old = port; > > + } > > + > > + return NULL; > > +} > > + > > +static struct fwnode_handle * > > +software_node_graph_get_next_endpoint(const struct fwnode_handle *fwnode, > > + struct fwnode_handle *endpoint) > > +{ > > + struct swnode *swnode = to_swnode(fwnode); > > + struct fwnode_handle *parent; > > + struct fwnode_handle *port; > > + > > + if (!swnode) > > + return NULL; > > + > > + if (endpoint) { > > + port = software_node_get_parent(endpoint); > > + parent = software_node_get_parent(port); > > + } else { > > + parent = software_node_get_named_child_node(fwnode, "ports"); > > + if (!parent) > > + parent = software_node_get(&swnode->fwnode); > > + > > + port = swnode_graph_find_next_port(parent, NULL); > > + } > > + > > + for (; port; port = swnode_graph_find_next_port(parent, port)) { > > + endpoint = software_node_get_next_child(port, endpoint); > > + if (endpoint) { > > + fwnode_handle_put(port); > > + break; > > + } > > + } > > + > > + fwnode_handle_put(parent); > > + > > + return endpoint; > > +} > > + > > +static struct fwnode_handle * > > +software_node_graph_get_remote_endpoint(const struct fwnode_handle *fwnode) > > +{ > > + struct swnode *swnode = to_swnode(fwnode); > > + const struct software_node_ref_args *ref; > > + const struct property_entry *prop; > > + > > + if (!swnode) > > + return NULL; > > + > > + prop = property_entry_get(swnode->node->properties, "remote-endpoint"); > > + if (!prop || prop->type != DEV_PROP_REF || prop->is_inline) > > + return NULL; > > + > > + ref = prop->pointer; > > + > > + return software_node_get(software_node_fwnode(ref[0].node)); > > +} > > + > > +static struct fwnode_handle * > > +software_node_graph_get_port_parent(struct fwnode_handle *fwnode) > > +{ > > + struct swnode *swnode = to_swnode(fwnode); > > + > > + swnode = swnode->parent; > > + if (swnode && !strcmp(swnode->node->name, "ports")) > > + swnode = swnode->parent; > > + > > + return swnode ? software_node_get(&swnode->fwnode) : NULL; > > +} > > + > > +static int > > +software_node_graph_parse_endpoint(const struct fwnode_handle *fwnode, > > + struct fwnode_endpoint *endpoint) > > +{ > > + struct swnode *swnode = to_swnode(fwnode); > > + int ret; > > + > > + /* Ports have naming style "port@n", we need to select the n */ > > > + ret = kstrtou32(swnode->parent->node->name + FWNODE_GRAPH_PORT_NAME_PREFIX_LEN, > > Maybe a temporary variable? > > unsigned int prefix_len = FWNODE_GRAPH_PORT_NAME_PREFIX_LEN; > ... > ret = kstrtou32(swnode->parent->node->name + prefix_len, Honestly I'm wondering if those macros don't hinder readability. I'd rather write + strlen("port@") and let the compiler optimize this to a compile-time constant. > > + 10, &endpoint->port); > > + if (ret) > > + return ret; > > + > > + endpoint->id = swnode->id; > > + endpoint->local_fwnode = fwnode; > > + > > + return 0; > > +} > > + > > static const struct fwnode_operations software_node_ops = { > > .get = software_node_get, > > .put = software_node_put, > > @@ -551,7 +657,11 @@ static const struct fwnode_operations software_node_ops = { > > .get_parent = software_node_get_parent, > > .get_next_child_node = software_node_get_next_child, > > .get_named_child_node = software_node_get_named_child_node, > > - .get_reference_args = software_node_get_reference_args > > + .get_reference_args = software_node_get_reference_args, > > + .graph_get_next_endpoint = software_node_graph_get_next_endpoint, > > + .graph_get_remote_endpoint = software_node_graph_get_remote_endpoint, > > + .graph_get_port_parent = software_node_graph_get_port_parent, > > + .graph_parse_endpoint = software_node_graph_parse_endpoint, > > }; > > > > /* -------------------------------------------------------------------------- */ -- Regards, Laurent Pinchart