Hi, a few remarks below. On Fri, Apr 02, 2021 at 01:03:58AM +0200, Giulio Benetti wrote: > This patch adds support for Hycon HY46XX. > > Signed-off-by: Giulio Benetti > --- > V1->V2: > * removed proximity-sensor-switch property according to previous patch > As suggested by Dmitry Torokhov > * moved i2c communaction to regmap use > * added macro to avoid magic number > * removed cmd variable that could uninitiliazed since we're using regmap now > * removed useless byte masking > * removed useless struct hycon_hy46xx_i2c_chip_data > * used IRQF_ONESHOT only for isr > --- > +config TOUCHSCREEN_HYCON_HY46XX > + tristate "Hycon hy46xx touchscreen support" > + depends on I2C > + help > + Say Y here if you have a touchscreen using Hycon hy46xx, > + or something similar enough. The "something similar enough" part doesn't seem relevant, because the driver only lists HY46xx chips (in the compatible strings), and no chips that are similar enough to work with the driver, but have a different part number. > +static void hycon_hy46xx_get_defaults(struct device *dev, struct hycon_hy46xx_data *tsdata) > +{ > + bool val_bool; > + int error; > + u32 val; > + > + error = device_property_read_u32(dev, "threshold", &val); This seems to follow the old version of the binding, where Hycon-specific properties didn't have the "hycon," prefix. Please check that the driver still works with a devicetree that follows the newest version of the binding. > +MODULE_AUTHOR("Giulio Benetti "); This is a different email address than you used in the DT binding. If this is intentional, no problem (Just letting you know, in case it's unintentional). Thanks, Jonathan Neuschäfer