From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-5.8 required=3.0 tests=BAYES_00,DKIM_SIGNED, DKIM_VALID,DKIM_VALID_AU,HEADER_FROM_DIFFERENT_DOMAINS,MAILING_LIST_MULTI, SPF_HELO_NONE,SPF_PASS autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 1DFAEC4707F for ; Thu, 27 May 2021 06:36:37 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id E364C61355 for ; Thu, 27 May 2021 06:36:36 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S233081AbhE0GiH (ORCPT ); Thu, 27 May 2021 02:38:07 -0400 Received: from lindbergh.monkeyblade.net ([23.128.96.19]:52864 "EHLO lindbergh.monkeyblade.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S229579AbhE0GiB (ORCPT ); Thu, 27 May 2021 02:38:01 -0400 Received: from casper.infradead.org (casper.infradead.org [IPv6:2001:8b0:10b:1236::1]) by lindbergh.monkeyblade.net (Postfix) with ESMTPS id 60576C061574 for ; Wed, 26 May 2021 23:36:29 -0700 (PDT) DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=infradead.org; s=casper.20170209; h=In-Reply-To:Content-Type:MIME-Version: References:Message-ID:Subject:Cc:To:From:Date:Sender:Reply-To: Content-Transfer-Encoding:Content-ID:Content-Description; bh=Bra5u3q0nsTT2vClh1YptF/HJcbKPIZLi7Sa4klMJfI=; b=IBy/VCryTi7VtzKxkz81CM2fSz 6Gv2/3624/KD2qw0+jN5QG2zDbACp2FdQF7vdOFJnK72ZSwHl+Up2O0G2JgB527NaM6ZvXDY3aHo1 SFqYJKBJVByeJ8pLCj9I8BT0MtthLCirHCS8ccOA3QqsrKm3vIRP1WWRYE6Wow4JTIlu/q+G2uzYf 8OcY0kMWXl7Ngr4nFPwWXqd4CZHQ9d5xbZnDnL9Tn2yRLBeA9/CHFBP27TeTVQvWej3O4nHuuouLX EWu2c+P5n95Zok0U17cqDg5VysFsfI5F6hdTdt+dRkfH+sdHQ624eN34qdhHp+x8HZdZ3vGrbXdeo nBuFTR1g==; Received: from hch by casper.infradead.org with local (Exim 4.94 #2 (Red Hat Linux)) id 1lm9cX-005FUj-Q3; Thu, 27 May 2021 06:35:56 +0000 Date: Thu, 27 May 2021 07:35:53 +0100 From: Christoph Hellwig To: Alexandre Ghiti Cc: Paul Walmsley , Palmer Dabbelt , Albert Ou , Jisheng Zhang , Zong Li , Anup Patel , linux-riscv@lists.infradead.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH v2] riscv: Map the kernel with correct permissions the first time Message-ID: References: <20210526134110.217073-1-alex@ghiti.fr> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20210526134110.217073-1-alex@ghiti.fr> X-SRS-Rewrite: SMTP reverse-path rewritten from by casper.infradead.org. See http://www.infradead.org/rpr.html Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, May 26, 2021 at 03:41:10PM +0200, Alexandre Ghiti wrote: > #ifdef CONFIG_64BIT > +#define is_kernel_mapping(x) ((x) >= kernel_virt_addr && (x) < (kernel_virt_addr + load_sz)) > +#define is_linear_mapping(x) ((x) >= PAGE_OFFSET && (x) < kernel_virt_addr) > + Overly long lines. Independ of that complex macros are generally much more readable if they are written more function-like, that is the name and paramtes are kept on a line of their own: #define is_kernel_mapping(x) \ ((x) >= kernel_virt_addr && (x) < (kernel_virt_addr + load_sz)) But what is the reason to not make them type-safe inline functions anyway? > #define __va_to_pa_nodebug(x) ({ \ > unsigned long _x = x; \ > - (_x < kernel_virt_addr) ? \ > + is_linear_mapping(_x) ? \ > linear_mapping_va_to_pa(_x) : kernel_mapping_va_to_pa(_x); \ > }) ... especially for something complex like this. > +static inline bool is_va_kernel_lm_alias_text(uintptr_t va) > +{ > + return (va >= (uintptr_t)lm_alias(_start) && va < (uintptr_t)lm_alias(__init_text_begin)); Overly long line as well. And useless braces. > +static inline bool is_va_kernel_init_text(uintptr_t va) > +{ > + return (va >= (uintptr_t)__init_text_begin && va < (uintptr_t)__init_data_begin); > +} Same here. > +#ifdef CONFIG_STRICT_KERNEL_RWX > +static __init pgprot_t pgprot_from_va(uintptr_t va) > +{ > +#ifdef CONFIG_64BIT > + if (is_va_kernel_text(va) || is_va_kernel_init_text(va)) > + return PAGE_KERNEL_READ_EXEC; > + > + /* > + * We must mark only text as read-only as init text will get freed later > + * and rodata section is marked readonly in mark_rodata_ro. > + */ > + if (is_va_kernel_lm_alias_text(va)) > + return PAGE_KERNEL_READ; > + > + return PAGE_KERNEL; > +#else > + if (is_va_kernel_text(va)) > + return PAGE_KERNEL_READ_EXEC; > + > + if (is_va_kernel_init_text(va)) > + return PAGE_KERNEL_EXEC; > + > + return PAGE_KERNEL; > +#endif /* CONFIG_64BIT */ > +} If the entire function is different for config symbols please just split it into two separate functions. But to make the difference more clear IS_ENABLED might fit better here: static __init pgprot_t pgprot_from_va(uintptr_t va) { if (is_va_kernel_text(va)) return PAGE_KERNEL_READ_EXEC; if (is_va_kernel_init_text(va)) return IS_ENABLED(CONFIG_64BIT) ? PAGE_KERNEL_READ_EXEC : PAGE_KERNEL_EXEC; if (IS_ENABLED(CONFIG_64BIT) && is_va_kernel_lm_alias_text(va)) return PAGE_KERNEL_READ; return PAGE_KERNEL; } Preferable with comments explaining the 32-bit vs 64-bit difference. > +void mark_rodata_ro(void) > +{ > + unsigned long rodata_start = (unsigned long)__start_rodata; > + unsigned long data_start = (unsigned long)_data; > + unsigned long __maybe_unused lm_rodata_start = (unsigned long)lm_alias(__start_rodata); > + unsigned long __maybe_unused lm_data_start = (unsigned long)lm_alias(_data); > + > + set_memory_ro(rodata_start, (data_start - rodata_start) >> PAGE_SHIFT); > +#ifdef CONFIG_64BIT > + set_memory_ro(lm_rodata_start, (lm_data_start - lm_rodata_start) >> PAGE_SHIFT); > +#endif Lots of unreadable overly lone lines. Why not add a helper and do something like: static void set_kernel_memory_ro(char *startp, char *endp) { unsigned long start = (unsigned long)startp; unsigned long end = (unsigned long)endp; set_memory_ro(start, (start - end) >> PAGE_SHIFT); } set_kernel_memory_ro(_start_rodata, _data); if (IS_ENABLED(CONFIG_64BIT)) set_kernel_memory_ro(lm_alias(__start_rodata), lm_alias(_data)); > +static __init pgprot_t pgprot_from_va(uintptr_t va) > +{ > +#ifdef CONFIG_64BIT > + if (is_kernel_mapping(va)) > + return PAGE_KERNEL_EXEC; > + > + if (is_linear_mapping(va)) > + return PAGE_KERNEL; > + > + return PAGE_KERNEL; > +#else > + return PAGE_KERNEL_EXEC; > +#endif /* CONFIG_64BIT */ > +} > +#endif /* CONFIG_STRICT_KERNEL_RWX */ > + Same comment as for the other version. This could become: static __init pgprot_t pgprot_from_va(uintptr_t va) { if (IS_ENABLED(CONFIG_64BIT) && !is_kernel_mapping(va)) return PAGE_KERNEL; return PAGE_KERNEL_EXEC; } > -static void __init create_kernel_page_table(pgd_t *pgdir, uintptr_t map_size) > +static void __init create_kernel_page_table(pgd_t *pgdir, uintptr_t map_size, bool early) Overly long line. > for (va = kernel_virt_addr; va < end_va; va += map_size) > create_pgd_mapping(pgdir, va, > load_pa + (va - kernel_virt_addr), > - map_size, PAGE_KERNEL_EXEC); > + map_size, early ? PAGE_KERNEL_EXEC : pgprot_from_va(va)); Same here. But why not pass in a "pgprot_t ram_pgprot" instead of the bool, which would be self-documenting. From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-4.1 required=3.0 tests=BAYES_00,DKIMWL_WL_HIGH, DKIM_SIGNED,DKIM_VALID,HEADER_FROM_DIFFERENT_DOMAINS,MAILING_LIST_MULTI, SPF_HELO_NONE,SPF_PASS,URIBL_BLOCKED autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 81710C4708A for ; Thu, 27 May 2021 06:36:38 +0000 (UTC) Received: from bombadil.infradead.org (bombadil.infradead.org [198.137.202.133]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by mail.kernel.org (Postfix) with ESMTPS id 94E2C6113B for ; Thu, 27 May 2021 06:36:35 +0000 (UTC) DMARC-Filter: OpenDMARC Filter v1.3.2 mail.kernel.org 94E2C6113B Authentication-Results: mail.kernel.org; dmarc=none (p=none dis=none) header.from=infradead.org Authentication-Results: mail.kernel.org; spf=none smtp.mailfrom=linux-riscv-bounces+linux-riscv=archiver.kernel.org@lists.infradead.org DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=lists.infradead.org; s=bombadil.20210309; h=Sender: Content-Transfer-Encoding:Content-Type:List-Subscribe:List-Help:List-Post: List-Archive:List-Unsubscribe:List-Id:In-Reply-To:MIME-Version:References: Message-ID:Subject:Cc:To:From:Date:Reply-To:Content-ID:Content-Description: Resent-Date:Resent-From:Resent-Sender:Resent-To:Resent-Cc:Resent-Message-ID: List-Owner; bh=/bEIkQiG3tlgzlc0c6GiOwxl0axhaY8Se64CyUVAcSM=; b=0ND00ru14UG5xI sWBZhMT5dhISvHB5elT4PyawXyWkcHn+oWLjAHa10zpGYoOm/pj74Q47YkLX7fwycXsqyZKRuGwND In2kZVFvfm5iMpd17aThJe6IkiLf6HhD1j79fJYP1xLj2PoQXDf/Io1W+OT9lQQSgrxMMHeOQHRnH w9tNTZjy5hfLP14OKRtNSYsYglIzV2PLBpeNUkRSexi60LFX0RDN5iBY9BrsasMGxnGWS4HGPjvQY liHPmkL9OWe147WXP29s7JuobZIQ2bwTHqSxu5+HBYKvS6GIzelvHefAGPCSaETp7CczGrbhNbHoS ljMyAUbDbpsyGnnvWPOg==; Received: from localhost ([::1] helo=bombadil.infradead.org) by bombadil.infradead.org with esmtp (Exim 4.94.2 #2 (Red Hat Linux)) id 1lm9cn-0033IM-JZ; Thu, 27 May 2021 06:36:09 +0000 Received: from casper.infradead.org ([2001:8b0:10b:1236::1]) by bombadil.infradead.org with esmtps (Exim 4.94.2 #2 (Red Hat Linux)) id 1lm9cg-0033Hg-Mw for linux-riscv@bombadil.infradead.org; Thu, 27 May 2021 06:36:02 +0000 DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=infradead.org; s=casper.20170209; h=In-Reply-To:Content-Type:MIME-Version: References:Message-ID:Subject:Cc:To:From:Date:Sender:Reply-To: Content-Transfer-Encoding:Content-ID:Content-Description; bh=Bra5u3q0nsTT2vClh1YptF/HJcbKPIZLi7Sa4klMJfI=; b=IBy/VCryTi7VtzKxkz81CM2fSz 6Gv2/3624/KD2qw0+jN5QG2zDbACp2FdQF7vdOFJnK72ZSwHl+Up2O0G2JgB527NaM6ZvXDY3aHo1 SFqYJKBJVByeJ8pLCj9I8BT0MtthLCirHCS8ccOA3QqsrKm3vIRP1WWRYE6Wow4JTIlu/q+G2uzYf 8OcY0kMWXl7Ngr4nFPwWXqd4CZHQ9d5xbZnDnL9Tn2yRLBeA9/CHFBP27TeTVQvWej3O4nHuuouLX EWu2c+P5n95Zok0U17cqDg5VysFsfI5F6hdTdt+dRkfH+sdHQ624eN34qdhHp+x8HZdZ3vGrbXdeo nBuFTR1g==; Received: from hch by casper.infradead.org with local (Exim 4.94 #2 (Red Hat Linux)) id 1lm9cX-005FUj-Q3; Thu, 27 May 2021 06:35:56 +0000 Date: Thu, 27 May 2021 07:35:53 +0100 From: Christoph Hellwig To: Alexandre Ghiti Cc: Paul Walmsley , Palmer Dabbelt , Albert Ou , Jisheng Zhang , Zong Li , Anup Patel , linux-riscv@lists.infradead.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH v2] riscv: Map the kernel with correct permissions the first time Message-ID: References: <20210526134110.217073-1-alex@ghiti.fr> MIME-Version: 1.0 Content-Disposition: inline In-Reply-To: <20210526134110.217073-1-alex@ghiti.fr> X-SRS-Rewrite: SMTP reverse-path rewritten from by casper.infradead.org. See http://www.infradead.org/rpr.html X-BeenThere: linux-riscv@lists.infradead.org X-Mailman-Version: 2.1.34 Precedence: list List-Id: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Sender: "linux-riscv" Errors-To: linux-riscv-bounces+linux-riscv=archiver.kernel.org@lists.infradead.org On Wed, May 26, 2021 at 03:41:10PM +0200, Alexandre Ghiti wrote: > #ifdef CONFIG_64BIT > +#define is_kernel_mapping(x) ((x) >= kernel_virt_addr && (x) < (kernel_virt_addr + load_sz)) > +#define is_linear_mapping(x) ((x) >= PAGE_OFFSET && (x) < kernel_virt_addr) > + Overly long lines. Independ of that complex macros are generally much more readable if they are written more function-like, that is the name and paramtes are kept on a line of their own: #define is_kernel_mapping(x) \ ((x) >= kernel_virt_addr && (x) < (kernel_virt_addr + load_sz)) But what is the reason to not make them type-safe inline functions anyway? > #define __va_to_pa_nodebug(x) ({ \ > unsigned long _x = x; \ > - (_x < kernel_virt_addr) ? \ > + is_linear_mapping(_x) ? \ > linear_mapping_va_to_pa(_x) : kernel_mapping_va_to_pa(_x); \ > }) ... especially for something complex like this. > +static inline bool is_va_kernel_lm_alias_text(uintptr_t va) > +{ > + return (va >= (uintptr_t)lm_alias(_start) && va < (uintptr_t)lm_alias(__init_text_begin)); Overly long line as well. And useless braces. > +static inline bool is_va_kernel_init_text(uintptr_t va) > +{ > + return (va >= (uintptr_t)__init_text_begin && va < (uintptr_t)__init_data_begin); > +} Same here. > +#ifdef CONFIG_STRICT_KERNEL_RWX > +static __init pgprot_t pgprot_from_va(uintptr_t va) > +{ > +#ifdef CONFIG_64BIT > + if (is_va_kernel_text(va) || is_va_kernel_init_text(va)) > + return PAGE_KERNEL_READ_EXEC; > + > + /* > + * We must mark only text as read-only as init text will get freed later > + * and rodata section is marked readonly in mark_rodata_ro. > + */ > + if (is_va_kernel_lm_alias_text(va)) > + return PAGE_KERNEL_READ; > + > + return PAGE_KERNEL; > +#else > + if (is_va_kernel_text(va)) > + return PAGE_KERNEL_READ_EXEC; > + > + if (is_va_kernel_init_text(va)) > + return PAGE_KERNEL_EXEC; > + > + return PAGE_KERNEL; > +#endif /* CONFIG_64BIT */ > +} If the entire function is different for config symbols please just split it into two separate functions. But to make the difference more clear IS_ENABLED might fit better here: static __init pgprot_t pgprot_from_va(uintptr_t va) { if (is_va_kernel_text(va)) return PAGE_KERNEL_READ_EXEC; if (is_va_kernel_init_text(va)) return IS_ENABLED(CONFIG_64BIT) ? PAGE_KERNEL_READ_EXEC : PAGE_KERNEL_EXEC; if (IS_ENABLED(CONFIG_64BIT) && is_va_kernel_lm_alias_text(va)) return PAGE_KERNEL_READ; return PAGE_KERNEL; } Preferable with comments explaining the 32-bit vs 64-bit difference. > +void mark_rodata_ro(void) > +{ > + unsigned long rodata_start = (unsigned long)__start_rodata; > + unsigned long data_start = (unsigned long)_data; > + unsigned long __maybe_unused lm_rodata_start = (unsigned long)lm_alias(__start_rodata); > + unsigned long __maybe_unused lm_data_start = (unsigned long)lm_alias(_data); > + > + set_memory_ro(rodata_start, (data_start - rodata_start) >> PAGE_SHIFT); > +#ifdef CONFIG_64BIT > + set_memory_ro(lm_rodata_start, (lm_data_start - lm_rodata_start) >> PAGE_SHIFT); > +#endif Lots of unreadable overly lone lines. Why not add a helper and do something like: static void set_kernel_memory_ro(char *startp, char *endp) { unsigned long start = (unsigned long)startp; unsigned long end = (unsigned long)endp; set_memory_ro(start, (start - end) >> PAGE_SHIFT); } set_kernel_memory_ro(_start_rodata, _data); if (IS_ENABLED(CONFIG_64BIT)) set_kernel_memory_ro(lm_alias(__start_rodata), lm_alias(_data)); > +static __init pgprot_t pgprot_from_va(uintptr_t va) > +{ > +#ifdef CONFIG_64BIT > + if (is_kernel_mapping(va)) > + return PAGE_KERNEL_EXEC; > + > + if (is_linear_mapping(va)) > + return PAGE_KERNEL; > + > + return PAGE_KERNEL; > +#else > + return PAGE_KERNEL_EXEC; > +#endif /* CONFIG_64BIT */ > +} > +#endif /* CONFIG_STRICT_KERNEL_RWX */ > + Same comment as for the other version. This could become: static __init pgprot_t pgprot_from_va(uintptr_t va) { if (IS_ENABLED(CONFIG_64BIT) && !is_kernel_mapping(va)) return PAGE_KERNEL; return PAGE_KERNEL_EXEC; } > -static void __init create_kernel_page_table(pgd_t *pgdir, uintptr_t map_size) > +static void __init create_kernel_page_table(pgd_t *pgdir, uintptr_t map_size, bool early) Overly long line. > for (va = kernel_virt_addr; va < end_va; va += map_size) > create_pgd_mapping(pgdir, va, > load_pa + (va - kernel_virt_addr), > - map_size, PAGE_KERNEL_EXEC); > + map_size, early ? PAGE_KERNEL_EXEC : pgprot_from_va(va)); Same here. But why not pass in a "pgprot_t ram_pgprot" instead of the bool, which would be self-documenting. _______________________________________________ linux-riscv mailing list linux-riscv@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-riscv