On Wed, Aug 25, 2021 at 10:26:28AM -0400, Derrick Stolee wrote: > On 8/24/2021 6:37 AM, Patrick Steinhardt wrote: > > - if (ret) { > > - transport_unlock_pack(transport); > > - return ret; > > - } > > + if (ret) > > + goto out; > > You were just reorganizing this method in the previous patch. > This "goto out" trick could have applied there instead, which > wouldn't complicate that patch and would simplify this one. > > But perhaps it would look strange to have the following ending > to the method, even if for only one patch: > > return 0; > > out: > transport_unlock_pack(transport); > return res; > } > > So, feel free to ignore me here. Decide based on your taste. I think you've got a point, I'll change this. Patrick