On Thu, Aug 12, 2021 at 02:06:01PM -0500, madvenka@linux.microsoft.com wrote: > Renaming of unwinder functions > ============================== > Rename unwinder functions to unwind_*() similar to other architectures > for naming consistency. More on this below. This feels like it could probably do with splitting up a bit for reviewability, several of these headers you've got in the commit logs look like they could be separate commits. Splitting things up does help with reviewability, having only one change to keep in mind at once is a lot less cognative load. > Replace walk_stackframe() with unwind() > ======================================= > > walk_stackframe() contains the unwinder loop that walks the stack > frames. Currently, start_backtrace() and walk_stackframe() are called > separately. They should be combined in the same function. Also, the > loop in walk_stackframe() should be simplified and should look like > the unwind loops in other architectures such as X86 and S390. This definitely seems like a separate change.