All of lore.kernel.org
 help / color / mirror / Atom feed
From: Yonghong Song <yhs@fb.com>
To: Christoph Hellwig <hch@lst.de>
Cc: Andrew Morton <akpm@linux-foundation.org>, <x86@kernel.org>,
	Alexei Starovoitov <ast@kernel.org>,
	Daniel Borkmann <daniel@iogearbox.net>,
	Masami Hiramatsu <mhiramat@kernel.org>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	<linux-parisc@vger.kernel.org>, <linux-um@lists.infradead.org>,
	<netdev@vger.kernel.org>, <bpf@vger.kernel.org>,
	<linux-mm@kvack.org>, <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 12/23] bpf: handle the compat string in bpf_trace_copy_string better
Date: Thu, 28 May 2020 10:06:17 -0700	[thread overview]
Message-ID: <a1aa26f4-8c0a-5f8a-8460-6d61f167702d@fb.com> (raw)
In-Reply-To: <20200528043957.GA28494@lst.de>



On 5/27/20 9:39 PM, Christoph Hellwig wrote:
> On Wed, May 27, 2020 at 07:26:30PM -0700, Yonghong Song wrote:
>>> --- a/kernel/trace/bpf_trace.c~xxx
>>> +++ a/kernel/trace/bpf_trace.c
>>> @@ -588,15 +588,22 @@ BPF_CALL_5(bpf_seq_printf, struct seq_fi
>>>    		}
>>>      		if (fmt[i] == 's') {
>>> +			void *unsafe_ptr;
>>> +
>>>    			/* try our best to copy */
>>>    			if (memcpy_cnt >= MAX_SEQ_PRINTF_MAX_MEMCPY) {
>>>    				err = -E2BIG;
>>>    				goto out;
>>>    			}
>>>    -			err = strncpy_from_unsafe(bufs->buf[memcpy_cnt],
>>> -						  (void *) (long) args[fmt_cnt],
>>> -						  MAX_SEQ_PRINTF_STR_LEN);
>>> +			unsafe_ptr = (void *)(long)args[fmt_cnt];
>>> +			if ((unsigned long)unsafe_ptr < TASK_SIZE) {
>>> +				err = strncpy_from_user_nofault(
>>> +					bufs->buf[memcpy_cnt], unsafe_ptr,
>>> +					MAX_SEQ_PRINTF_STR_LEN);
>>> +			} else {
>>> +				err = -EFAULT;
>>> +			}
>>
>> This probably not right.
>> The pointer stored at args[fmt_cnt] is a kernel pointer,
>> but it could be an invalid address and we do not want to fault.
>> Not sure whether it exists or not, we should use
>> strncpy_from_kernel_nofault()?
> 
> If you know it is a kernel pointer with this series it should be
> strncpy_from_kernel_nofault.  But even before the series it should have
> been strncpy_from_unsafe_strict.

The use of strncpy_from_unsafe() mimics old bpf_trace_printk() 
implementation which just changed to _strict version:
https://lkml.org/lkml/2020/5/18/1309

Agreed that we should change to strncpy_from_unsafe_strict().
I can submit a patch for this.

Thanks!

WARNING: multiple messages have this Message-ID (diff)
From: Yonghong Song <yhs@fb.com>
To: Christoph Hellwig <hch@lst.de>
Cc: linux-parisc@vger.kernel.org,
	Daniel Borkmann <daniel@iogearbox.net>,
	netdev@vger.kernel.org, x86@kernel.org,
	linux-um@lists.infradead.org, Alexei Starovoitov <ast@kernel.org>,
	linux-kernel@vger.kernel.org, linux-mm@kvack.org,
	Masami Hiramatsu <mhiramat@kernel.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	bpf@vger.kernel.org
Subject: Re: [PATCH 12/23] bpf: handle the compat string in bpf_trace_copy_string better
Date: Thu, 28 May 2020 10:06:17 -0700	[thread overview]
Message-ID: <a1aa26f4-8c0a-5f8a-8460-6d61f167702d@fb.com> (raw)
In-Reply-To: <20200528043957.GA28494@lst.de>



On 5/27/20 9:39 PM, Christoph Hellwig wrote:
> On Wed, May 27, 2020 at 07:26:30PM -0700, Yonghong Song wrote:
>>> --- a/kernel/trace/bpf_trace.c~xxx
>>> +++ a/kernel/trace/bpf_trace.c
>>> @@ -588,15 +588,22 @@ BPF_CALL_5(bpf_seq_printf, struct seq_fi
>>>    		}
>>>      		if (fmt[i] == 's') {
>>> +			void *unsafe_ptr;
>>> +
>>>    			/* try our best to copy */
>>>    			if (memcpy_cnt >= MAX_SEQ_PRINTF_MAX_MEMCPY) {
>>>    				err = -E2BIG;
>>>    				goto out;
>>>    			}
>>>    -			err = strncpy_from_unsafe(bufs->buf[memcpy_cnt],
>>> -						  (void *) (long) args[fmt_cnt],
>>> -						  MAX_SEQ_PRINTF_STR_LEN);
>>> +			unsafe_ptr = (void *)(long)args[fmt_cnt];
>>> +			if ((unsigned long)unsafe_ptr < TASK_SIZE) {
>>> +				err = strncpy_from_user_nofault(
>>> +					bufs->buf[memcpy_cnt], unsafe_ptr,
>>> +					MAX_SEQ_PRINTF_STR_LEN);
>>> +			} else {
>>> +				err = -EFAULT;
>>> +			}
>>
>> This probably not right.
>> The pointer stored at args[fmt_cnt] is a kernel pointer,
>> but it could be an invalid address and we do not want to fault.
>> Not sure whether it exists or not, we should use
>> strncpy_from_kernel_nofault()?
> 
> If you know it is a kernel pointer with this series it should be
> strncpy_from_kernel_nofault.  But even before the series it should have
> been strncpy_from_unsafe_strict.

The use of strncpy_from_unsafe() mimics old bpf_trace_printk() 
implementation which just changed to _strict version:
https://lkml.org/lkml/2020/5/18/1309

Agreed that we should change to strncpy_from_unsafe_strict().
I can submit a patch for this.

Thanks!

_______________________________________________
linux-um mailing list
linux-um@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-um


  reply	other threads:[~2020-05-28 17:07 UTC|newest]

Thread overview: 80+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-05-21 15:22 clean up and streamline probe_kernel_* and friends v4 Christoph Hellwig
2020-05-21 15:22 ` Christoph Hellwig
2020-05-21 15:22 ` [PATCH 01/23] maccess: unexport probe_kernel_write and probe_user_write Christoph Hellwig
2020-05-21 15:22   ` Christoph Hellwig
2020-05-21 15:22 ` [PATCH 02/23] maccess: remove various unused weak aliases Christoph Hellwig
2020-05-21 15:22   ` Christoph Hellwig
2020-05-21 15:22 ` [PATCH 03/23] maccess: remove duplicate kerneldoc comments Christoph Hellwig
2020-05-21 15:22   ` Christoph Hellwig
2020-05-21 15:22 ` [PATCH 04/23] maccess: clarify " Christoph Hellwig
2020-05-21 15:22   ` Christoph Hellwig
2020-05-21 15:22 ` [PATCH 05/23] maccess: update the top of file comment Christoph Hellwig
2020-05-21 15:22   ` Christoph Hellwig
2020-05-21 15:22 ` [PATCH 06/23] maccess: rename strncpy_from_unsafe_user to strncpy_from_user_nofault Christoph Hellwig
2020-05-21 15:22   ` Christoph Hellwig
2020-05-21 15:22 ` [PATCH 07/23] maccess: rename strncpy_from_unsafe_strict to strncpy_from_kernel_nofault Christoph Hellwig
2020-05-21 15:22   ` Christoph Hellwig
2020-05-21 15:22 ` [PATCH 08/23] maccess: rename strnlen_unsafe_user to strnlen_user_nofault Christoph Hellwig
2020-05-21 15:22   ` Christoph Hellwig
2020-05-21 15:22 ` [PATCH 09/23] maccess: remove probe_read_common and probe_write_common Christoph Hellwig
2020-05-21 15:22   ` Christoph Hellwig
2020-05-21 15:22 ` [PATCH 10/23] maccess: unify the probe kernel arch hooks Christoph Hellwig
2020-05-21 15:22   ` Christoph Hellwig
2020-05-28  0:55   ` Andrew Morton
2020-05-28  0:55     ` Andrew Morton
2020-05-21 15:22 ` [PATCH 11/23] bpf: factor out a bpf_trace_copy_string helper Christoph Hellwig
2020-05-21 15:22   ` Christoph Hellwig
2020-05-21 22:10   ` Andrii Nakryiko
2020-05-21 22:10     ` Andrii Nakryiko
2020-05-21 22:10     ` Andrii Nakryiko
2020-05-21 15:22 ` [PATCH 12/23] bpf: handle the compat string in bpf_trace_copy_string better Christoph Hellwig
2020-05-21 15:22   ` Christoph Hellwig
2020-05-21 22:10   ` Andrii Nakryiko
2020-05-21 22:10     ` Andrii Nakryiko
2020-05-21 22:10     ` Andrii Nakryiko
2020-05-28  2:04   ` Andrew Morton
2020-05-28  2:04     ` Andrew Morton
2020-05-28  2:26     ` Yonghong Song
2020-05-28  2:26       ` Yonghong Song
2020-05-28  4:39       ` Christoph Hellwig
2020-05-28  4:39         ` Christoph Hellwig
2020-05-28 17:06         ` Yonghong Song [this message]
2020-05-28 17:06           ` Yonghong Song
2020-05-21 15:22 ` [PATCH 13/23] bpf: rework the compat kernel probe handling Christoph Hellwig
2020-05-21 15:22   ` Christoph Hellwig
2020-05-21 22:10   ` Andrii Nakryiko
2020-05-21 22:10     ` Andrii Nakryiko
2020-05-21 22:10     ` Andrii Nakryiko
2020-05-21 15:22 ` [PATCH 14/23] tracing/kprobes: handle mixed kernel/userspace probes better Christoph Hellwig
2020-05-21 15:22   ` Christoph Hellwig
2020-05-22  0:04   ` Masami Hiramatsu
2020-05-22  0:04     ` Masami Hiramatsu
2020-05-21 15:22 ` [PATCH 15/23] maccess: remove strncpy_from_unsafe Christoph Hellwig
2020-05-21 15:22   ` Christoph Hellwig
2020-05-21 15:22 ` [PATCH 16/23] maccess: always use strict semantics for probe_kernel_read Christoph Hellwig
2020-05-21 15:22   ` Christoph Hellwig
2020-05-21 15:22 ` [PATCH 17/23] maccess: move user access routines together Christoph Hellwig
2020-05-21 15:22   ` Christoph Hellwig
2020-05-21 15:22 ` [PATCH 18/23] maccess: allow architectures to provide kernel probing directly Christoph Hellwig
2020-05-21 15:22   ` Christoph Hellwig
2020-05-21 15:22 ` [PATCH 19/23] x86: use non-set_fs based maccess routines Christoph Hellwig
2020-05-21 15:22   ` Christoph Hellwig
2020-05-21 15:22 ` [PATCH 20/23] maccess: rename probe_kernel_{read,write} to copy_{from,to}_kernel_nofault Christoph Hellwig
2020-05-21 15:22   ` [PATCH 20/23] maccess: rename probe_kernel_{read, write} to copy_{from, to}_kernel_nofault Christoph Hellwig
2020-05-21 15:22 ` [PATCH 21/23] maccess: rename probe_user_{read,write} to copy_{from,to}_user_nofault Christoph Hellwig
2020-05-21 15:22   ` [PATCH 21/23] maccess: rename probe_user_{read, write} to copy_{from, to}_user_nofault Christoph Hellwig
2020-05-21 15:23 ` [PATCH 22/23] maccess: rename probe_kernel_address to get_kernel_nofault Christoph Hellwig
2020-05-21 15:23   ` Christoph Hellwig
2020-05-21 15:23 ` [PATCH 23/23] maccess: return -ERANGE when copy_from_kernel_nofault_allowed fails Christoph Hellwig
2020-05-21 15:23   ` Christoph Hellwig
2020-05-21 18:03 ` clean up and streamline probe_kernel_* and friends v4 Linus Torvalds
2020-05-21 18:03   ` Linus Torvalds
2020-05-21 18:03   ` Linus Torvalds
2020-05-22  0:22 ` Masami Hiramatsu
2020-05-22  0:22   ` Masami Hiramatsu
2020-05-25 22:19 ` Andrew Morton
2020-05-25 22:19   ` Andrew Morton
2020-05-26  6:13   ` Christoph Hellwig
2020-05-26  6:13     ` Christoph Hellwig
2020-05-28  0:36     ` Andrew Morton
2020-05-28  0:36       ` Andrew Morton

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=a1aa26f4-8c0a-5f8a-8460-6d61f167702d@fb.com \
    --to=yhs@fb.com \
    --cc=akpm@linux-foundation.org \
    --cc=ast@kernel.org \
    --cc=bpf@vger.kernel.org \
    --cc=daniel@iogearbox.net \
    --cc=hch@lst.de \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-parisc@vger.kernel.org \
    --cc=linux-um@lists.infradead.org \
    --cc=mhiramat@kernel.org \
    --cc=netdev@vger.kernel.org \
    --cc=torvalds@linux-foundation.org \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.