From mboxrd@z Thu Jan 1 00:00:00 1970 From: "Guo, Jia" Subject: Re: [PATCH V4 1/9] bus: introduce hotplug failure handler Date: Wed, 4 Jul 2018 15:16:15 +0800 Message-ID: References: <1498711073-42917-1-git-send-email-jia.guo@intel.com> <1530268248-7328-1-git-send-email-jia.guo@intel.com> <1530268248-7328-2-git-send-email-jia.guo@intel.com> <6033435.uqaPCSQc1q@xps> Mime-Version: 1.0 Content-Type: text/plain; charset=windows-1252; format=flowed Content-Transfer-Encoding: 7bit Cc: dev@dpdk.org, stephen@networkplumber.org, bruce.richardson@intel.com, ferruh.yigit@intel.com, konstantin.ananyev@intel.com, gaetan.rivet@6wind.com, jingjing.wu@intel.com, motih@mellanox.com, matan@mellanox.com, harry.van.haaren@intel.com, qi.z.zhang@intel.com, shaopeng.he@intel.com, bernard.iremonger@intel.com, jblunck@infradead.org, shreyansh.jain@nxp.com, helin.zhang@intel.com To: Thomas Monjalon Return-path: Received: from mga04.intel.com (mga04.intel.com [192.55.52.120]) by dpdk.org (Postfix) with ESMTP id C97881BED8 for ; Wed, 4 Jul 2018 09:16:23 +0200 (CEST) In-Reply-To: <6033435.uqaPCSQc1q@xps> List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" On 7/4/2018 6:21 AM, Thomas Monjalon wrote: > 29/06/2018 12:30, Jeff Guo: >> /** >> + * Implementation a specific hot plug handler, which is responsible >> + * for handle the failure when hot remove the device, guaranty the system >> + * would not crash in the case. >> + * @param dev >> + * Pointer of the device structure. >> + * >> + * @return >> + * 0 on success. >> + * !0 on error. >> + */ >> +typedef int (*rte_bus_hotplug_handler_t)(struct rte_device *dev); > [...] >> @@ -211,6 +224,8 @@ struct rte_bus { >> rte_bus_parse_t parse; /**< Parse a device name */ >> struct rte_bus_conf conf; /**< Bus configuration */ >> rte_bus_get_iommu_class_t get_iommu_class; /**< Get iommu class */ >> + rte_bus_hotplug_handler_t hotplug_handler; >> + /**< handle hot plug on bus */ > The name is misleading. > It is to handle unplugging but is called "hotplug". ok, so i prefer hotplug_failure_handler than hot_unplug_handler, since it is more explicit for failure handle, and more clearly. > In order to demonstrate how the handler is used, you should > introduce the code using this handler in the same patch. > sorry, i check the history of rte_bus.h, and the way is introduce ops at first, second implement in specific bus, then come across the usage. I think that way clear and make sense. what do you think? Anyway, i will check the commit log if is there any misleading.