On Tue, 2019-05-28 at 12:32 +0200, Juergen Gross wrote: > Instead of returning a physical cpu number let pick_cpu() return a > scheduler resource instead. Rename pick_cpu() to pick_resource() to > reflect that change. > > Signed-off-by: Juergen Gross > Reviewed-by: Dario Faggioli with: > --- a/xen/include/xen/sched-if.h > +++ b/xen/include/xen/sched-if.h > @@ -351,14 +351,14 @@ static inline void sched_migrate(const struct > scheduler *s, > else > { > unit->vcpu->processor = cpu; > - unit->res = per_cpu(sched_res, cpu); > + unit->res = get_sched_res(cpu); > } > } > this hunk moving in patch 8, as noted while reviewing it already. :-) Regards -- Dario Faggioli, Ph.D http://about.me/dario.faggioli Virtualization Software Engineer SUSE Labs, SUSE https://www.suse.com/ ------------------------------------------------------------------- <> (Raistlin Majere)