All of lore.kernel.org
 help / color / mirror / Atom feed
From: Heinrich Schuchardt <xypron.glpk@gmx.de>
To: Joe Perches <joe@perches.com>, Andy Whitcroft <apw@canonical.com>,
	Andrew Morton <akpm@linux-foundation.org>
Cc: linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/1] checkpatch: remove false warning for commit reference
Date: Mon, 24 Oct 2016 19:22:33 +0200	[thread overview]
Message-ID: <ae7cd959-d5b5-d76f-1926-16bcecbaa916@gmx.de> (raw)
In-Reply-To: <1477255021.3561.9.camel@perches.com>

On 10/23/2016 10:37 PM, Joe Perches wrote:
> On Sun, 2016-10-23 at 09:34 +0200, Heinrich Schuchardt wrote:
>> Checkpatch warns of an incorrect commit reference style
>> for any hexadecimal number of 12 digits and more.
>>
>> Numbers of 12 digits are not necessarily commit ids.
>>
>> For an example provoking the problem see
>> https://patchwork.kernel.org/patch/9170897/
>>
>> Checkpatch should only warn if the number refers to an
>> existing commit.
> 
> That seems sensible.
> 
>> Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>
>> ---
>>  scripts/checkpatch.pl | 5 ++++-
>>  1 file changed, 4 insertions(+), 1 deletion(-)
>>
>> diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl
> []
>> @@ -848,6 +848,7 @@ sub git_commit_info {
>>  #		    echo "commit $(cut -c 1-12,41-)"
>>  #		done
>>  	} elsif ($lines[0] =~ /^fatal: ambiguous argument '$commit': unknown revision or path not in the working tree\./) {
>> +		$id = undef;
> 
> OK
> 
>>  	} else {
>>  		$id = substr($lines[0], 0, 12);
>>  		$desc = substr($lines[0], 41);
>> @@ -2577,7 +2578,9 @@ sub process {
>>  			($id, $description) = git_commit_info($orig_commit,
>>  							      $id, $orig_desc);
>>  
>> -			if ($short || $long || $space || $case || ($orig_desc ne $description) || !$hasparens) {
>> +			if ($id && ($short || $long || $space || $case
>> +				|| ($orig_desc ne $description)
>> +				|| !$hasparens)) {
> 
> I'd prefer
> 			if (defined($id) &&
For $id = 0 or $id = "" this would make a difference.
Surely I can update the patch like this to make the test more readable.

> 			   ($short || $long || $space || $case || ($orig_desc ne $description) || !$hasparens)) {
> 
> and not wrap the tests.

Putting defined($id) on a line of its own is fine.

Not wrapping the tests will produce a line of over 80 characters and
give a warning in scripts/checkpatch.pl.

The script should respect the standards it imposes on others.

> 
> Maybe ignore all the cases there git is not installed too.
> Something like:
> ---
>  scripts/checkpatch.pl | 16 ++++++++++------
>  1 file changed, 10 insertions(+), 6 deletions(-)
> 
> diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl
> index a8368d1c4348..a46b6ebe067b 100755
> --- a/scripts/checkpatch.pl
> +++ b/scripts/checkpatch.pl
> @@ -829,13 +829,16 @@ sub seed_camelcase_includes {
>  sub git_commit_info {
>  	my ($commit, $id, $desc) = @_;
>  
> -	return ($id, $desc) if ((which("git") eq "") || !(-e ".git"));
> +	my $git_id = undef;
> +	my $git_desc = undef;
> +
> +	return ($git_id, $git_desc) if ((which("git") eq "") || !(-e ".git"));
Why not simply
return (undef, undef) if ((which("git") eq "") || !(-e ".git"));

Should we provide a warning: "git not found"?
>  
>  	my $output = `git log --no-color --format='%H %s' -1 $commit 2>&1`;
>  	$output =~ s/^\s*//gm;
>  	my @lines = split("\n", $output);
>  
> -	return ($id, $desc) if ($#lines < 0);
> +	return ($git_id, $git_desc) if ($#lines < 0);
>  
>  	if ($lines[0] =~ /^error: short SHA1 $commit is ambiguous\./) {
>  # Maybe one day convert this block of bash into something that returns
> @@ -849,11 +852,11 @@ sub git_commit_info {
>  #		done
>  	} elsif ($lines[0] =~ /^fatal: ambiguous argument '$commit': unknown revision or path not in the working tree\./) {
>  	} else {
> -		$id = substr($lines[0], 0, 12);
> -		$desc = substr($lines[0], 41);
> +		$git_id = substr($lines[0], 0, 12);
> +		$git_desc = substr($lines[0], 41);
>  	}
>  
> -	return ($id, $desc);
> +	return ($git_id, $git_desc);

This will change the program logic for
if ($lines[0] =~ /^error: short SHA1 $commit is ambiguous\./)

>  }
>  
>  $chk_signoff = 0 if ($file);
> @@ -2577,7 +2580,8 @@ sub process {
>  			($id, $description) = git_commit_info($orig_commit,
>  							      $id, $orig_desc);
>  
> -			if ($short || $long || $space || $case || ($orig_desc ne $description) || !$hasparens) {
> +			if (defined($id) &&
> +			    ($short || $long || $space || $case || ($orig_desc ne $description) || !$hasparens)) {
This line is over 80 characters.
Which is not accepatble according to checkpatch.pl.

>  				ERROR("GIT_COMMIT_ID",
>  				      "Please use git commit description style 'commit <12+ chars of sha1> (\"\")' - ie: '${init_char}ommit $id (\"$description\")'\n" . $herecurr);
>  			}
> 
> 
> 

  reply	other threads:[~2016-10-24 17:29 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-06-11  1:26 [BUG] False positive in scripts/checkpatch.pl Heinrich Schuchardt
2016-10-23  7:34 ` [PATCH 1/1] checkpatch: remove false warning for commit reference Heinrich Schuchardt
2016-10-23 20:37   ` Joe Perches
2016-10-24 17:22     ` Heinrich Schuchardt [this message]
2016-10-24 18:39       ` Joe Perches
2016-10-24 18:46         ` Andy Whitcroft
2016-10-24 20:17           ` [PATCH] checkpatch: Don't check .pl files, improve absolute path commit log test Joe Perches
2017-06-07 18:40     ` [PATCH 1/1 v2] checkpatch: remove false warning for commit reference Heinrich Schuchardt
2017-06-07 18:56       ` Joe Perches

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ae7cd959-d5b5-d76f-1926-16bcecbaa916@gmx.de \
    --to=xypron.glpk@gmx.de \
    --cc=akpm@linux-foundation.org \
    --cc=apw@canonical.com \
    --cc=joe@perches.com \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.