Hi Am 26.08.20 um 03:44 schrieb Dave Airlie: > From: Dave Airlie > > Signed-off-by: Dave Airlie > --- > drivers/gpu/drm/drm_gem_vram_helper.c | 7 +------ > 1 file changed, 1 insertion(+), 6 deletions(-) > > diff --git a/drivers/gpu/drm/drm_gem_vram_helper.c b/drivers/gpu/drm/drm_gem_vram_helper.c > index 788557bc5c01..93586a310971 100644 > --- a/drivers/gpu/drm/drm_gem_vram_helper.c > +++ b/drivers/gpu/drm/drm_gem_vram_helper.c > @@ -973,10 +973,6 @@ static void backend_func_destroy(struct ttm_bo_device *bdev, struct ttm_tt *tt) > kfree(tt); > } > > -static struct ttm_backend_func backend_func = { > - .destroy = backend_func_destroy > -}; > - > /* > * TTM BO device > */ > @@ -991,8 +987,6 @@ static struct ttm_tt *bo_driver_ttm_tt_create(struct ttm_buffer_object *bo, > if (!tt) > return NULL; > > - tt->func = &backend_func; > - > ret = ttm_tt_init(tt, bo, page_flags); > if (ret < 0) > goto err_ttm_tt_init; > @@ -1055,6 +1049,7 @@ static int bo_driver_io_mem_reserve(struct ttm_bo_device *bdev, > > static struct ttm_bo_driver bo_driver = { > .ttm_tt_create = bo_driver_ttm_tt_create, > + .ttm_tt_destroy = backend_func_destroy, Please rename backend_func_destroy to bo_driver_ttm_tt_destroy. With this change Acked-by: Thomas Zimmermann Best regards Thomas > .eviction_valuable = ttm_bo_eviction_valuable, > .evict_flags = bo_driver_evict_flags, > .move_notify = bo_driver_move_notify, > -- Thomas Zimmermann Graphics Driver Developer SUSE Software Solutions Germany GmbH Maxfeldstr. 5, 90409 Nürnberg, Germany (HRB 36809, AG Nürnberg) Geschäftsführer: Felix Imendörffer