From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753278AbcHALih (ORCPT ); Mon, 1 Aug 2016 07:38:37 -0400 Received: from mail3-relais-sop.national.inria.fr ([192.134.164.104]:4298 "EHLO mail3-relais-sop.national.inria.fr" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753279AbcHALiI (ORCPT ); Mon, 1 Aug 2016 07:38:08 -0400 X-IronPort-AV: E=Sophos;i="5.28,454,1464645600"; d="scan'208";a="186554074" Date: Mon, 1 Aug 2016 13:37:36 +0200 (CEST) From: Julia Lawall X-X-Sender: jll@hadrien To: SF Markus Elfring cc: Amitoj Kaur Chawla , LKML , Coccinelle , Gilles Muller , Michal Marek , Nicolas Palix Subject: Re: [Cocci] [PATCH v3] Coccinelle: Script to replace allocate and memset with zalloc functions In-Reply-To: Message-ID: References: <20160801070233.GA19102@amitoj-Inspiron-3542> User-Agent: Alpine 2.10 (DEB 1266 2009-07-14) MIME-Version: 1.0 Content-Type: TEXT/PLAIN; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Mon, 1 Aug 2016, SF Markus Elfring wrote: > > +@vz1 depends on patch && !context && !org && !report@ > > +type T; > > +T *d; > > +statement S; > > +@@ > > + > > + d = > > +- vmalloc > > ++ vzalloc > > + (...); > > + if (!d) S > > +- memset(d, 0, sizeof(T)); > > + > > +@vz2 depends on patch && !context && !org && !report@ > > +expression d; > > +statement S; > > +@@ > > + > > + d = > > +- vmalloc > > ++ vzalloc > > + (...); > > + if (!d) S > > +- memset(d, 0, sizeof(*d)); > > I suggest to take another look at a few implementation details. > > 1. Would it make sense to merge such SmPL rules into one > so that code duplication could be reduced a bit > in such a script? I think it would suffer in readability. Perhaps in performance as well. julia > > 2. How do you think about to extend the shown check list > with the function "kvm_kvzalloc"? > > 3. Do you want to maintain a growing (?) function name list manually? > > Regards, > Markus > From mboxrd@z Thu Jan 1 00:00:00 1970 From: julia.lawall@lip6.fr (Julia Lawall) Date: Mon, 1 Aug 2016 13:37:36 +0200 (CEST) Subject: [Cocci] [PATCH v3] Coccinelle: Script to replace allocate and memset with zalloc functions In-Reply-To: References: <20160801070233.GA19102@amitoj-Inspiron-3542> Message-ID: To: cocci@systeme.lip6.fr List-Id: cocci@systeme.lip6.fr On Mon, 1 Aug 2016, SF Markus Elfring wrote: > > + at vz1 depends on patch && !context && !org && !report@ > > +type T; > > +T *d; > > +statement S; > > +@@ > > + > > + d = > > +- vmalloc > > ++ vzalloc > > + (...); > > + if (!d) S > > +- memset(d, 0, sizeof(T)); > > + > > + at vz2 depends on patch && !context && !org && !report@ > > +expression d; > > +statement S; > > +@@ > > + > > + d = > > +- vmalloc > > ++ vzalloc > > + (...); > > + if (!d) S > > +- memset(d, 0, sizeof(*d)); > > I suggest to take another look at a few implementation details. > > 1. Would it make sense to merge such SmPL rules into one > so that code duplication could be reduced a bit > in such a script? I think it would suffer in readability. Perhaps in performance as well. julia > > 2. How do you think about to extend the shown check list > with the function "kvm_kvzalloc"? > > 3. Do you want to maintain a growing (?) function name list manually? > > Regards, > Markus >