All of lore.kernel.org
 help / color / mirror / Atom feed
From: Johannes Schindelin <Johannes.Schindelin@gmx.de>
To: Junio C Hamano <gitster@pobox.com>
Cc: git@vger.kernel.org
Subject: Re: [PATCH] Provide a dirname() function when NO_LIBGEN_H=YesPlease
Date: Fri, 8 Jan 2016 17:17:29 +0100 (CET)	[thread overview]
Message-ID: <alpine.DEB.2.20.1601081707340.2964@virtualbox> (raw)
In-Reply-To: <xmqq8u7n934i.fsf@gitster.mtv.corp.google.com>

Hi Junio,

On Wed, 30 Sep 2015, Junio C Hamano wrote:

> Johannes Schindelin <johannes.schindelin@gmx.de> writes:
> 
> > diff --git a/compat/basename.c b/compat/basename.c
> > index d8f8a3c..10dba38 100644
> > --- a/compat/basename.c
> > +++ b/compat/basename.c
> > @@ -13,3 +13,29 @@ char *gitbasename (char *path)
> >  	}
> >  	return (char *)base;
> >  }
> > +
> > +char *gitdirname(char *path)
> > +{
> > +	char *p = path, *slash, c;
> > +
> > +	/* Skip over the disk name in MSDOS pathnames. */
> > +	if (has_dos_drive_prefix(p))
> > +		p += 2;
> 
> Not a new problem, but many callers of has_dos_drive_prefix()
> hardcodes that "2" in various forms.  I wonder if this is something
> we should relieve callers of by tweaking the semantics of it, e.g.
> by returning 2 (or howmanyever bytes should be skipped) from the
> function, changing it to skip_dos_drive_prefix(&p), etc.

In the upcoming v2, this is addressed.

> > +	/* POSIX.1-2001 says dirname("/") should return "/" */
> > +	slash = is_dir_sep(*p) ? ++p : NULL;
> > +	while ((c = *(p++)))
> 
> I am confused by this.  What is the invariant on 'p' at the
> beginning of the body of this while loop in each iteration?

The idea was that 'p' looks at whatever is the next character. And 'slash'
records the location of the latest slash we have seen (to be overwritten
with a '\0' to terminate the dirname).

Since '/' should not be shortened to the empty string, I special-cased
absolute paths to actually shift the 'slash' to one byte later. A little
dirty, but it worked.

Except that Ramsay's tests pointed out that I did not even look at what
the specs say, and I even fixed basename() in the meantime (and I think
dirname() looks more readable, but feel free to contradict me there).

> > +		if (is_dir_sep(c)) {
> > +			char *tentative = p - 1;
> > +
> > +			/* POSIX.1-2001 says to ignore trailing slashes */
> > +			while (is_dir_sep(*p))
> > +				p++;
> > +			if (*p)
> > +				slash = tentative;
> > +		}
> 
> I would have expected the function to scan from the end/right/tail.

Why scan twice (once to find the end, then to find the slashes)?

Ciao,
Dscho

  reply	other threads:[~2016-01-08 16:17 UTC|newest]

Thread overview: 63+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-09-30 14:50 [PATCH] Provide a dirname() function when NO_LIBGEN_H=YesPlease Johannes Schindelin
2015-09-30 18:24 ` Junio C Hamano
2016-01-08 16:17   ` Johannes Schindelin [this message]
2015-09-30 18:57 ` Ramsay Jones
2016-01-08 16:18   ` Johannes Schindelin
2016-01-08 16:21 ` [PATCH v2 0/4] Ensure that we can build without libgen.h Johannes Schindelin
2016-01-08 16:21   ` [PATCH v2 1/4] Refactor skipping DOS drive prefixes Johannes Schindelin
2016-01-08 21:51     ` Eric Sunshine
2016-01-08 22:07       ` Junio C Hamano
2016-01-11  9:32         ` Johannes Schindelin
2016-01-11 15:58           ` Junio C Hamano
2016-01-08 16:21   ` [PATCH v2 2/4] compat/basename: make basename() conform to POSIX Johannes Schindelin
2016-01-08 18:45     ` Junio C Hamano
2016-01-09 14:53       ` Johannes Schindelin
2016-01-11 16:01         ` Junio C Hamano
2016-01-08 16:21   ` [PATCH v2 3/4] Provide a dirname() function when NO_LIBGEN_H=YesPlease Johannes Schindelin
2016-01-08 18:53     ` Junio C Hamano
2016-01-08 16:21   ` [PATCH v2 4/4] t0060: verify that basename() and dirname() work as expected Johannes Schindelin
2016-01-10  4:17     ` Eric Sunshine
2016-01-11 10:50       ` Johannes Schindelin
2016-01-13 18:52     ` Michael Blume
2016-01-13 19:43       ` Junio C Hamano
2016-01-14  6:09         ` Johannes Schindelin
2016-01-11 18:29   ` [PATCH v3 0/4] Ensure that we can build without libgen.h Johannes Schindelin
2016-01-11 18:29     ` [PATCH v3 1/4] Refactor skipping DOS drive prefixes Johannes Schindelin
2016-01-11 18:29     ` [PATCH v3 2/4] compat/basename: make basename() conform to POSIX Johannes Schindelin
2016-01-11 18:30     ` [PATCH v3 3/4] Provide a dirname() function when NO_LIBGEN_H=YesPlease Johannes Schindelin
2016-01-11 20:33       ` Eric Sunshine
2016-01-11 22:56         ` Junio C Hamano
2016-01-12  7:57           ` Johannes Schindelin
2016-01-11 18:30     ` [PATCH v3 4/4] t0060: verify that basename() and dirname() work as expected Johannes Schindelin
2016-01-11 22:59     ` [PATCH v3 0/4] Ensure that we can build without libgen.h Junio C Hamano
2016-01-12  7:57     ` [PATCH v4 " Johannes Schindelin
2016-01-12  7:57       ` [PATCH v4 1/4] Refactor skipping DOS drive prefixes Johannes Schindelin
2016-01-22 18:50         ` Johannes Sixt
2016-01-22 19:09           ` Junio C Hamano
2016-01-23  8:25             ` Johannes Schindelin
2016-01-23 19:02               ` Johannes Sixt
2016-01-24 10:56                 ` Johannes Schindelin
2016-01-24 12:36                   ` Johannes Sixt
2016-01-24 22:12                     ` Junio C Hamano
2016-01-25 21:47                       ` [PATCH] mingw: avoid linking to the C library's isalpha() Johannes Sixt
2016-01-25 22:04                         ` Junio C Hamano
2016-01-12  7:57       ` [PATCH v4 2/4] compat/basename: make basename() conform to POSIX Johannes Schindelin
2016-01-13  0:49         ` Ramsay Jones
2016-01-13  7:14           ` Johannes Schindelin
2016-01-12  7:57       ` [PATCH v4 3/4] Provide a dirname() function when NO_LIBGEN_H=YesPlease Johannes Schindelin
2016-01-13  0:55         ` Ramsay Jones
2016-01-13  7:40           ` Johannes Schindelin
2016-01-13 16:44             ` Ramsay Jones
2016-01-12  7:57       ` [PATCH v4 4/4] t0060: verify that basename() and dirname() work as expected Johannes Schindelin
2016-01-13  0:58         ` Ramsay Jones
2016-01-13  7:17           ` Johannes Schindelin
     [not found]         ` <5695E4FB.2060705@web.de>
2016-01-13  9:27           ` Johannes Schindelin
2016-01-13 16:46             ` Ramsay Jones
2016-01-13 16:34           ` Ramsay Jones
2016-01-13 17:20             ` Junio C Hamano
2016-01-13 18:53               ` Johannes Schindelin
2016-01-13  0:44       ` [PATCH v4 0/4] Ensure that we can build without libgen.h Ramsay Jones
2016-01-13  2:56         ` Junio C Hamano
2016-01-13  6:15           ` Torsten Bögershausen
2016-01-13  7:38             ` Johannes Schindelin
2016-01-13  7:02         ` Johannes Schindelin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.DEB.2.20.1601081707340.2964@virtualbox \
    --to=johannes.schindelin@gmx.de \
    --cc=git@vger.kernel.org \
    --cc=gitster@pobox.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.