All of lore.kernel.org
 help / color / mirror / Atom feed
From: Ferruh Yigit <ferruh.yigit@intel.com>
To: "Min Hu (Connor)" <humin29@huawei.com>, dev@dpdk.org
Subject: Re: [dpdk-dev] [PATCH v3] net/hns3: fix parse link fails code fail
Date: Tue, 27 Apr 2021 13:45:08 +0100	[thread overview]
Message-ID: <b38d6b83-4fb3-a48b-fbd9-3e6cf5c8c6da@intel.com> (raw)
In-Reply-To: <1619525859-4182-1-git-send-email-humin29@huawei.com>

On 4/27/2021 1:17 PM, Min Hu (Connor) wrote:
> From: Chengwen Feng <fengchengwen@huawei.com>
> 
> The link fails code should be parsed using the structure
> hns3_mbx_vf_to_pf_cmd, else it will parse fail.
> 
> Fixes: 109e4dd1bd7a ("net/hns3: get link state change through mailbox")
> Cc: stable@dpdk.org
> 
> Signed-off-by: Chengwen Feng <fengchengwen@huawei.com>
> Signed-off-by: Min Hu (Connor) <humin29@huawei.com>
> ---
> v3:
> * get the parameter as 'struct hns3_mbx_vf_to_pf_cmd' at first place.
> 
> v2:
> * kept original API interface.
> ---
>  drivers/net/hns3/hns3_mbx.c | 11 +++++++++--
>  1 file changed, 9 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/net/hns3/hns3_mbx.c b/drivers/net/hns3/hns3_mbx.c
> index ba04ac9..31ab130 100644
> --- a/drivers/net/hns3/hns3_mbx.c
> +++ b/drivers/net/hns3/hns3_mbx.c
> @@ -347,7 +347,7 @@ hns3_link_fail_parse(struct hns3_hw *hw, uint8_t link_fail_code)
>  
>  static void
>  hns3pf_handle_link_change_event(struct hns3_hw *hw,
> -			      struct hns3_mbx_pf_to_vf_cmd *req)
> +				struct hns3_mbx_vf_to_pf_cmd *req)
>  {
>  #define LINK_STATUS_OFFSET     1
>  #define LINK_FAIL_CODE_OFFSET  2
> @@ -513,7 +513,14 @@ hns3_dev_handle_mbx_msg(struct hns3_hw *hw)
>  			hns3_handle_asserting_reset(hw, req);
>  			break;
>  		case HNS3_MBX_PUSH_LINK_STATUS:
> -			hns3pf_handle_link_change_event(hw, req);
> +			/*
> +			 * This message is reported by the firmware and is
> +			 * reported in 'struct hns3_mbx_vf_to_pf_cmd' format.
> +			 * Therefore, we should cast the req variable to
> +			 * 'struct hns3_mbx_vf_to_pf_cmd' and then process it.
> +			 */

I am asking just to double check, the 'msg' type is different of
'hns3_mbx_pf_to_vf_cmd' & 'hns3_mbx_vf_to_pf_cmd', one is 'uint8_t', other is
'uint16_t', and 'msg' is used in the function 'hns3pf_handle_link_change_event()'.
Is the 'msg' usage still correct after this change?

> +			hns3pf_handle_link_change_event(hw,
> +				(struct hns3_mbx_vf_to_pf_cmd *)req);

Will it be more readable if 'desc->data' cast to "struct hns3_mbx_vf_to_pf_cmd
*" (instead of 'req')? Up to you, I can proceed with this one if you prefer.

  reply	other threads:[~2021-04-27 12:45 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-04-22  1:55 [dpdk-dev] [PATCH 0/4] bugfix for hns3 PMD Min Hu (Connor)
2021-04-22  1:55 ` [dpdk-dev] [PATCH 1/4] net/hns3: fix error mbx messages prompt errors Min Hu (Connor)
2021-04-22  1:55 ` [dpdk-dev] [PATCH 2/4] net/hns3: fix PF miss link status notify message Min Hu (Connor)
2021-04-22  1:55 ` [dpdk-dev] [PATCH 3/4] net/hns3: fix parse link fails code fail Min Hu (Connor)
2021-04-26 12:26   ` Ferruh Yigit
2021-04-26 12:41     ` fengchengwen
2021-04-26 12:50       ` Ferruh Yigit
2021-04-26 13:20         ` fengchengwen
2021-04-26 13:42   ` [dpdk-dev] [PATCH v2] " Min Hu (Connor)
2021-04-27 11:11     ` Ferruh Yigit
2021-04-27 12:31       ` Min Hu (Connor)
2021-04-27 12:17   ` [dpdk-dev] [PATCH v3] " Min Hu (Connor)
2021-04-27 12:45     ` Ferruh Yigit [this message]
2021-04-27 13:03       ` Min Hu (Connor)
2021-04-27 13:19         ` Ferruh Yigit
2021-04-27 13:43           ` Min Hu (Connor)
2021-04-27 15:09             ` Ferruh Yigit
2021-04-22  1:55 ` [dpdk-dev] [PATCH 4/4] net/hns3: delete unused macro and struct of mbx module Min Hu (Connor)
2021-04-26 12:52 ` [dpdk-dev] [PATCH 0/4] bugfix for hns3 PMD Ferruh Yigit

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=b38d6b83-4fb3-a48b-fbd9-3e6cf5c8c6da@intel.com \
    --to=ferruh.yigit@intel.com \
    --cc=dev@dpdk.org \
    --cc=humin29@huawei.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.