All of lore.kernel.org
 help / color / mirror / Atom feed
From: Igor Torrente <igormtorrente@gmail.com>
To: Pekka Paalanen <ppaalanen@gmail.com>
Cc: hamohammed.sa@gmail.com, tzimmermann@suse.de,
	rodrigosiqueiramelo@gmail.com, airlied@linux.ie,
	leandro.ribeiro@collabora.com, melissa.srw@gmail.com,
	dri-devel@lists.freedesktop.org, tales.aparecida@gmail.com,
	~lkcamp/patches@lists.sr.ht
Subject: Re: [PATCH v5 9/9] drm: vkms: Add support to the RGB565 format
Date: Tue, 10 May 2022 16:24:17 -0300	[thread overview]
Message-ID: <b72729ea-6e4f-0c5e-1895-55aad648a0b3@gmail.com> (raw)
In-Reply-To: <20220509105324.5ede4d90@eldfell>

On 5/9/22 04:53, Pekka Paalanen wrote:
> On Fri, 6 May 2022 20:05:39 -0300
> Igor Torrente <igormtorrente@gmail.com> wrote:
> 
>> Hi Pekka,
>>
>> On 4/27/22 04:55, Pekka Paalanen wrote:
>>> On Tue, 26 Apr 2022 21:53:19 -0300
>>> Igor Torrente <igormtorrente@gmail.com> wrote:
>>>    
>>>> Hi Pekka,
>>>>
>>>> On 4/21/22 07:58, Pekka Paalanen wrote:
>>>>> On Mon,  4 Apr 2022 17:45:15 -0300
>>>>> Igor Torrente <igormtorrente@gmail.com> wrote:
>>>>>       
>>>>>> Adds this common format to vkms.
>>>>>>
>>>>>> This commit also adds new helper macros to deal with fixed-point
>>>>>> arithmetic.
>>>>>>
>>>>>> It was done to improve the precision of the conversion to ARGB16161616
>>>>>> since the "conversion ratio" is not an integer.
>>>>>>
>>>>>> V3: Adapt the handlers to the new format introduced in patch 7 V3.
>>>>>> V5: Minor improvements
>>>>>>
>>>>>> Signed-off-by: Igor Torrente <igormtorrente@gmail.com>
>>>>>> ---
>>>>>>     drivers/gpu/drm/vkms/vkms_formats.c   | 70 +++++++++++++++++++++++++++
>>>>>>     drivers/gpu/drm/vkms/vkms_plane.c     |  6 ++-
>>>>>>     drivers/gpu/drm/vkms/vkms_writeback.c |  3 +-
>>>>>>     3 files changed, 76 insertions(+), 3 deletions(-)
>>>>>>
>>>>>> diff --git a/drivers/gpu/drm/vkms/vkms_formats.c b/drivers/gpu/drm/vkms/vkms_formats.c
>>>>>> index 8d913fa7dbde..4af8b295f31e 100644
>>>>>> --- a/drivers/gpu/drm/vkms/vkms_formats.c
>>>>>> +++ b/drivers/gpu/drm/vkms/vkms_formats.c
>>>>>> @@ -5,6 +5,23 @@
>>>>>>     
>>>>>>     #include "vkms_formats.h"
>>>>>>     
>>>>>> +/* The following macros help doing fixed point arithmetic. */
>>>>>> +/*
>>>>>> + * With Fixed-Point scale 15 we have 17 and 15 bits of integer and fractional
>>>>>> + * parts respectively.
>>>>>> + *  | 0000 0000 0000 0000 0.000 0000 0000 0000 |
>>>>>> + * 31                                          0
>>>>>> + */
>>>>>> +#define FIXED_SCALE 15
>>>>>
>>>>> I think this would usually be called a "shift" since it's used in
>>>>> bit-shifts.
>>>>
>>>> Ok, I will rename this.
>>>>   
>>>>>       
>>>>>> +
>>>>>> +#define INT_TO_FIXED(a) ((a) << FIXED_SCALE)
>>>>>> +#define FIXED_MUL(a, b) ((s32)(((s64)(a) * (b)) >> FIXED_SCALE))
>>>>>> +#define FIXED_DIV(a, b) ((s32)(((s64)(a) << FIXED_SCALE) / (b)))
>>>>>
>>>>> A truncating div, ok.
>>>>>       
>>>>>> +/* This macro converts a fixed point number to int, and round half up it */
>>>>>> +#define FIXED_TO_INT_ROUND(a) (((a) + (1 << (FIXED_SCALE - 1))) >> FIXED_SCALE)
>>>>>
>>>>> Yes.
>>>>>       
>>>>>> +/* Convert divisor and dividend to Fixed-Point and performs the division */
>>>>>> +#define INT_TO_FIXED_DIV(a, b) (FIXED_DIV(INT_TO_FIXED(a), INT_TO_FIXED(b)))
>>>>>
>>>>> Ok, this is obvious to read, even though it's the same as FIXED_DIV()
>>>>> alone. Not sure the compiler would optimize that extra bit-shift away...
>>>>>
>>>>> If one wanted to, it would be possible to write type-safe functions for
>>>>> these so that fixed and integer could not be mixed up.
>>>>
>>>> Ok, I will move to a function.
>>>
>>> That's not all.
>>>
>>> If you want it type-safe, then you need something like
>>>
>>> struct vkms_fixed_point {
>>> 	s32 value;
>>> };
>>>
>>> And use `struct vkms_fixed_point` (by value) everywhere where you pass
>>> a fixed point value, and never as a plain s32 type. Then it will be
>>> impossible to do incorrect arithmetic or conversions by accident on
>>> fixed point values.
>>>
>>> Is it worth it? I don't know, since it's limited into this one file.
>>>
>>> A simple 'typedef s32 vkms_fixed_point' does not work, because it does
>>> not prevent computing with vkms_fixed_point as if it was just a normal
>>> s32. Using a struct prevents that.
>>
>> ohhh. Got it!
>>
>>>
>>> I wonder if the kernel doesn't already have something like this
>>> available in general...
>>
>> After some time searching I found `include/drm/drm_fixed.h`[1].
>>
>> It seems fine. There are minor things to consider:
>>
>> 1. It doesn't have a `FIXED_TO_INT_ROUND` equivalent.
>> 2. We can use `fixed20_12` for rgb565 but We have to use s64 for YUV
>> formats or add a `sfixed20_12` with s32.
>>
>> In terms of consistency, do you think worth using this "library" given
>> that we may need to use two distinct ways to represent the fixed point
>> soonish? Or it's better to implement `sfixed20_12`? Or just continue
>> with the
>> current macros?
>>
>> [1] - https://elixir.bootlin.com/linux/latest/source/include/drm/drm_fixed.h
> 
> I think that is something the kernel people should weigh in on.
> 
> The one thing I would definitely avoid is ending up using multiple
> fixed point formats in VKMS.
> 
> In the mean time, your current macros seem good enough, if there is no
> community interest in better type safety nor sharing the fixed point
> code.

OK. Thanks!

> 
> 
> Thanks,
> pq

  reply	other threads:[~2022-05-10 19:24 UTC|newest]

Thread overview: 44+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-04-04 20:45 [PATCH v5 0/9] Add new formats support to vkms Igor Torrente
2022-04-04 20:45 ` [PATCH v5 1/9] drm: vkms: Alloc the compose frame using vzalloc Igor Torrente
2022-04-05 14:05   ` André Almeida
2022-04-05 19:03     ` Igor Torrente
2022-04-04 20:45 ` [PATCH v5 2/9] drm: vkms: Replace hardcoded value of `vkms_composer.map` to DRM_FORMAT_MAX_PLANES Igor Torrente
2022-04-04 20:45 ` [PATCH v5 3/9] drm: vkms: Rename `vkms_composer` to `vkms_frame_info` Igor Torrente
2022-04-04 20:45 ` [PATCH v5 4/9] drm: drm_atomic_helper: Add a new helper to deal with the writeback connector validation Igor Torrente
2022-04-05 14:21   ` André Almeida
2022-04-05 19:05     ` Igor Torrente
2022-04-04 20:45 ` [PATCH v5 5/9] drm: vkms: Add fb information to `vkms_writeback_job` Igor Torrente
2022-04-20 11:23   ` Pekka Paalanen
2022-04-23 15:12     ` Igor Torrente
2022-04-25  7:56       ` Pekka Paalanen
2022-04-26  0:56         ` Igor Torrente
2022-04-26  7:09           ` Pekka Paalanen
2022-04-27  0:43             ` Igor Torrente
2022-04-27  7:31               ` Pekka Paalanen
2022-04-04 20:45 ` [PATCH v5 6/9] drm: vkms: Refactor the plane composer to accept new formats Igor Torrente
2022-04-20 12:36   ` Pekka Paalanen
2022-04-23 16:04     ` Igor Torrente
2022-04-23 18:53       ` Igor Torrente
2022-04-25  8:10         ` Pekka Paalanen
2022-04-26  1:54           ` Igor Torrente
2022-04-27  1:03             ` Igor Torrente
2022-04-27  1:22               ` Igor Torrente
2022-04-27  7:43                 ` Pekka Paalanen
2022-04-28  0:44                   ` Igor Torrente
2022-04-29 12:31                     ` Pekka Paalanen
2022-04-04 20:45 ` [PATCH v5 7/9] drm: vkms: Supports to the case where primary plane doesn't match the CRTC Igor Torrente
2022-04-20 13:13   ` Pekka Paalanen
2022-04-24  0:41     ` Igor Torrente
2022-04-04 20:45 ` [PATCH v5 8/9] drm: vkms: Adds XRGB_16161616 and ARGB_1616161616 formats Igor Torrente
2022-04-20 13:19   ` Pekka Paalanen
2022-05-07  7:32   ` Thomas Zimmermann
2022-05-10 20:32     ` Igor Torrente
2022-04-04 20:45 ` [PATCH v5 9/9] drm: vkms: Add support to the RGB565 format Igor Torrente
2022-04-21 10:58   ` Pekka Paalanen
2022-04-27  0:53     ` Igor Torrente
2022-04-27  7:55       ` Pekka Paalanen
2022-05-06 23:05         ` Igor Torrente
2022-05-09  7:53           ` Pekka Paalanen
2022-05-10 19:24             ` Igor Torrente [this message]
2022-06-13  9:52 ` [PATCH v5 0/9] Add new formats support to vkms Melissa Wen
2022-06-13 20:26   ` Igor Torrente

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=b72729ea-6e4f-0c5e-1895-55aad648a0b3@gmail.com \
    --to=igormtorrente@gmail.com \
    --cc=airlied@linux.ie \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=hamohammed.sa@gmail.com \
    --cc=leandro.ribeiro@collabora.com \
    --cc=melissa.srw@gmail.com \
    --cc=ppaalanen@gmail.com \
    --cc=rodrigosiqueiramelo@gmail.com \
    --cc=tales.aparecida@gmail.com \
    --cc=tzimmermann@suse.de \
    --cc=~lkcamp/patches@lists.sr.ht \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.