All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] platform/chrome: Kconfig: Remove CONFIG_ prefix from MFD_CROS_EC section
@ 2020-03-05 10:28 Enric Balletbo i Serra
  2020-03-05 11:11 ` Andy Shevchenko
  2020-03-05 15:54 ` Randy Dunlap
  0 siblings, 2 replies; 4+ messages in thread
From: Enric Balletbo i Serra @ 2020-03-05 10:28 UTC (permalink / raw)
  To: linux-kernel
  Cc: Collabora Kernel ML, groeck, bleung, dtor, gwendal, Randy Dunlap,
	Andy Shevchenko, Lee Jones

Remove the CONFIG_ prefix from the select statement for MFD_CROS_EC.

Fixes: 2fa2b980e3fe1 ("mfd / platform: cros_ec: Rename config to a better name")
Reported-by: Randy Dunlap <rdunlap@infradead.org>
Signed-off-by: Enric Balletbo i Serra <enric.balletbo@collabora.com>
---

 drivers/platform/chrome/Kconfig | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/platform/chrome/Kconfig b/drivers/platform/chrome/Kconfig
index 15fc8b8a2db8..5ae6c49f553d 100644
--- a/drivers/platform/chrome/Kconfig
+++ b/drivers/platform/chrome/Kconfig
@@ -7,7 +7,7 @@ config MFD_CROS_EC
 	tristate "Platform support for Chrome hardware (transitional)"
 	select CHROME_PLATFORMS
 	select CROS_EC
-	select CONFIG_MFD_CROS_EC_DEV
+	select MFD_CROS_EC_DEV
 	depends on X86 || ARM || ARM64 || COMPILE_TEST
 	help
 	  This is a transitional Kconfig option and will be removed after
-- 
2.25.1


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH] platform/chrome: Kconfig: Remove CONFIG_ prefix from MFD_CROS_EC section
  2020-03-05 10:28 [PATCH] platform/chrome: Kconfig: Remove CONFIG_ prefix from MFD_CROS_EC section Enric Balletbo i Serra
@ 2020-03-05 11:11 ` Andy Shevchenko
  2020-03-05 15:54 ` Randy Dunlap
  1 sibling, 0 replies; 4+ messages in thread
From: Andy Shevchenko @ 2020-03-05 11:11 UTC (permalink / raw)
  To: Enric Balletbo i Serra
  Cc: linux-kernel, Collabora Kernel ML, groeck, bleung, dtor, gwendal,
	Randy Dunlap, Lee Jones

On Thu, Mar 05, 2020 at 11:28:38AM +0100, Enric Balletbo i Serra wrote:
> Remove the CONFIG_ prefix from the select statement for MFD_CROS_EC.
> 

Acked-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>

> Fixes: 2fa2b980e3fe1 ("mfd / platform: cros_ec: Rename config to a better name")
> Reported-by: Randy Dunlap <rdunlap@infradead.org>
> Signed-off-by: Enric Balletbo i Serra <enric.balletbo@collabora.com>
> ---
> 
>  drivers/platform/chrome/Kconfig | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/platform/chrome/Kconfig b/drivers/platform/chrome/Kconfig
> index 15fc8b8a2db8..5ae6c49f553d 100644
> --- a/drivers/platform/chrome/Kconfig
> +++ b/drivers/platform/chrome/Kconfig
> @@ -7,7 +7,7 @@ config MFD_CROS_EC
>  	tristate "Platform support for Chrome hardware (transitional)"
>  	select CHROME_PLATFORMS
>  	select CROS_EC
> -	select CONFIG_MFD_CROS_EC_DEV
> +	select MFD_CROS_EC_DEV
>  	depends on X86 || ARM || ARM64 || COMPILE_TEST
>  	help
>  	  This is a transitional Kconfig option and will be removed after
> -- 
> 2.25.1
> 

-- 
With Best Regards,
Andy Shevchenko



^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] platform/chrome: Kconfig: Remove CONFIG_ prefix from MFD_CROS_EC section
  2020-03-05 10:28 [PATCH] platform/chrome: Kconfig: Remove CONFIG_ prefix from MFD_CROS_EC section Enric Balletbo i Serra
  2020-03-05 11:11 ` Andy Shevchenko
@ 2020-03-05 15:54 ` Randy Dunlap
  2020-03-09  8:39   ` Enric Balletbo i Serra
  1 sibling, 1 reply; 4+ messages in thread
From: Randy Dunlap @ 2020-03-05 15:54 UTC (permalink / raw)
  To: Enric Balletbo i Serra, linux-kernel
  Cc: Collabora Kernel ML, groeck, bleung, dtor, gwendal,
	Andy Shevchenko, Lee Jones

On 3/5/20 2:28 AM, Enric Balletbo i Serra wrote:
> Remove the CONFIG_ prefix from the select statement for MFD_CROS_EC.
> 
> Fixes: 2fa2b980e3fe1 ("mfd / platform: cros_ec: Rename config to a better name")
> Reported-by: Randy Dunlap <rdunlap@infradead.org>
> Signed-off-by: Enric Balletbo i Serra <enric.balletbo@collabora.com>

Acked-by: Randy Dunlap <rdunlap@infradead.org>

Thanks.

> ---
> 
>  drivers/platform/chrome/Kconfig | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/platform/chrome/Kconfig b/drivers/platform/chrome/Kconfig
> index 15fc8b8a2db8..5ae6c49f553d 100644
> --- a/drivers/platform/chrome/Kconfig
> +++ b/drivers/platform/chrome/Kconfig
> @@ -7,7 +7,7 @@ config MFD_CROS_EC
>  	tristate "Platform support for Chrome hardware (transitional)"
>  	select CHROME_PLATFORMS
>  	select CROS_EC
> -	select CONFIG_MFD_CROS_EC_DEV
> +	select MFD_CROS_EC_DEV
>  	depends on X86 || ARM || ARM64 || COMPILE_TEST
>  	help
>  	  This is a transitional Kconfig option and will be removed after
> 


-- 
~Randy


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] platform/chrome: Kconfig: Remove CONFIG_ prefix from MFD_CROS_EC section
  2020-03-05 15:54 ` Randy Dunlap
@ 2020-03-09  8:39   ` Enric Balletbo i Serra
  0 siblings, 0 replies; 4+ messages in thread
From: Enric Balletbo i Serra @ 2020-03-09  8:39 UTC (permalink / raw)
  To: Randy Dunlap, linux-kernel
  Cc: Collabora Kernel ML, groeck, bleung, dtor, gwendal,
	Andy Shevchenko, Lee Jones



On 5/3/20 16:54, Randy Dunlap wrote:
> On 3/5/20 2:28 AM, Enric Balletbo i Serra wrote:
>> Remove the CONFIG_ prefix from the select statement for MFD_CROS_EC.
>>
>> Fixes: 2fa2b980e3fe1 ("mfd / platform: cros_ec: Rename config to a better name")
>> Reported-by: Randy Dunlap <rdunlap@infradead.org>
>> Signed-off-by: Enric Balletbo i Serra <enric.balletbo@collabora.com>
> 
> Acked-by: Randy Dunlap <rdunlap@infradead.org>
> 

Queued for 5.7.

> Thanks.
> 
>> ---
>>
>>  drivers/platform/chrome/Kconfig | 2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/drivers/platform/chrome/Kconfig b/drivers/platform/chrome/Kconfig
>> index 15fc8b8a2db8..5ae6c49f553d 100644
>> --- a/drivers/platform/chrome/Kconfig
>> +++ b/drivers/platform/chrome/Kconfig
>> @@ -7,7 +7,7 @@ config MFD_CROS_EC
>>  	tristate "Platform support for Chrome hardware (transitional)"
>>  	select CHROME_PLATFORMS
>>  	select CROS_EC
>> -	select CONFIG_MFD_CROS_EC_DEV
>> +	select MFD_CROS_EC_DEV
>>  	depends on X86 || ARM || ARM64 || COMPILE_TEST
>>  	help
>>  	  This is a transitional Kconfig option and will be removed after
>>
> 
> 

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2020-03-09  8:39 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-03-05 10:28 [PATCH] platform/chrome: Kconfig: Remove CONFIG_ prefix from MFD_CROS_EC section Enric Balletbo i Serra
2020-03-05 11:11 ` Andy Shevchenko
2020-03-05 15:54 ` Randy Dunlap
2020-03-09  8:39   ` Enric Balletbo i Serra

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.