All of lore.kernel.org
 help / color / mirror / Atom feed
From: Yann E. MORIN <yann.morin.1998@free.fr>
To: buildroot@busybox.net
Subject: [Buildroot] [PATCH 0/13 v2] some download-related changes
Date: Sun,  2 Mar 2014 18:51:41 +0100	[thread overview]
Message-ID: <cover.1393781649.git.yann.morin.1998@free.fr> (raw)

From: "Yann E. MORIN" <yann.morin.1998@free.fr>

Hello All!

This series contains those download-related changes:

  - Patches 1..3  : some cleanups and preparatory works in the
    download infra,

  - Patches 4..8  : move download helpers to shell scripts, one
    such script for each download helper

  - Patches 9..10 : don't use DL_DIR as scratchpad for temporary VCS
    checkouts, since DL_DIR is a precious location

  - Patches 11..13: check hashes of downloaded files, to ensure the
    files are genuine


Changes v1 -> v2:
  - don't do any behavioural change when switching to shell scripts,
    just reproduce exactly what was in the Makefile  (Luca, Arnout)
  - support more than one hash algorithm  (Arnout, Gustavo)
  - typoes  (Luca, Baruch)


Regards,
Yann E. MORIN.


----------------------------------------------------------------
Yann E. MORIN (13):
      pkg-infra: DOWNLOAD is never called with two arguments
      Makefile: rename USER_HOOKS_EXTRA_ENV to EXTRA_ENV
      Makefile: add BR2_DL_DIR to EXTRA_ENV
      pkg-infra: move the git download helper to a script
      pkg-infra: move the svn download helper to a script
      pkg-infra: move the cvs download helper to a script
      pkg-infra: move the hg download helper to a script
      pkg-infra: move the wget download helper to a script
      pkg-infra: don't use DL_DIR as scratchpad for temporary VCS checkouts
      pkg-infra: also set PKGDIR for the download step
      pkg-infra: add possiblity to check downloaded files against known hashes
      manual: add documentation about packages' hashes
      package/ca-certificates: add tarball's hashes

 Makefile                                     |  4 +-
 docs/manual/adding-packages-directory.txt    | 57 +++++++++++++++++++
 package/Makefile.in                          |  5 +-
 package/ca-certificates/ca-certificates.hash |  3 +
 package/pkg-download.mk                      | 84 +++++++++++-----------------
 package/pkg-generic.mk                       |  3 +-
 support/download/check-hash                  | 71 +++++++++++++++++++++++
 support/download/cvs                         | 31 ++++++++++
 support/download/git                         | 40 +++++++++++++
 support/download/hg                          | 29 ++++++++++
 support/download/svn                         | 27 +++++++++
 support/download/wget                        | 23 ++++++++
 12 files changed, 322 insertions(+), 55 deletions(-)
 create mode 100644 package/ca-certificates/ca-certificates.hash
 create mode 100755 support/download/check-hash
 create mode 100755 support/download/cvs
 create mode 100755 support/download/git
 create mode 100755 support/download/hg
 create mode 100755 support/download/svn
 create mode 100755 support/download/wget

-- 
.-----------------.--------------------.------------------.--------------------.
|  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON | Erics' conspiracy: |
| +33 662 376 056 | Software  Designer | \ / CAMPAIGN     |  ___               |
| +33 223 225 172 `------------.-------:  X  AGAINST      |  \e/  There is no  |
| http://ymorin.is-a-geek.org/ | _/*\_ | / \ HTML MAIL    |   v   conspiracy.  |
'------------------------------^-------^------------------^--------------------'

             reply	other threads:[~2014-03-02 17:51 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-03-02 17:51 Yann E. MORIN [this message]
2014-03-02 17:51 ` [Buildroot] [PATCH 01/13] pkg-infra: DOWNLOAD is never called with two arguments Yann E. MORIN
2014-03-02 20:01   ` Thomas Petazzoni
2014-03-02 17:51 ` [Buildroot] [PATCH 02/13] Makefile: rename USER_HOOKS_EXTRA_ENV to EXTRA_ENV Yann E. MORIN
2014-03-02 17:51 ` [Buildroot] [PATCH 03/13] Makefile: add BR2_DL_DIR " Yann E. MORIN
2014-03-05  6:29   ` Arnout Vandecappelle
2014-03-02 17:51 ` [Buildroot] [PATCH 04/13] pkg-infra: move the git download helper to a script Yann E. MORIN
2014-03-05  6:34   ` Arnout Vandecappelle
2014-03-02 17:51 ` [Buildroot] [PATCH 05/13] pkg-infra: move the svn " Yann E. MORIN
2014-03-02 17:51 ` [Buildroot] [PATCH 06/13] pkg-infra: move the cvs " Yann E. MORIN
2014-03-02 17:51 ` [Buildroot] [PATCH 07/13] pkg-infra: move the hg " Yann E. MORIN
2014-03-02 17:51 ` [Buildroot] [PATCH 08/13] pkg-infra: move the wget " Yann E. MORIN
2014-03-02 17:51 ` [Buildroot] [PATCH 09/13] pkg-infra: don't use DL_DIR as scratchpad for temporary VCS checkouts Yann E. MORIN
2014-03-02 17:51 ` [Buildroot] [PATCH 10/13] pkg-infra: also set PKGDIR for the download step Yann E. MORIN
2014-03-02 17:51 ` [Buildroot] [PATCH 11/13] pkg-infra: add possiblity to check downloaded files against known hashes Yann E. MORIN
2014-03-02 20:10   ` Samuel Martin
2014-03-02 22:19     ` Yann E. MORIN
2014-03-02 17:51 ` [Buildroot] [PATCH 12/13] manual: add documentation about packages' hashes Yann E. MORIN
2014-03-02 17:51 ` [Buildroot] [PATCH 13/13] package/ca-certificates: add tarball's hashes Yann E. MORIN
2014-03-02 20:14 ` [Buildroot] [PATCH 0/13 v2] some download-related changes Samuel Martin
2014-03-02 20:55   ` Thomas De Schampheleire
2014-03-02 22:32     ` Yann E. MORIN

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=cover.1393781649.git.yann.morin.1998@free.fr \
    --to=yann.morin.1998@free.fr \
    --cc=buildroot@busybox.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.