All of lore.kernel.org
 help / color / mirror / Atom feed
From: BALATON Zoltan <balaton@eik.bme.hu>
To: qemu-devel@nongnu.org, qemu-ppc@nongnu.org
Cc: Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk>
Subject: [PATCH v3 00/13] Misc ppc/mac machines clean up
Date: Mon,  3 Oct 2022 22:13:13 +0200 (CEST)	[thread overview]
Message-ID: <cover.1664827008.git.balaton@eik.bme.hu> (raw)

This series includes some clean ups to mac_newworld and mac_oldworld
to make them a bit simpler and more readable, It also removes the
shared mac.h file that turns out was more of a random collection of
unrelated things. Getting rid of this mac.h improves the locality of
device models and reduces unnecessary interdependency.

v3: Some more patch spliting and changes I've noticed and address more
review comments
v2: Split some patches and add a few more I've noticed now and address
review comments

BALATON Zoltan (13):
  mac_newworld: Drop some variables
  mac_oldworld: Drop some more variables
  mac_{old|new}world: Set tbfreq at declaration
  mac_{old|new}world: Avoid else branch by setting default value
  mac_{old|new}world: Simplify cmdline_base calculation
  mac_newworld: Clean up creation of Uninorth devices
  mac_{old|new}world: Reduce number of QOM casts
  hw/ppc/mac.h: Move newworld specific parts out from shared header
  hw/ppc/mac.h: Move macio specific parts out from shared header
  hw/ppc/mac.h: Move grackle-pcihost type declaration out to a header
  hw/ppc/mac.h: Move PROM and KERNEL defines to board code
  hw/ppc/mac.h: Rename to include/hw/nvram/mac_nvram.h
  mac_nvram: Use NVRAM_SIZE constant

 MAINTAINERS                   |   2 +
 hw/ide/macio.c                |   1 -
 hw/intc/heathrow_pic.c        |   1 -
 hw/intc/openpic.c             |   1 -
 hw/misc/macio/cuda.c          |   1 -
 hw/misc/macio/gpio.c          |   1 -
 hw/misc/macio/macio.c         |   8 +-
 hw/misc/macio/pmu.c           |   1 -
 hw/nvram/mac_nvram.c          |   2 +-
 hw/pci-host/grackle.c         |  15 +--
 hw/pci-host/uninorth.c        |   1 -
 hw/ppc/mac.h                  | 105 ----------------
 hw/ppc/mac_newworld.c         | 225 ++++++++++++++++------------------
 hw/ppc/mac_oldworld.c         | 111 +++++++----------
 include/hw/misc/macio/macio.h |  23 +++-
 include/hw/nvram/mac_nvram.h  |  51 ++++++++
 include/hw/pci-host/grackle.h |  44 +++++++
 17 files changed, 280 insertions(+), 313 deletions(-)
 delete mode 100644 hw/ppc/mac.h
 create mode 100644 include/hw/nvram/mac_nvram.h
 create mode 100644 include/hw/pci-host/grackle.h

-- 
2.30.4



             reply	other threads:[~2022-10-03 21:24 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-10-03 20:13 BALATON Zoltan [this message]
2022-10-03 20:13 ` [PATCH v3 01/13] mac_newworld: Drop some variables BALATON Zoltan
2022-10-03 20:13 ` [PATCH v3 02/13] mac_oldworld: Drop some more variables BALATON Zoltan
2022-10-03 20:13 ` [PATCH v3 03/13] mac_{old|new}world: Set tbfreq at declaration BALATON Zoltan
2022-10-03 20:13 ` [PATCH v3 04/13] mac_{old|new}world: Avoid else branch by setting default value BALATON Zoltan
2022-10-03 20:13 ` [PATCH v3 05/13] mac_{old|new}world: Simplify cmdline_base calculation BALATON Zoltan
2022-10-14  8:57   ` Mark Cave-Ayland
2022-10-14 11:56     ` BALATON Zoltan
2022-10-14 15:25       ` BALATON Zoltan
2022-10-28  8:54         ` Mark Cave-Ayland
2022-10-28 11:59           ` BALATON Zoltan
2022-10-03 20:13 ` [PATCH v3 06/13] mac_newworld: Clean up creation of Uninorth devices BALATON Zoltan
2022-10-14  9:04   ` Mark Cave-Ayland
2022-10-03 20:13 ` [PATCH v3 07/13] mac_{old|new}world: Reduce number of QOM casts BALATON Zoltan
2022-10-03 20:13 ` [PATCH v3 08/13] hw/ppc/mac.h: Move newworld specific parts out from shared header BALATON Zoltan
2022-10-03 20:13 ` [PATCH v3 09/13] hw/ppc/mac.h: Move macio " BALATON Zoltan
2022-10-03 20:13 ` [PATCH v3 10/13] hw/ppc/mac.h: Move grackle-pcihost type declaration out to a header BALATON Zoltan
2022-10-14  9:08   ` Mark Cave-Ayland
2022-10-03 20:13 ` [PATCH v3 11/13] hw/ppc/mac.h: Move PROM and KERNEL defines to board code BALATON Zoltan
2022-10-03 20:13 ` [PATCH v3 12/13] hw/ppc/mac.h: Rename to include/hw/nvram/mac_nvram.h BALATON Zoltan
2022-10-03 20:13 ` [PATCH v3 13/13] mac_nvram: Use NVRAM_SIZE constant BALATON Zoltan
2022-10-11 10:22 ` [PATCH v3 00/13] Misc ppc/mac machines clean up BALATON Zoltan
2022-10-18 11:37   ` BALATON Zoltan
2022-10-28  9:03     ` Mark Cave-Ayland

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=cover.1664827008.git.balaton@eik.bme.hu \
    --to=balaton@eik.bme.hu \
    --cc=mark.cave-ayland@ilande.co.uk \
    --cc=qemu-devel@nongnu.org \
    --cc=qemu-ppc@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.