From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-14.8 required=3.0 tests=BAYES_00,DKIM_SIGNED, DKIM_VALID,DKIM_VALID_AU,HEADER_FROM_DIFFERENT_DOMAINS,MAILING_LIST_MULTI, NICE_REPLY_A,SPF_HELO_NONE,SPF_PASS,USER_AGENT_SANE_1,USER_IN_DEF_DKIM_WL autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 08CC4C48BC2 for ; Fri, 25 Jun 2021 17:05:23 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id E4A016194F for ; Fri, 25 Jun 2021 17:05:22 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S230025AbhFYRHm (ORCPT ); Fri, 25 Jun 2021 13:07:42 -0400 Received: from linux.microsoft.com ([13.77.154.182]:40074 "EHLO linux.microsoft.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S229630AbhFYRHk (ORCPT ); Fri, 25 Jun 2021 13:07:40 -0400 Received: from [192.168.254.32] (unknown [47.187.214.213]) by linux.microsoft.com (Postfix) with ESMTPSA id D7D1320B6C50; Fri, 25 Jun 2021 10:05:18 -0700 (PDT) DKIM-Filter: OpenDKIM Filter v2.11.0 linux.microsoft.com D7D1320B6C50 DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=linux.microsoft.com; s=default; t=1624640719; bh=UD+BcbDrEM2gSB6paV5YXzW78vc08XXoCGTvEEINV80=; h=Subject:To:Cc:References:From:Date:In-Reply-To:From; b=X1zzO73pT7lIAH1H7ftc3htOKEyCYdRZg/ULZnydJNZyYzIw5egr9/DXNmILLHur1 kpCC2DiQecmwU91SeljGYC8jawn/gCBMcY3cEk9CTm5uVEM+H7feWSI80BqWtjJh+M I7fJgV3KSIz0q2Cegvg8udOQ8vteE14TNmxlJoNc= Subject: Re: [RFC PATCH v5 1/2] arm64: Introduce stack trace reliability checks in the unwinder To: Mark Brown Cc: Mark Rutland , jpoimboe@redhat.com, ardb@kernel.org, nobuta.keiya@fujitsu.com, catalin.marinas@arm.com, will@kernel.org, jmorris@namei.org, pasha.tatashin@soleen.com, jthierry@redhat.com, linux-arm-kernel@lists.infradead.org, live-patching@vger.kernel.org, linux-kernel@vger.kernel.org References: <20210526214917.20099-1-madvenka@linux.microsoft.com> <20210526214917.20099-2-madvenka@linux.microsoft.com> <20210624144021.GA17937@C02TD0UTHF1T.local> <20210625155127.GC4492@sirena.org.uk> From: "Madhavan T. Venkataraman" Message-ID: Date: Fri, 25 Jun 2021 12:05:18 -0500 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.11.0 MIME-Version: 1.0 In-Reply-To: <20210625155127.GC4492@sirena.org.uk> Content-Type: text/plain; charset=windows-1252 Content-Language: en-US Content-Transfer-Encoding: 7bit Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 6/25/21 10:51 AM, Mark Brown wrote: > On Fri, Jun 25, 2021 at 10:39:57AM -0500, Madhavan T. Venkataraman wrote: >> On 6/24/21 9:40 AM, Mark Rutland wrote: > >>> At a high-level, I'm on-board with keeping track of this per unwind >>> step, but if we do that then I want to be abel to use this during >>> regular unwinds (e.g. so that we can have a backtrace idicate when a >>> step is not reliable, like x86 does with '?'), and to do that we need to >>> be a little more accurate. > >> The only consumer of frame->reliable is livepatch. So, in retrospect, my >> original per-frame reliability flag was an overkill. I was just trying to >> provide extra per-frame debug information which is not really a requirement >> for livepatch. > > It's not a requirement for livepatch but if it's there a per frame > reliability flag would have other uses - for example Mark has mentioned > the way x86 prints a ? next to unreliable entries in oops output for > example, that'd be handy for people debugging issues and would have the > added bonus of ensuring that there's more constant and widespread > exercising of the reliability stuff than if it's just used for livepatch > which is a bit niche. > I agree. That is why I introduced the per-frame flag. So, let us try a different approach. First, let us get rid of the frame->reliable flag from this patch series. That flag can be implemented when all of the pieces are in place for per-frame debug and tracking. For consumers such as livepatch that don't really care about per-frame stuff, let us solve it more cleanly via the return value of unwind_frame(). Currently, the return value from unwind_frame() is a tri-state return value which is somewhat confusing. 0 means continue unwinding -error means stop unwinding. However, -ENOENT means successful termination Other values mean an error has happened. Instead, let unwind_frame() return one of 3 values: enum { UNWIND_CONTINUE, UNWIND_CONTINUE_WITH_ERRORS, UNWIND_STOP, }; All consumers will stop unwinding upon seeing UNWIND_STOP. Livepatch type consumers will stop unwinding upon seeing anything other than UNWIND_CONTINUE. Debug type consumers can choose to continue upon seeing UNWIND_CONTINUE_WITH_ERRORS. When we eventually implement per-frame stuff, debug consumers can examine the frame for more information when they see UNWIND_CONTINUE_WITH_ERRORS. This way, my patch series does not have a dependency on the per-frame enhancements. >> So, let us separate the two. I will rename frame->reliable to frame->livepatch_safe. >> This will apply to the whole stacktrace and not to every frame. > > I'd rather keep it as reliable, even with only the livepatch usage I > think it's clearer. > See suggestion above. >> Finally, it might be a good idea to perform reliability checks even in >> start_backtrace() so we don't assume that the starting frame is reliable even >> if the caller passes livepatch_safe=true. What do you think? > > That makes sense to me. > Thanks. Madhavan From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-5.6 required=3.0 tests=BAYES_00,DKIMWL_WL_HIGH, DKIM_SIGNED,DKIM_VALID,HEADER_FROM_DIFFERENT_DOMAINS,MAILING_LIST_MULTI, NICE_REPLY_A,SPF_HELO_NONE,SPF_PASS,USER_AGENT_SANE_1 autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 59F6BC2B9F4 for ; Fri, 25 Jun 2021 17:06:53 +0000 (UTC) Received: from bombadil.infradead.org (bombadil.infradead.org [198.137.202.133]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by mail.kernel.org (Postfix) with ESMTPS id 2843061949 for ; Fri, 25 Jun 2021 17:06:53 +0000 (UTC) DMARC-Filter: OpenDMARC Filter v1.3.2 mail.kernel.org 2843061949 Authentication-Results: mail.kernel.org; dmarc=fail (p=none dis=none) header.from=linux.microsoft.com Authentication-Results: mail.kernel.org; spf=none smtp.mailfrom=linux-arm-kernel-bounces+linux-arm-kernel=archiver.kernel.org@lists.infradead.org DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=lists.infradead.org; s=bombadil.20210309; h=Sender: Content-Transfer-Encoding:Content-Type:List-Subscribe:List-Help:List-Post: List-Archive:List-Unsubscribe:List-Id:In-Reply-To:MIME-Version:Date: Message-ID:From:References:Cc:To:Subject:Reply-To:Content-ID: Content-Description:Resent-Date:Resent-From:Resent-Sender:Resent-To:Resent-Cc :Resent-Message-ID:List-Owner; bh=TlbdfsQ7ZOod/tCg4sr/duZ6RWuZGz4rbcLcvpUOb8g=; b=R9xjmfBcAh5U735q68jCZPsc9P VfVLVenpdK2Bcs9ZwrLgqsoaobi8wJ16RQNB35NjtfWIF9Al+UAD1GeTT9KqNUZmCrZPiz/GjDzuu k5kJeaoEu7Xi+OYql1+SSS7vUURBaMcf7pWEq5gMoX0leOdl1xvjjzODh7ACeKGehKtigK+hvoAlP G9vKaG2F6zcDaFZvmA6XIwgNfGApZFaXf2A2rK9bfy2Nx6whdbCUHBUmp4gSYeGzzEYQWVOVXzu2W 8AdHRlTdwqtKhgtvClSGMPMqI0zLk5TsLBwGo3ne8USAi8LIOXIgvs3BCqP7thogUDsEdz9HS4zkW jT0pGCoQ==; Received: from localhost ([::1] helo=bombadil.infradead.org) by bombadil.infradead.org with esmtp (Exim 4.94.2 #2 (Red Hat Linux)) id 1lwpGe-002OIf-IV; Fri, 25 Jun 2021 17:05:24 +0000 Received: from linux.microsoft.com ([13.77.154.182]) by bombadil.infradead.org with esmtp (Exim 4.94.2 #2 (Red Hat Linux)) id 1lwpGa-002OI4-ID for linux-arm-kernel@lists.infradead.org; Fri, 25 Jun 2021 17:05:22 +0000 Received: from [192.168.254.32] (unknown [47.187.214.213]) by linux.microsoft.com (Postfix) with ESMTPSA id D7D1320B6C50; Fri, 25 Jun 2021 10:05:18 -0700 (PDT) DKIM-Filter: OpenDKIM Filter v2.11.0 linux.microsoft.com D7D1320B6C50 DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=linux.microsoft.com; s=default; t=1624640719; bh=UD+BcbDrEM2gSB6paV5YXzW78vc08XXoCGTvEEINV80=; h=Subject:To:Cc:References:From:Date:In-Reply-To:From; b=X1zzO73pT7lIAH1H7ftc3htOKEyCYdRZg/ULZnydJNZyYzIw5egr9/DXNmILLHur1 kpCC2DiQecmwU91SeljGYC8jawn/gCBMcY3cEk9CTm5uVEM+H7feWSI80BqWtjJh+M I7fJgV3KSIz0q2Cegvg8udOQ8vteE14TNmxlJoNc= Subject: Re: [RFC PATCH v5 1/2] arm64: Introduce stack trace reliability checks in the unwinder To: Mark Brown Cc: Mark Rutland , jpoimboe@redhat.com, ardb@kernel.org, nobuta.keiya@fujitsu.com, catalin.marinas@arm.com, will@kernel.org, jmorris@namei.org, pasha.tatashin@soleen.com, jthierry@redhat.com, linux-arm-kernel@lists.infradead.org, live-patching@vger.kernel.org, linux-kernel@vger.kernel.org References: <20210526214917.20099-1-madvenka@linux.microsoft.com> <20210526214917.20099-2-madvenka@linux.microsoft.com> <20210624144021.GA17937@C02TD0UTHF1T.local> <20210625155127.GC4492@sirena.org.uk> From: "Madhavan T. Venkataraman" Message-ID: Date: Fri, 25 Jun 2021 12:05:18 -0500 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.11.0 MIME-Version: 1.0 In-Reply-To: <20210625155127.GC4492@sirena.org.uk> Content-Language: en-US X-CRM114-Version: 20100106-BlameMichelson ( TRE 0.8.0 (BSD) ) MR-646709E3 X-CRM114-CacheID: sfid-20210625_100520_765601_61D42476 X-CRM114-Status: GOOD ( 26.75 ) X-BeenThere: linux-arm-kernel@lists.infradead.org X-Mailman-Version: 2.1.34 Precedence: list List-Id: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Sender: "linux-arm-kernel" Errors-To: linux-arm-kernel-bounces+linux-arm-kernel=archiver.kernel.org@lists.infradead.org On 6/25/21 10:51 AM, Mark Brown wrote: > On Fri, Jun 25, 2021 at 10:39:57AM -0500, Madhavan T. Venkataraman wrote: >> On 6/24/21 9:40 AM, Mark Rutland wrote: > >>> At a high-level, I'm on-board with keeping track of this per unwind >>> step, but if we do that then I want to be abel to use this during >>> regular unwinds (e.g. so that we can have a backtrace idicate when a >>> step is not reliable, like x86 does with '?'), and to do that we need to >>> be a little more accurate. > >> The only consumer of frame->reliable is livepatch. So, in retrospect, my >> original per-frame reliability flag was an overkill. I was just trying to >> provide extra per-frame debug information which is not really a requirement >> for livepatch. > > It's not a requirement for livepatch but if it's there a per frame > reliability flag would have other uses - for example Mark has mentioned > the way x86 prints a ? next to unreliable entries in oops output for > example, that'd be handy for people debugging issues and would have the > added bonus of ensuring that there's more constant and widespread > exercising of the reliability stuff than if it's just used for livepatch > which is a bit niche. > I agree. That is why I introduced the per-frame flag. So, let us try a different approach. First, let us get rid of the frame->reliable flag from this patch series. That flag can be implemented when all of the pieces are in place for per-frame debug and tracking. For consumers such as livepatch that don't really care about per-frame stuff, let us solve it more cleanly via the return value of unwind_frame(). Currently, the return value from unwind_frame() is a tri-state return value which is somewhat confusing. 0 means continue unwinding -error means stop unwinding. However, -ENOENT means successful termination Other values mean an error has happened. Instead, let unwind_frame() return one of 3 values: enum { UNWIND_CONTINUE, UNWIND_CONTINUE_WITH_ERRORS, UNWIND_STOP, }; All consumers will stop unwinding upon seeing UNWIND_STOP. Livepatch type consumers will stop unwinding upon seeing anything other than UNWIND_CONTINUE. Debug type consumers can choose to continue upon seeing UNWIND_CONTINUE_WITH_ERRORS. When we eventually implement per-frame stuff, debug consumers can examine the frame for more information when they see UNWIND_CONTINUE_WITH_ERRORS. This way, my patch series does not have a dependency on the per-frame enhancements. >> So, let us separate the two. I will rename frame->reliable to frame->livepatch_safe. >> This will apply to the whole stacktrace and not to every frame. > > I'd rather keep it as reliable, even with only the livepatch usage I > think it's clearer. > See suggestion above. >> Finally, it might be a good idea to perform reliability checks even in >> start_backtrace() so we don't assume that the starting frame is reliable even >> if the caller passes livepatch_safe=true. What do you think? > > That makes sense to me. > Thanks. Madhavan _______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel