All of lore.kernel.org
 help / color / mirror / Atom feed
* [RESEND PATCH] btrfs: rename btrfs_alloc_chunk to btrfs_create_chunk
@ 2021-08-18 10:41 Nikolay Borisov
  2021-08-18 22:28 ` David Sterba
  0 siblings, 1 reply; 4+ messages in thread
From: Nikolay Borisov @ 2021-08-18 10:41 UTC (permalink / raw)
  To: linux-btrfs; +Cc: Nikolay Borisov, Filipe Manana

The user facing function used to allocate new chunks is
btrfs_chunk_alloc, unfortunately there is yet another similar sounding
function - btrfs_alloc_chunk. This creates confusion, especially since
the latter function can be considered "private" in the sense that it
implements the first stage of chunk creation and as such is called by
btrfs_chunk_alloc.

To avoid the awkwardness that comes with having similarly named but
distinctly different in their purpose function rename btrfs_alloc_chunk
to btrfs_create_chunk, given that the main purpose of this function is
to orchestrate the whole process of allocating a chunk - reserving space
into devices, deciding on characteristics of the stripe size and
creating the in-memory structures.

Signed-off-by: Nikolay Borisov <nborisov@suse.com>
Reviewed-by: Filipe Manana <fdmanana@suse.com>
---
 fs/btrfs/block-group.c | 6 +++---
 fs/btrfs/volumes.c     | 8 ++++----
 fs/btrfs/volumes.h     | 2 +-
 3 files changed, 8 insertions(+), 8 deletions(-)

diff --git a/fs/btrfs/block-group.c b/fs/btrfs/block-group.c
index a3b830b8410a..1f8b06afbd03 100644
--- a/fs/btrfs/block-group.c
+++ b/fs/btrfs/block-group.c
@@ -3380,7 +3380,7 @@ static int do_chunk_alloc(struct btrfs_trans_handle *trans, u64 flags)
 	 */
 	check_system_chunk(trans, flags);

-	bg = btrfs_alloc_chunk(trans, flags);
+	bg = btrfs_create_chunk(trans, flags);
 	if (IS_ERR(bg)) {
 		ret = PTR_ERR(bg);
 		goto out;
@@ -3441,7 +3441,7 @@ static int do_chunk_alloc(struct btrfs_trans_handle *trans, u64 flags)
 		const u64 sys_flags = btrfs_system_alloc_profile(trans->fs_info);
 		struct btrfs_block_group *sys_bg;

-		sys_bg = btrfs_alloc_chunk(trans, sys_flags);
+		sys_bg = btrfs_create_chunk(trans, sys_flags);
 		if (IS_ERR(sys_bg)) {
 			ret = PTR_ERR(sys_bg);
 			btrfs_abort_transaction(trans, ret);
@@ -3734,7 +3734,7 @@ void check_system_chunk(struct btrfs_trans_handle *trans, u64 type)
 		 * could deadlock on an extent buffer since our caller may be
 		 * COWing an extent buffer from the chunk btree.
 		 */
-		bg = btrfs_alloc_chunk(trans, flags);
+		bg = btrfs_create_chunk(trans, flags);
 		if (IS_ERR(bg)) {
 			ret = PTR_ERR(bg);
 		} else if (!(type & BTRFS_BLOCK_GROUP_SYSTEM)) {
diff --git a/fs/btrfs/volumes.c b/fs/btrfs/volumes.c
index 7fec0c68b744..26f8d5825121 100644
--- a/fs/btrfs/volumes.c
+++ b/fs/btrfs/volumes.c
@@ -3066,7 +3066,7 @@ int btrfs_remove_chunk(struct btrfs_trans_handle *trans, u64 chunk_offset)
 		const u64 sys_flags = btrfs_system_alloc_profile(fs_info);
 		struct btrfs_block_group *sys_bg;

-		sys_bg = btrfs_alloc_chunk(trans, sys_flags);
+		sys_bg = btrfs_create_chunk(trans, sys_flags);
 		if (IS_ERR(sys_bg)) {
 			ret = PTR_ERR(sys_bg);
 			btrfs_abort_transaction(trans, ret);
@@ -5347,7 +5347,7 @@ static struct btrfs_block_group *create_chunk(struct btrfs_trans_handle *trans,
 	return block_group;
 }

-struct btrfs_block_group *btrfs_alloc_chunk(struct btrfs_trans_handle *trans,
+struct btrfs_block_group *btrfs_create_chunk(struct btrfs_trans_handle *trans,
 					    u64 type)
 {
 	struct btrfs_fs_info *info = trans->fs_info;
@@ -5548,12 +5548,12 @@ static noinline int init_first_rw_device(struct btrfs_trans_handle *trans)
 	 */

 	alloc_profile = btrfs_metadata_alloc_profile(fs_info);
-	meta_bg = btrfs_alloc_chunk(trans, alloc_profile);
+	meta_bg = btrfs_create_chunk(trans, alloc_profile);
 	if (IS_ERR(meta_bg))
 		return PTR_ERR(meta_bg);

 	alloc_profile = btrfs_system_alloc_profile(fs_info);
-	sys_bg = btrfs_alloc_chunk(trans, alloc_profile);
+	sys_bg = btrfs_create_chunk(trans, alloc_profile);
 	if (IS_ERR(sys_bg))
 		return PTR_ERR(sys_bg);

diff --git a/fs/btrfs/volumes.h b/fs/btrfs/volumes.h
index b082250b42e0..4efdfaa68e76 100644
--- a/fs/btrfs/volumes.h
+++ b/fs/btrfs/volumes.h
@@ -450,7 +450,7 @@ int btrfs_get_io_geometry(struct btrfs_fs_info *fs_info, struct extent_map *map,
 			  struct btrfs_io_geometry *io_geom);
 int btrfs_read_sys_array(struct btrfs_fs_info *fs_info);
 int btrfs_read_chunk_tree(struct btrfs_fs_info *fs_info);
-struct btrfs_block_group *btrfs_alloc_chunk(struct btrfs_trans_handle *trans,
+struct btrfs_block_group *btrfs_create_chunk(struct btrfs_trans_handle *trans,
 					    u64 type);
 void btrfs_mapping_tree_free(struct extent_map_tree *tree);
 blk_status_t btrfs_map_bio(struct btrfs_fs_info *fs_info, struct bio *bio,
--
2.25.1


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [RESEND PATCH] btrfs: rename btrfs_alloc_chunk to btrfs_create_chunk
  2021-08-18 10:41 [RESEND PATCH] btrfs: rename btrfs_alloc_chunk to btrfs_create_chunk Nikolay Borisov
@ 2021-08-18 22:28 ` David Sterba
  2021-08-20  4:27   ` [PATCH] btrfs: fix stale reference to __btrfs_alloc_chunk Anand Jain
  0 siblings, 1 reply; 4+ messages in thread
From: David Sterba @ 2021-08-18 22:28 UTC (permalink / raw)
  To: Nikolay Borisov; +Cc: linux-btrfs, Filipe Manana

On Wed, Aug 18, 2021 at 01:41:19PM +0300, Nikolay Borisov wrote:
> The user facing function used to allocate new chunks is
> btrfs_chunk_alloc, unfortunately there is yet another similar sounding
> function - btrfs_alloc_chunk. This creates confusion, especially since
> the latter function can be considered "private" in the sense that it
> implements the first stage of chunk creation and as such is called by
> btrfs_chunk_alloc.
> 
> To avoid the awkwardness that comes with having similarly named but
> distinctly different in their purpose function rename btrfs_alloc_chunk
> to btrfs_create_chunk, given that the main purpose of this function is
> to orchestrate the whole process of allocating a chunk - reserving space
> into devices, deciding on characteristics of the stripe size and
> creating the in-memory structures.
> 
> Signed-off-by: Nikolay Borisov <nborisov@suse.com>
> Reviewed-by: Filipe Manana <fdmanana@suse.com>

Added to misc-next, thanks.

^ permalink raw reply	[flat|nested] 4+ messages in thread

* [PATCH] btrfs: fix stale reference to __btrfs_alloc_chunk
  2021-08-18 22:28 ` David Sterba
@ 2021-08-20  4:27   ` Anand Jain
  2021-08-20 10:38     ` David Sterba
  0 siblings, 1 reply; 4+ messages in thread
From: Anand Jain @ 2021-08-20  4:27 UTC (permalink / raw)
  To: linux-btrfs; +Cc: dsterba, nborisov

__btrfs_alloc_chunk() is renamed to btrfs_alloc_chunk() and then to
btrfs_create_chunk() in the commits 11c67b1a40b0 and ad6b24de1d50
respectively. And left the stale reference to __btrfs_alloc_chunk().
Fix them.

Signed-off-by: Anand Jain <anand.jain@oracle.com>
---

David/Nikolay,

I commented about this earlier [1]

 [1]
 https://patchwork.kernel.org/project/linux-btrfs/patch/20210705091643.3404691-1-nborisov@suse.com/

I am fine if you want to rollup this patch to the patch (btrfs: rename
btrfs_alloc_chunk to btrfs_create_chunk) and add my RB, or add this patch
as a new one.

Thx.

 fs/btrfs/volumes.c | 2 +-
 fs/btrfs/zoned.c   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/fs/btrfs/volumes.c b/fs/btrfs/volumes.c
index f3a958a214ff..f915c1d6bb9b 100644
--- a/fs/btrfs/volumes.c
+++ b/fs/btrfs/volumes.c
@@ -4941,7 +4941,7 @@ static void check_raid1c34_incompat_flag(struct btrfs_fs_info *info, u64 type)
 }
 
 /*
- * Structure used internally for __btrfs_alloc_chunk() function.
+ * Structure used internally for btrfs_create_chunk() function.
  * Wraps needed parameters.
  */
 struct alloc_chunk_ctl {
diff --git a/fs/btrfs/zoned.c b/fs/btrfs/zoned.c
index 47af1ab3bf12..90d9df131fc1 100644
--- a/fs/btrfs/zoned.c
+++ b/fs/btrfs/zoned.c
@@ -585,7 +585,7 @@ int btrfs_check_zoned_mode(struct btrfs_fs_info *fs_info)
 
 	/*
 	 * stripe_size is always aligned to BTRFS_STRIPE_LEN in
-	 * __btrfs_alloc_chunk(). Since we want stripe_len == zone_size,
+	 * btrfs_create_chunk(). Since we want stripe_len == zone_size,
 	 * check the alignment here.
 	 */
 	if (!IS_ALIGNED(zone_size, BTRFS_STRIPE_LEN)) {
-- 
2.31.1


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH] btrfs: fix stale reference to __btrfs_alloc_chunk
  2021-08-20  4:27   ` [PATCH] btrfs: fix stale reference to __btrfs_alloc_chunk Anand Jain
@ 2021-08-20 10:38     ` David Sterba
  0 siblings, 0 replies; 4+ messages in thread
From: David Sterba @ 2021-08-20 10:38 UTC (permalink / raw)
  To: Anand Jain; +Cc: linux-btrfs, dsterba, nborisov

On Fri, Aug 20, 2021 at 12:27:52PM +0800, Anand Jain wrote:
> __btrfs_alloc_chunk() is renamed to btrfs_alloc_chunk() and then to
> btrfs_create_chunk() in the commits 11c67b1a40b0 and ad6b24de1d50
> respectively. And left the stale reference to __btrfs_alloc_chunk().
> Fix them.
> 
> Signed-off-by: Anand Jain <anand.jain@oracle.com>
> ---
> 
> David/Nikolay,
> 
> I commented about this earlier [1]
> 
>  [1]
>  https://patchwork.kernel.org/project/linux-btrfs/patch/20210705091643.3404691-1-nborisov@suse.com/

I missed that sorry and also expected that when a patch gets resent all
the feedback is also incorporated.

> I am fine if you want to rollup this patch to the patch (btrfs: rename
> btrfs_alloc_chunk to btrfs_create_chunk) and add my RB, or add this patch
> as a new one.

I'll fold it into the patch plus RB, thanks.

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2021-08-20 10:41 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-08-18 10:41 [RESEND PATCH] btrfs: rename btrfs_alloc_chunk to btrfs_create_chunk Nikolay Borisov
2021-08-18 22:28 ` David Sterba
2021-08-20  4:27   ` [PATCH] btrfs: fix stale reference to __btrfs_alloc_chunk Anand Jain
2021-08-20 10:38     ` David Sterba

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.