All of lore.kernel.org
 help / color / mirror / Atom feed
From: Ramalingam C <ramalingam.c@intel.com>
To: "Shankar, Uma" <uma.shankar@intel.com>,
	"intel-gfx@lists.freedesktop.org"
	<intel-gfx@lists.freedesktop.org>,
	"dri-devel@lists.freedesktop.org"
	<dri-devel@lists.freedesktop.org>,
	"daniel@ffwll.ch" <daniel@ffwll.ch>,
	"seanpaul@chromium.org" <seanpaul@chromium.org>,
	"Winkler, Tomas" <tomas.winkler@intel.com>,
	"Usyskin, Alexander" <alexander.usyskin@intel.com>
Subject: Re: [PATCH v6 01/35] drm: hdcp2.2 authentication msg definitions
Date: Wed, 1 Aug 2018 16:44:06 +0530	[thread overview]
Message-ID: <e8682307-1e4c-e112-714e-a5b4afdd9448@intel.com> (raw)
In-Reply-To: <E7C9878FBA1C6D42A1CA3F62AEB6945F7F3619D7@BGSMSX104.gar.corp.intel.com>

Thanks Uma, for the review.

On Tuesday 31 July 2018 11:51 AM, Shankar, Uma wrote:
>
>> -----Original Message-----
>> From: dri-devel [mailto:dri-devel-bounces@lists.freedesktop.org] On Behalf Of
>> Ramalingam C
>> Sent: Saturday, July 14, 2018 8:45 AM
>> To: intel-gfx@lists.freedesktop.org; dri-devel@lists.freedesktop.org;
>> daniel@ffwll.ch; seanpaul@chromium.org; Winkler, Tomas
>> <tomas.winkler@intel.com>; Usyskin, Alexander <alexander.usyskin@intel.com>;
>> Shankar, Uma <uma.shankar@intel.com>
>> Subject: [PATCH v6 01/35] drm: hdcp2.2 authentication msg definitions
>>
>> This patch defines the hdcp2.2 protocol messages for authentication.
>>
>> v2:
>>   bit_fields are removed. Instead bitmasking used. [Tomas and Jani]
>>   prefix HDCP_2_2_ is added to the macros. [Tomas]
>> v3:
>>   No Changes.
>> v4:
>>   Style and spellings are fixed [Uma]
>> v5:
>>   Fix for macros.
>> v6:
>>   comment for Type is improved [Sean Paul]
>>
>> Signed-off-by: Ramalingam C <ramalingam.c@intel.com>
>> ---
>> include/drm/drm_hdcp.h | 184
>> +++++++++++++++++++++++++++++++++++++++++++++++++
>> 1 file changed, 184 insertions(+)
>>
>> diff --git a/include/drm/drm_hdcp.h b/include/drm/drm_hdcp.h index
>> 98e63d870139..a2a4a159fcde 100644
>> --- a/include/drm/drm_hdcp.h
>> +++ b/include/drm/drm_hdcp.h
>> @@ -38,4 +38,188 @@
>> #define DRM_HDCP_DDC_BSTATUS			0x41
>> #define DRM_HDCP_DDC_KSV_FIFO			0x43
>>
>> +#define DRM_HDCP_1_4_SRM_ID			0x8
>> +#define DRM_HDCP_1_4_VRL_LENGTH_SIZE		3
>> +#define DRM_HDCP_1_4_DCP_SIG_SIZE		40
>> +
>> +/* Protocol message definition for HDCP2.2 specification */
>> +/*
>> + * Protected content streams are classified into 2 types:
>> + * - Type0: Can be transmitted with HDCP 1.4+
>> + * - Type1: Can be transmitted with HDCP 2.2+  */
>> +#define HDCP_STREAM_TYPE0			0x00
>> +#define HDCP_STREAM_TYPE1			0x01
>> +
>> +/* HDCP2.2 Msg IDs */
>> +#define HDCP_2_2_NULL_MSG			1
>> +#define HDCP_2_2_AKE_INIT			2
>> +#define HDCP_2_2_AKE_SEND_CERT			3
>> +#define HDCP_2_2_AKE_NO_STORED_KM		4
>> +#define HDCP_2_2_AKE_STORED_KM			5
>> +#define HDCP_2_2_AKE_SEND_HPRIME		7
>> +#define HDCP_2_2_AKE_SEND_PAIRING_INFO		8
>> +#define HDCP_2_2_LC_INIT			9
>> +#define HDCP_2_2_LC_SEND_LPRIME			10
>> +#define HDCP_2_2_SKE_SEND_EKS			11
>> +#define HDCP_2_2_REP_SEND_RECVID_LIST		12
>> +#define HDCP_2_2_REP_SEND_ACK			15
>> +#define HDCP_2_2_REP_STREAM_MANAGE		16
>> +#define HDCP_2_2_REP_STREAM_READY		17
>> +#define HDCP_2_2_ERRATA_DP_STREAM_TYPE		50
>> +
>> +#define HDCP_2_2_RTX_LEN			8
>> +#define HDCP_2_2_RRX_LEN			8
>> +
>> +#define HDCP_2_2_K_PUB_RX_MOD_N_LEN		128
>> +#define HDCP_2_2_K_PUB_RX_EXP_E_LEN		3
>> +#define HDCP_2_2_K_PUB_RX_LEN
>> 	(HDCP_2_2_K_PUB_RX_MOD_N_LEN + \
>> +
>> HDCP_2_2_K_PUB_RX_EXP_E_LEN)
>> +
>> +#define HDCP_2_2_DCP_LLC_SIG_LEN		384
>> +
>> +#define HDCP_2_2_E_KPUB_KM_LEN			128
>> +#define HDCP_2_2_E_KH_KM_M_LEN			(16 + 16)
>> +#define HDCP_2_2_H_PRIME_LEN			32
>> +#define HDCP_2_2_E_KH_KM_LEN			16
>> +#define HDCP_2_2_RN_LEN				8
>> +#define HDCP_2_2_L_PRIME_LEN			32
>> +#define HDCP_2_2_E_DKEY_KS_LEN			16
>> +#define HDCP_2_2_RIV_LEN			8
>> +#define HDCP_2_2_SEQ_NUM_LEN			3
>> +#define HDCP_2_2_LPRIME_HALF_LEN		(HDCP_2_2_L_PRIME_LEN / 2)
>> +#define HDCP_2_2_RECEIVER_ID_LEN		DRM_HDCP_KSV_LEN
>> +#define HDCP_2_2_MAX_DEVICE_COUNT		31
>> +#define HDCP_2_2_RECEIVER_IDS_MAX_LEN
>> 	(HDCP_2_2_RECEIVER_ID_LEN * \
>> +
>> HDCP_2_2_MAX_DEVICE_COUNT)
>> +#define HDCP_2_2_MPRIME_LEN			32
>> +
>> +/* Following Macros take a byte at a time for bit(s) masking */
>> +/*
>> + * TODO: This has to be changed for DP MST, as multiple stream on
>> + * same port is possible.
>> + * For HDCP2.2 on HDMI and DP SST this value is always 1.
>> + */
>> +#define HDCP_2_2_MAX_CONTENT_STREAMS_CNT	1
>> +#define HDCP_2_2_TXCAP_MASK_LEN			2
>> +#define HDCP_2_2_RXCAPS_LEN			3
>> +#define HDCP_2_2_RX_REPEATER(x)			((x) & BIT(0))
>> +#define HDCP_2_2_DP_HDCP_CAPABLE(x)		((x) & BIT(1))
>> +#define HDCP_2_2_RXINFO_LEN			2
>> +
>> +/* HDCP1.x compliant device in downstream */
>> +#define HDCP_2_2_HDCP1_DEVICE_CONNECTED(x)	((x) & BIT(0))
>> +
>> +/* HDCP2.0 Compliant repeater in downstream */
>> +#define HDCP_2_2_HDCP_2_0_REP_CONNECTED(x)	((x) & BIT(1))
>> +#define HDCP_2_2_MAX_CASCADE_EXCEEDED(x)	((x) & BIT(2))
>> +#define HDCP_2_2_MAX_DEVS_EXCEEDED(x)		((x) & BIT(3))
>> +#define HDCP_2_2_DEV_COUNT_LO(x)		(((x) & (0xF << 4)) >> 4)
>> +#define HDCP_2_2_DEV_COUNT_HI(x)		((x) & BIT(0))
>> +#define HDCP_2_2_DEPTH(x)			(((x) & (0x7 << 1)) >> 1)
>> +
>> +struct hdcp2_cert_rx {
>> +	uint8_t	receiver_id[HDCP_2_2_RECEIVER_ID_LEN];
>> +	uint8_t	kpub_rx[HDCP_2_2_K_PUB_RX_LEN];
>> +	uint8_t	reserved[2];
>> +	uint8_t	dcp_signature[HDCP_2_2_DCP_LLC_SIG_LEN];
>> +} __packed;
>> +
>> +struct hdcp2_streamid_type {
>> +	uint8_t stream_id;
>> +	uint8_t stream_type;
>> +} __packed;
>> +
>> +/*
>> + * The TxCaps field specified in the HDCP HDMI, DP specs
>> + * This field is big endian as specified in the errata.
>> + */
>> +struct hdcp2_tx_caps {
>> +	/* Transmitter must set this to 0x2 */
>> +	uint8_t			version;
>> +
>> +	/* Reserved for HDCP and DP Spec. Read as Zero */
>> +	uint8_t			tx_cap_mask[HDCP_2_2_TXCAP_MASK_LEN];
> Seems like extra tabs here, Fixed that universally across all structure definitions.
As we discussed offline, I have added the tab to align across all new 
structures added.
I could restrict the alignment only for that structure alone. :)
>
>> +} __packed;
>> +
>> +/* Main structures for HDCP2.2 protocol communication */ struct
>> +hdcp2_ake_init {
>> +	uint8_t			msg_id;
>> +	uint8_t			r_tx[HDCP_2_2_RTX_LEN];
>> +	struct hdcp2_tx_caps	tx_caps;
>> +} __packed;
>> +
>> +struct hdcp2_ake_send_cert {
>> +	uint8_t			msg_id;
>> +	struct hdcp2_cert_rx	cert_rx;
>> +	uint8_t			r_rx[HDCP_2_2_RRX_LEN];
>> +	uint8_t			rx_caps[HDCP_2_2_RXCAPS_LEN];
>> +} __packed;
>> +
>> +struct hdcp2_ake_no_stored_km {
>> +	uint8_t			msg_id;
>> +	uint8_t			e_kpub_km[HDCP_2_2_E_KPUB_KM_LEN];
>> +} __packed;
>> +
>> +struct hdcp2_ake_stored_km {
>> +	uint8_t			msg_id;
>> +	uint8_t			e_kh_km_m[HDCP_2_2_E_KH_KM_M_LEN];
>> +} __packed;
>> +
>> +struct hdcp2_ake_send_hprime {
>> +	uint8_t			msg_id;
>> +	uint8_t			h_prime[HDCP_2_2_H_PRIME_LEN];
>> +} __packed;
>> +
>> +struct hdcp2_ake_send_pairing_info {
>> +	uint8_t			msg_id;
>> +	uint8_t			e_kh_km[HDCP_2_2_E_KH_KM_LEN];
>> +} __packed;
>> +
>> +struct hdcp2_lc_init {
>> +	uint8_t			msg_id;
>> +	uint8_t			r_n[HDCP_2_2_RN_LEN];
>> +} __packed;
>> +
>> +struct hdcp2_lc_send_lprime {
>> +	uint8_t			msg_id;
>> +	uint8_t			l_prime[HDCP_2_2_L_PRIME_LEN];
>> +} __packed;
>> +
>> +struct hdcp2_ske_send_eks {
>> +	uint8_t			msg_id;
>> +	uint8_t			e_dkey_ks[HDCP_2_2_E_DKEY_KS_LEN];
>> +	uint8_t			riv[HDCP_2_2_RIV_LEN];
>> +} __packed;
>> +
>> +struct hdcp2_rep_send_receiverid_list {
>> +	uint8_t			msg_id;
>> +	uint8_t			rx_info[HDCP_2_2_RXINFO_LEN];
>> +	uint8_t			seq_num_v[HDCP_2_2_SEQ_NUM_LEN];
>> +	uint8_t			v_prime[HDCP_2_2_LPRIME_HALF_LEN];
> Why not call it as Vprime itself instead of lprime_half to match the spec naming ?
This macro is used only in this context. So sure, I will rename it. Thanks!

--Ram
> With the above 2 comments fixed,
> Reviewed-by: Uma Shankar <uma.shankar@intel.com>
>
>> +	uint8_t
>> 	receiver_ids[HDCP_2_2_RECEIVER_IDS_MAX_LEN];
>> +} __packed;
>> +
>> +struct hdcp2_rep_send_ack {
>> +	uint8_t			msg_id;
>> +	uint8_t			v[HDCP_2_2_LPRIME_HALF_LEN];
>> +} __packed;
>> +
>> +struct hdcp2_rep_stream_manage {
>> +	uint8_t			msg_id;
>> +	uint8_t			seq_num_m[HDCP_2_2_SEQ_NUM_LEN];
>> +	__be16			k;
>> +	struct hdcp2_streamid_type
>> streams[HDCP_2_2_MAX_CONTENT_STREAMS_CNT];
>> +} __packed;
>> +
>> +struct hdcp2_rep_stream_ready {
>> +	uint8_t			msg_id;
>> +	uint8_t			m_prime[HDCP_2_2_MPRIME_LEN];
>> +} __packed;
>> +
>> +struct hdcp2_dp_errata_stream_type {
>> +	uint8_t			msg_id;
>> +	uint8_t			stream_type;
>> +} __packed;
>> +
>> #endif
>> --
>> 2.7.4
>>
>> _______________________________________________
>> dri-devel mailing list
>> dri-devel@lists.freedesktop.org
>> https://lists.freedesktop.org/mailman/listinfo/dri-devel

_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

  reply	other threads:[~2018-08-01 11:14 UTC|newest]

Thread overview: 73+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-07-14  3:14 [PATCH v6 00/35] drm/i915: Implement HDCP2.2 Ramalingam C
2018-07-14  3:14 ` [PATCH v6 01/35] drm: hdcp2.2 authentication msg definitions Ramalingam C
2018-07-31  6:21   ` Shankar, Uma
2018-08-01 11:14     ` Ramalingam C [this message]
2018-07-14  3:14 ` [PATCH v6 02/35] drm: HDMI and DP specific HDCP2.2 defines Ramalingam C
2018-07-31  8:25   ` Shankar, Uma
2018-08-01 11:34     ` Ramalingam C
2018-07-14  3:14 ` [PATCH v6 03/35] mei: bus: whitelist hdcp client Ramalingam C
2018-07-14  3:14 ` [PATCH v6 04/35] linux/mei: Header for mei_hdcp driver interface Ramalingam C
2018-07-31  8:39   ` Shankar, Uma
2018-07-14  3:14 ` [PATCH v6 05/35] drm/i915: wrapping all hdcp var into intel_hdcp Ramalingam C
2018-07-31  8:53   ` Shankar, Uma
2018-07-14  3:14 ` [PATCH v6 06/35] drm/i915: Define Intel HDCP2.2 registers Ramalingam C
2018-07-31  8:59   ` Shankar, Uma
2018-07-14  3:14 ` [PATCH v6 07/35] component: alloc component_match without any comp to match Ramalingam C
2018-07-14  3:14 ` [PATCH v6 08/35] drm/i915: component master at i915 driver load Ramalingam C
2018-07-14  3:14 ` [PATCH v6 09/35] drm/i915: Initialize HDCP2.2 and its MEI interface Ramalingam C
2018-07-17  1:29   ` kbuild test robot
2018-07-31 19:41   ` Shankar, Uma
2018-08-01 11:42     ` Ramalingam C
2018-07-14  3:14 ` [PATCH v6 10/35] drm/i915: Pullout the bksv read and validation Ramalingam C
2018-07-14  3:14 ` [PATCH v6 11/35] drm/i915: Enable and Disable of HDCP2.2 Ramalingam C
2018-07-31 20:49   ` Shankar, Uma
2018-07-14  3:14 ` [PATCH v6 12/35] drm/i915: Implement HDCP2.2 receiver authentication Ramalingam C
2018-08-01  9:41   ` Shankar, Uma
2018-08-30  6:34     ` Ramalingam C
2018-07-14  3:14 ` [PATCH v6 13/35] drm/i915: Implement HDCP2.2 repeater authentication Ramalingam C
2018-08-01 10:30   ` Shankar, Uma
2018-08-30  6:49     ` Ramalingam C
2018-07-14  3:14 ` [PATCH v6 14/35] drm/i915: Implement HDCP2.2 link integrity check Ramalingam C
2018-08-01 10:45   ` Shankar, Uma
2018-08-30  6:57     ` Ramalingam C
2018-07-14  3:14 ` [PATCH v6 15/35] drm/i915: Handle HDCP2.2 downstream topology change Ramalingam C
2018-07-14  3:14 ` [PATCH v6 16/35] drm/i915: hdcp_check_link only on CP_IRQ Ramalingam C
2018-07-14  3:14 ` [PATCH v6 17/35] drm/i915: Check HDCP 1.4 and 2.2 link " Ramalingam C
2018-08-01 11:02   ` Shankar, Uma
2018-08-30  7:24     ` Ramalingam C
2018-07-14  3:15 ` [PATCH v6 18/35] drm/i915: Implement the HDCP2.2 support for DP Ramalingam C
2018-08-01 11:31   ` Shankar, Uma
2018-07-14  3:15 ` [PATCH v6 19/35] drm/i915: Implement the HDCP2.2 support for HDMI Ramalingam C
2018-08-01 11:38   ` Shankar, Uma
2018-07-14  3:15 ` [PATCH v6 20/35] drm/i915: Add HDCP2.2 support for DP connectors Ramalingam C
2018-07-14  3:15 ` [PATCH v6 21/35] drm/i915: Add HDCP2.2 support for HDMI connectors Ramalingam C
2018-07-14  3:15 ` [PATCH v6 22/35] misc/mei/hdcp: Client driver for HDCP application Ramalingam C
2018-07-14  3:15 ` [PATCH v6 23/35] misc/mei/hdcp: Component framework for I915 Interface Ramalingam C
2018-08-01 13:06   ` Shankar, Uma
2018-07-14  3:15 ` [PATCH v6 24/35] misc/mei/hdcp: Define ME FW interface for HDCP2.2 Ramalingam C
2018-07-14  3:15 ` [PATCH v6 25/35] misc/mei/hdcp: Initiate Wired HDCP2.2 Tx Session Ramalingam C
2018-08-01 13:13   ` Shankar, Uma
2018-07-14  3:15 ` [PATCH v6 26/35] misc/mei/hdcp: Verify Receiver Cert and prepare km Ramalingam C
2018-08-01 13:18   ` Shankar, Uma
2018-07-14  3:15 ` [PATCH v6 27/35] misc/mei/hdcp: Verify H_prime Ramalingam C
2018-08-01 13:21   ` Shankar, Uma
2018-07-14  3:15 ` [PATCH v6 28/35] misc/mei/hdcp: Store the HDCP Pairing info Ramalingam C
2018-08-01 13:23   ` Shankar, Uma
2018-07-14  3:15 ` [PATCH v6 29/35] misc/mei/hdcp: Initiate Locality check Ramalingam C
2018-08-01 13:24   ` Shankar, Uma
2018-07-14  3:15 ` [PATCH v6 30/35] misc/mei/hdcp: Verify L_prime Ramalingam C
2018-08-01 13:26   ` Shankar, Uma
2018-07-14  3:15 ` [PATCH v6 31/35] misc/mei/hdcp: Prepare Session Key Ramalingam C
2018-08-01 13:29   ` Shankar, Uma
2018-07-14  3:15 ` [PATCH v6 32/35] misc/mei/hdcp: Repeater topology verification and ack Ramalingam C
2018-08-01 13:31   ` Shankar, Uma
2018-07-14  3:15 ` [PATCH v6 33/35] misc/mei/hdcp: Verify M_prime Ramalingam C
2018-08-01 13:33   ` Shankar, Uma
2018-07-14  3:15 ` [PATCH v6 34/35] misc/mei/hdcp: Enabling the HDCP authentication Ramalingam C
2018-08-01 13:36   ` Shankar, Uma
2018-07-14  3:15 ` [PATCH v6 35/35] misc/mei/hdcp: Closing wired HDCP2.2 Tx Session Ramalingam C
2018-08-01 13:38   ` Shankar, Uma
2018-07-14  3:39 ` ✗ Fi.CI.CHECKPATCH: warning for drm/i915: Implement HDCP2.2 (rev8) Patchwork
2018-07-14  3:49 ` ✗ Fi.CI.SPARSE: " Patchwork
2018-07-14  3:55 ` ✗ Fi.CI.BAT: failure " Patchwork
2018-07-30  9:09 ` [PATCH v6 00/35] drm/i915: Implement HDCP2.2 Shankar, Uma

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=e8682307-1e4c-e112-714e-a5b4afdd9448@intel.com \
    --to=ramalingam.c@intel.com \
    --cc=alexander.usyskin@intel.com \
    --cc=daniel@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=intel-gfx@lists.freedesktop.org \
    --cc=seanpaul@chromium.org \
    --cc=tomas.winkler@intel.com \
    --cc=uma.shankar@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.