All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] gcr: depends on gnupg-native
@ 2020-05-11  9:23 kai
  2020-05-14  1:59 ` kai
  0 siblings, 1 reply; 5+ messages in thread
From: kai @ 2020-05-11  9:23 UTC (permalink / raw)
  To: openembedded-core

From: Kai Kang <kai.kang@windriver.com>

It fails to build gcr if no commmand gpg on build host:

| meson.build:44:0: ERROR: Program(s) ['gpg2', 'gpg'] not found or not executable

Add dependency gnupg-native to fix the error.

Signed-off-by: Kai Kang <kai.kang@windriver.com>
---
 meta/recipes-gnome/gcr/gcr_3.36.0.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/meta/recipes-gnome/gcr/gcr_3.36.0.bb b/meta/recipes-gnome/gcr/gcr_3.36.0.bb
index 4fe3b2fff3..458dc8e6c4 100644
--- a/meta/recipes-gnome/gcr/gcr_3.36.0.bb
+++ b/meta/recipes-gnome/gcr/gcr_3.36.0.bb
@@ -8,7 +8,7 @@ BUGTRACKER = "https://gitlab.gnome.org/GNOME/gcr/issues"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
 
-DEPENDS = "gtk+3 p11-kit glib-2.0 libgcrypt \
+DEPENDS = "gtk+3 p11-kit glib-2.0 libgcrypt gnupg-native \
            ${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'libxslt-native', '', d)}"
 
 GNOMEBASEBUILDCLASS = "meson"
-- 
2.17.1


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] gcr: depends on gnupg-native
  2020-05-11  9:23 [PATCH] gcr: depends on gnupg-native kai
@ 2020-05-14  1:59 ` kai
  2020-05-14 13:26   ` [OE-core] " Richard Purdie
  0 siblings, 1 reply; 5+ messages in thread
From: kai @ 2020-05-14  1:59 UTC (permalink / raw)
  To: openembedded-core

On 2020/5/11 下午5:23, kai.kang@windriver.com wrote:
> From: Kai Kang <kai.kang@windriver.com>
>
> It fails to build gcr if no commmand gpg on build host:
>
> | meson.build:44:0: ERROR: Program(s) ['gpg2', 'gpg'] not found or not executable
>
> Add dependency gnupg-native to fix the error.
>
> Signed-off-by: Kai Kang <kai.kang@windriver.com>
> ---
>   meta/recipes-gnome/gcr/gcr_3.36.0.bb | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta/recipes-gnome/gcr/gcr_3.36.0.bb b/meta/recipes-gnome/gcr/gcr_3.36.0.bb
> index 4fe3b2fff3..458dc8e6c4 100644
> --- a/meta/recipes-gnome/gcr/gcr_3.36.0.bb
> +++ b/meta/recipes-gnome/gcr/gcr_3.36.0.bb
> @@ -8,7 +8,7 @@ BUGTRACKER = "https://gitlab.gnome.org/GNOME/gcr/issues"
>   LICENSE = "GPLv2"
>   LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
>   
> -DEPENDS = "gtk+3 p11-kit glib-2.0 libgcrypt \
> +DEPENDS = "gtk+3 p11-kit glib-2.0 libgcrypt gnupg-native \
>              ${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'libxslt-native', '', d)}"
>   
>   GNOMEBASEBUILDCLASS = "meson"

Any comment, please?

-- 
Kai Kang
Wind River Linux


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [OE-core] [PATCH] gcr: depends on gnupg-native
  2020-05-14  1:59 ` kai
@ 2020-05-14 13:26   ` Richard Purdie
  2020-05-14 17:29     ` Alexander Kanavin
  0 siblings, 1 reply; 5+ messages in thread
From: Richard Purdie @ 2020-05-14 13:26 UTC (permalink / raw)
  To: kai, openembedded-core

On Thu, 2020-05-14 at 09:59 +0800, kai wrote:
> On 2020/5/11 下午5:23, kai.kang@windriver.com wrote:
> > From: Kai Kang <kai.kang@windriver.com>
> > 
> > It fails to build gcr if no commmand gpg on build host:
> > 
> > > meson.build:44:0: ERROR: Program(s) ['gpg2', 'gpg'] not found or
> > > not executable
> > 
> > Add dependency gnupg-native to fix the error.
> > 
> > Signed-off-by: Kai Kang <kai.kang@windriver.com>
> > ---
> >   meta/recipes-gnome/gcr/gcr_3.36.0.bb | 2 +-
> >   1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/meta/recipes-gnome/gcr/gcr_3.36.0.bb b/meta/recipes-
> > gnome/gcr/gcr_3.36.0.bb
> > index 4fe3b2fff3..458dc8e6c4 100644
> > --- a/meta/recipes-gnome/gcr/gcr_3.36.0.bb
> > +++ b/meta/recipes-gnome/gcr/gcr_3.36.0.bb
> > @@ -8,7 +8,7 @@ BUGTRACKER = "
> > https://gitlab.gnome.org/GNOME/gcr/issues"
> >   LICENSE = "GPLv2"
> >   LIC_FILES_CHKSUM =
> > "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
> >   
> > -DEPENDS = "gtk+3 p11-kit glib-2.0 libgcrypt \
> > +DEPENDS = "gtk+3 p11-kit glib-2.0 libgcrypt gnupg-native \
> >              ${@bb.utils.contains('GI_DATA_ENABLED', 'True',
> > 'libxslt-native', '', d)}"
> >   
> >   GNOMEBASEBUILDCLASS = "meson"
> 
> Any comment, please?

Why did this happen? Was this as a result of the move to meson? Is it
really needed and can we avoid it? native dependencies like this are a
pain from a build performance perspective...

Cheers,

Richard


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [OE-core] [PATCH] gcr: depends on gnupg-native
  2020-05-14 13:26   ` [OE-core] " Richard Purdie
@ 2020-05-14 17:29     ` Alexander Kanavin
  2020-05-15  1:51       ` kai
  0 siblings, 1 reply; 5+ messages in thread
From: Alexander Kanavin @ 2020-05-14 17:29 UTC (permalink / raw)
  To: Richard Purdie; +Cc: kai, OE-core

[-- Attachment #1: Type: text/plain, Size: 1849 bytes --]

Looking gcr's autotools and meson build files, gpg executable is required
in both. Gcr is needed only by epiphany, so I don't think build performance
will suffer much.

Alex

On Thu, 14 May 2020 at 15:26, Richard Purdie <
richard.purdie@linuxfoundation.org> wrote:

> On Thu, 2020-05-14 at 09:59 +0800, kai wrote:
> > On 2020/5/11 下午5:23, kai.kang@windriver.com wrote:
> > > From: Kai Kang <kai.kang@windriver.com>
> > >
> > > It fails to build gcr if no commmand gpg on build host:
> > >
> > > > meson.build:44:0: ERROR: Program(s) ['gpg2', 'gpg'] not found or
> > > > not executable
> > >
> > > Add dependency gnupg-native to fix the error.
> > >
> > > Signed-off-by: Kai Kang <kai.kang@windriver.com>
> > > ---
> > >   meta/recipes-gnome/gcr/gcr_3.36.0.bb | 2 +-
> > >   1 file changed, 1 insertion(+), 1 deletion(-)
> > >
> > > diff --git a/meta/recipes-gnome/gcr/gcr_3.36.0.bb b/meta/recipes-
> > > gnome/gcr/gcr_3.36.0.bb
> > > index 4fe3b2fff3..458dc8e6c4 100644
> > > --- a/meta/recipes-gnome/gcr/gcr_3.36.0.bb
> > > +++ b/meta/recipes-gnome/gcr/gcr_3.36.0.bb
> > > @@ -8,7 +8,7 @@ BUGTRACKER = "
> > > https://gitlab.gnome.org/GNOME/gcr/issues"
> > >   LICENSE = "GPLv2"
> > >   LIC_FILES_CHKSUM =
> > > "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
> > >
> > > -DEPENDS = "gtk+3 p11-kit glib-2.0 libgcrypt \
> > > +DEPENDS = "gtk+3 p11-kit glib-2.0 libgcrypt gnupg-native \
> > >              ${@bb.utils.contains('GI_DATA_ENABLED', 'True',
> > > 'libxslt-native', '', d)}"
> > >
> > >   GNOMEBASEBUILDCLASS = "meson"
> >
> > Any comment, please?
>
> Why did this happen? Was this as a result of the move to meson? Is it
> really needed and can we avoid it? native dependencies like this are a
> pain from a build performance perspective...
>
> Cheers,
>
> Richard
>
> 
>

[-- Attachment #2: Type: text/html, Size: 3229 bytes --]

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [OE-core] [PATCH] gcr: depends on gnupg-native
  2020-05-14 17:29     ` Alexander Kanavin
@ 2020-05-15  1:51       ` kai
  0 siblings, 0 replies; 5+ messages in thread
From: kai @ 2020-05-15  1:51 UTC (permalink / raw)
  To: Alexander Kanavin, Richard Purdie; +Cc: OE-core

[-- Attachment #1: Type: text/plain, Size: 2654 bytes --]

On 2020/5/15 上午1:29, Alexander Kanavin wrote:
> Looking gcr's autotools and meson build files, gpg executable is 
> required in both. Gcr is needed only by epiphany, so I don't think 
> build performance will suffer much.

It seems gcr requires command gpg long long time ago(about 8 years). But 
I don't know why just exposed recently.

https://gitlab.gnome.org/GNOME/gcr/-/commit/c6691faa0348ab087e99ab9bd9914e1d5e81fa14

Regards,
Kai

>
> Alex
>
> On Thu, 14 May 2020 at 15:26, Richard Purdie 
> <richard.purdie@linuxfoundation.org 
> <mailto:richard.purdie@linuxfoundation.org>> wrote:
>
>     On Thu, 2020-05-14 at 09:59 +0800, kai wrote:
>     > On 2020/5/11 下午5:23, kai.kang@windriver.com
>     <mailto:kai.kang@windriver.com> wrote:
>     > > From: Kai Kang <kai.kang@windriver.com
>     <mailto:kai.kang@windriver.com>>
>     > >
>     > > It fails to build gcr if no commmand gpg on build host:
>     > >
>     > > > meson.build:44:0: ERROR: Program(s) ['gpg2', 'gpg'] not found or
>     > > > not executable
>     > >
>     > > Add dependency gnupg-native to fix the error.
>     > >
>     > > Signed-off-by: Kai Kang <kai.kang@windriver.com
>     <mailto:kai.kang@windriver.com>>
>     > > ---
>     > >   meta/recipes-gnome/gcr/gcr_3.36.0.bb <http://gcr_3.36.0.bb>
>     | 2 +-
>     > >   1 file changed, 1 insertion(+), 1 deletion(-)
>     > >
>     > > diff --git a/meta/recipes-gnome/gcr/gcr_3.36.0.bb
>     <http://gcr_3.36.0.bb> b/meta/recipes-
>     > > gnome/gcr/gcr_3.36.0.bb <http://gcr_3.36.0.bb>
>     > > index 4fe3b2fff3..458dc8e6c4 100644
>     > > --- a/meta/recipes-gnome/gcr/gcr_3.36.0.bb <http://gcr_3.36.0.bb>
>     > > +++ b/meta/recipes-gnome/gcr/gcr_3.36.0.bb <http://gcr_3.36.0.bb>
>     > > @@ -8,7 +8,7 @@ BUGTRACKER = "
>     > > https://gitlab.gnome.org/GNOME/gcr/issues"
>     > >   LICENSE = "GPLv2"
>     > >   LIC_FILES_CHKSUM =
>     > > "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
>     > >
>     > > -DEPENDS = "gtk+3 p11-kit glib-2.0 libgcrypt \
>     > > +DEPENDS = "gtk+3 p11-kit glib-2.0 libgcrypt gnupg-native \
>     > >              ${@bb.utils.contains('GI_DATA_ENABLED', 'True',
>     > > 'libxslt-native', '', d)}"
>     > >
>     > >   GNOMEBASEBUILDCLASS = "meson"
>     >
>     > Any comment, please?
>
>     Why did this happen? Was this as a result of the move to meson? Is it
>     really needed and can we avoid it? native dependencies like this are a
>     pain from a build performance perspective...
>
>     Cheers,
>
>     Richard
>
>     
>

-- 
Kai Kang
Wind River Linux


[-- Attachment #2: Type: text/html, Size: 5472 bytes --]

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2020-05-15  1:52 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-05-11  9:23 [PATCH] gcr: depends on gnupg-native kai
2020-05-14  1:59 ` kai
2020-05-14 13:26   ` [OE-core] " Richard Purdie
2020-05-14 17:29     ` Alexander Kanavin
2020-05-15  1:51       ` kai

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.