From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752930AbdCOLK2 (ORCPT ); Wed, 15 Mar 2017 07:10:28 -0400 Received: from mail-pg0-f68.google.com ([74.125.83.68]:33916 "EHLO mail-pg0-f68.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751868AbdCOLJ3 (ORCPT ); Wed, 15 Mar 2017 07:09:29 -0400 Subject: Re: [PATCH v3 2/8] staging: rtl8192e: Fix coding style To: Dan Carpenter References: <20170312134112.GF27791@kroah.com> <1489571517-3332-1-git-send-email-sunil.m@techveda.org> <1489571517-3332-3-git-send-email-sunil.m@techveda.org> <20170315101442.GZ4136@mwanda> Cc: gregkh@linuxfoundation.org, devel@driverdev.osuosl.org, karthiknishu@yahoo.com, linux-kernel@vger.kernel.org From: Suniel Mahesh Message-ID: Date: Wed, 15 Mar 2017 16:39:20 +0530 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.7.0 MIME-Version: 1.0 In-Reply-To: <20170315101442.GZ4136@mwanda> Content-Type: text/plain; charset=windows-1252; format=flowed Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wednesday 15 March 2017 03:44 PM, Dan Carpenter wrote: > On Wed, Mar 15, 2017 at 03:21:51PM +0530, sunil.m@techveda.org wrote: >> @@ -1796,7 +1796,7 @@ static short _rtl92e_alloc_rx_ring(struct net_device *dev) >> >> for (rx_queue_idx = 0; rx_queue_idx < MAX_RX_QUEUE; rx_queue_idx++) { >> priv->rx_ring[rx_queue_idx] = pci_zalloc_consistent(priv->pdev, >> - sizeof(*priv->rx_ring[rx_queue_idx]) * priv->rxringcount, >> + sizeof(*priv->rx_ring[rx_queue_idx]) * priv->rxringcount, >> &priv->rx_ring_dma[rx_queue_idx]); > > No, don't do that. The original was easier to read. Ignore > checkpatch.pl if it gives you bad advice. > >> if (!priv->rx_ring[rx_queue_idx] || >> (unsigned long)priv->rx_ring[rx_queue_idx] & 0xFF) { >> @@ -2272,7 +2272,8 @@ static int _rtl92e_ioctl(struct net_device *dev, struct ifreq *rq, int cmd) >> int ret = -1; >> struct rtllib_device *ieee = priv->rtllib; >> u32 key[4]; >> - const u8 broadcast_addr[ETH_ALEN] = {0xff, 0xff, 0xff, 0xff, 0xff, 0xff}; >> + const u8 broadcast_addr[ETH_ALEN] = {0xff, 0xff, 0xff, 0xff, 0xff, >> + 0xff}; > > Just drop this patch... The original is better. > > regards, > dan carpenter > hi, when you say drop this patch, should I send the entire patch set as PATCH v4 with this particular patch dropped ? regards suniel