All of lore.kernel.org
 help / color / mirror / Atom feed
From: Takashi Iwai <tiwai@suse.de>
To: Rene Herman <rene.herman@gmail.com>
Cc: ALSA devel <alsa-devel@lists.sourceforge.net>
Subject: Re: isa_bus: ad1848
Date: Mon, 12 Feb 2007 12:54:00 +0100	[thread overview]
Message-ID: <s5hire7mw13.wl%tiwai@suse.de> (raw)
In-Reply-To: <45CFD653.4050401@gmail.com>

At Mon, 12 Feb 2007 03:52:03 +0100,
Rene Herman wrote:
> 

> @@ -44,99 +47,111 @@ static char *id[SNDRV_CARDS] = SNDRV_DEF
>  static int enable[SNDRV_CARDS] = SNDRV_DEFAULT_ENABLE;	/* Enable this card */
>  static long port[SNDRV_CARDS] = SNDRV_DEFAULT_PORT;	/* PnP setup */
>  static int irq[SNDRV_CARDS] = SNDRV_DEFAULT_IRQ;	/* 5,7,9,11,12,15 */
> -static int dma1[SNDRV_CARDS] = SNDRV_DEFAULT_DMA;	/* 0,1,3,5,6,7 */
> +static int dma[SNDRV_CARDS] = SNDRV_DEFAULT_DMA;	/* 0,1,3,5,6,7 */

Renaming a module option is a bad idea.  It breaks the compatibility.

> -static struct platform_device *devices[SNDRV_CARDS];
> +static int __devinit snd_ad1848_match(struct device *dev, unsigned int n)
> +{
> +	int match;
> +
> +	match = enable[n];
> +	if (!match)
> +		goto out;
>  
> +	match = port[n] != SNDRV_AUTO_PORT;
> +	if (!match) {
> +		snd_printk(KERN_ERR "%s: please specify port\n", dev->bus_id);
> +		goto out;
> +	}

I feel simply returning 0 would be easier to read.

>  
> -	strcpy(card->driver, "AD1848");
> +	strcpy(card->driver, DEV_NAME);

This name is exported and referred in alsa-lib, that this change
breaks the compatibility again (it's case-sensitive).


Thanks,

Takashi

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier.
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642

  reply	other threads:[~2007-02-12 11:54 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2007-02-12  2:52 isa_bus: ad1848 Rene Herman
2007-02-12 11:54 ` Takashi Iwai [this message]
2007-02-13  6:11 Rene Herman
2007-02-14  7:19 Rene Herman

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=s5hire7mw13.wl%tiwai@suse.de \
    --to=tiwai@suse.de \
    --cc=alsa-devel@lists.sourceforge.net \
    --cc=rene.herman@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.