All of lore.kernel.org
 help / color / mirror / Atom feed
From: Takashi Iwai <tiwai@suse.de>
To: Lisandro Pin <lisandro@hotmail.com>
Cc: alsa-devel@lists.sourceforge.net
Subject: Re: SIS7012 works but get's frozen
Date: Wed, 23 Jul 2003 10:25:27 +0200	[thread overview]
Message-ID: <s5hsmoxfy4o.wl@alsa2.suse.de> (raw)
In-Reply-To: <BAY2-F35RPQIWDO3hRD000001e3@hotmail.com>

At Wed, 23 Jul 2003 01:55:35 +0000,
Lisandro Pin wrote:
> 
> >From: Takashi Iwai <tiwai@suse.de>
> >To: "Lisandro Pin" <lisandro@hotmail.com>
> >CC: alsa-devel@lists.sourceforge.net
> >Subject: Re: [Alsa-devel] SIS7012 works but get's frozen
> >Date: Tue, 22 Jul 2003 18:47:25 +0200
> >
> >At Tue, 22 Jul 2003 16:43:16 +0000,
> >Lisandro Pin wrote:
> > >
> > > > >    I also have a ECS K7S5A, and i experienced something funny while
> > > >trying
> > > > > to play the attached file (about 45k, sorry, it's the only way :). 
> >It's
> > > >an
> > > > > old ICQ soundclip i wanted to use to warn me of new mail, so i hope 
> >i'm
> > > >not
> > > > > breaking any laws here; but the thing is that trying to play it 
> >directly
> > > > > through ALSA freezes it about 1/2 of the clip. No errors on aplay 
> >(or
> > > >any
> > > > > other player for that sake), just a seg fault. The interesting part 
> >is
> > > >that
> > > > > using a wrapper like arts or esd the file plays just fine.
> > > >
> > > >could you elaborate the status "freeze"?
> > > >does machine still respond?  or a kernel panic?
> > > >if it's a kernel oops, please trace it via ksymoops program.
> > >
> > >   No, just the program. aplay segfaults at about half the clip and XMMS
> > > simply halts and needs to be killed (again, no error message). The 
> >machine
> > > keeps on going but ALSA is mute until the "offending" program ends.
> >
> >hmm, segfaults is evil.  can you get aplay in gdb running?
> >you might need to set LD_PRELOAD=/usr/lib/libasound.so.2 to load the
> >plugins before starting gdb.
> 
> (gdb) run ~/newmail.wav
> The program being debugged has been started already.
> Start it from the beginning? (y or n) y
> 
> Starting program: /usr/bin/aplay ~/newmail.wav
> (no debugging symbols found)...(no debugging symbols found)...
> (no debugging symbols found)...(no debugging symbols found)...[New Thread 
> 16384 (LWP 30679)]
> 
> Playing WAVE '/home/lys/newmail.wav' : Signed 16 bit Little Endian, Rate 
> 44100 Hz, Mono
> (no debugging symbols found)...(no debugging symbols found)...
> Program received signal SIGSEGV, Segmentation fault.
> [Switching to Thread 16384 (LWP 30679)]
> 0x4fb68445 in snd_pcm_route_convert1_one () from /usr/lib/libasound.so.2
> 
>    Pretty useless. Could you give me some indications on how to do a quick 
> make of aplay with the symbols table loaded?

make sure that you installed the non-stripped library and exec files.
if not, specify the location of the original binaries (usually hidden
under .libs directory).  don't forget to set LD_PRELOAD.


Takashi


-------------------------------------------------------
This SF.net email is sponsored by: VM Ware
With VMware you can run multiple operating systems on a single machine.
WITHOUT REBOOTING! Mix Linux / Windows / Novell virtual machines at the
same time. Free trial click here: http://www.vmware.com/wl/offer/345/0

  reply	other threads:[~2003-07-23  8:25 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2003-07-23  1:55 SIS7012 works but get's frozen Lisandro Pin
2003-07-23  8:25 ` Takashi Iwai [this message]
     [not found] <BAY2-F34S5C74a24LnK000028d9@hotmail.com>
2003-07-22 16:47 ` Takashi Iwai
  -- strict thread matches above, loose matches on Subject: below --
2003-07-18 23:37 P.I.Julius
2003-07-18 22:47 P.I.Julius
2003-07-19 10:25 ` David B Harris
2003-07-21 14:35   ` Takashi Iwai
2003-07-21 16:19     ` David B Harris
2003-07-21 14:34 ` Takashi Iwai

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=s5hsmoxfy4o.wl@alsa2.suse.de \
    --to=tiwai@suse.de \
    --cc=alsa-devel@lists.sourceforge.net \
    --cc=lisandro@hotmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.