All of lore.kernel.org
 help / color / mirror / Atom feed
From: Junio C Hamano <gitster@pobox.com>
To: Johannes Sixt <j6t@kdbg.org>
Cc: Eric Sunshine <sunshine@sunshineco.com>,
	Duy Nguyen <pclouds@gmail.com>, Git List <git@vger.kernel.org>
Subject: Re: [PATCH 24/25] worktree move: accept destination as directory
Date: Wed, 11 May 2016 14:34:47 -0700	[thread overview]
Message-ID: <xmqqbn4cjn2g.fsf@gitster.mtv.corp.google.com> (raw)
In-Reply-To: <57337ACF.3020402@kdbg.org> (Johannes Sixt's message of "Wed, 11 May 2016 20:32:47 +0200")

Johannes Sixt <j6t@kdbg.org> writes:

>> As this path is read from a file git itself creates, and if we know
>> that it will always contain forward slashes, then I agree that it
>> could be potentially confusing to later readers to see
>> git_find_last_dir_sep(). So, keeping it as-is seems correct.
>
> Please allow me to disagree. There should not be any assumption that a
> path uses forward slashes as directory separator, except when the path
> is
>
> - a pathspec
> - a ref
> - a path found in the object database including the index

I think standardising on one way for what we write out would give
less hassle to users.  The human end users should not be opening
these files in their editors and futzing with their contents, but
there are third-party tools and reimplementations of Git.  Forcing
them to be prepared for input with slashes and backslashes does not
make much sense to me.

Is there an upside for us to accept both slashes in this file?

  reply	other threads:[~2016-05-11 21:34 UTC|newest]

Thread overview: 35+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-04-13 13:15 [PATCH 00/25] worktree lock, move, remove and unlock Nguyễn Thái Ngọc Duy
2016-04-13 13:15 ` [PATCH 01/25] usage.c: move format processing out of die_errno() Nguyễn Thái Ngọc Duy
2016-04-13 13:15 ` [PATCH 02/25] usage.c: add sys_error() that prints strerror() automatically Nguyễn Thái Ngọc Duy
2016-04-13 13:15 ` [PATCH 03/25] copy.c: import copy_file() from busybox Nguyễn Thái Ngọc Duy
2016-04-13 13:15 ` [PATCH 04/25] copy.c: delete unused code in copy_file() Nguyễn Thái Ngọc Duy
2016-04-13 13:15 ` [PATCH 05/25] copy.c: convert bb_(p)error_msg to (sys_)error Nguyễn Thái Ngọc Duy
2016-04-13 13:15 ` [PATCH 06/25] copy.c: style fix Nguyễn Thái Ngọc Duy
2016-04-13 13:15 ` [PATCH 07/25] copy.c: convert copy_file() to copy_dir_recursively() Nguyễn Thái Ngọc Duy
2016-04-13 13:15 ` [PATCH 08/25] completion: support git-worktree Nguyễn Thái Ngọc Duy
2016-04-13 13:15 ` [PATCH 09/25] git-worktree.txt: keep subcommand listing in alphabetical order Nguyễn Thái Ngọc Duy
2016-04-13 13:15 ` [PATCH 10/25] path.c: add git_common_path() and strbuf_git_common_path() Nguyễn Thái Ngọc Duy
2016-04-13 13:15 ` [PATCH 11/25] worktree.c: use is_dot_or_dotdot() Nguyễn Thái Ngọc Duy
2016-04-13 13:15 ` [PATCH 12/25] worktree.c: store "id" instead of "git_dir" Nguyễn Thái Ngọc Duy
2016-04-13 13:15 ` [PATCH 13/25] worktree.c: add clear_worktree() Nguyễn Thái Ngọc Duy
2016-04-13 13:15 ` [PATCH 14/25] worktree.c: add find_worktree_by_path() Nguyễn Thái Ngọc Duy
2016-04-13 13:15 ` [PATCH 15/25] worktree.c: add is_main_worktree() Nguyễn Thái Ngọc Duy
2016-04-13 13:15 ` [PATCH 16/25] worktree.c: add validate_worktree() Nguyễn Thái Ngọc Duy
2016-04-13 13:15 ` [PATCH 17/25] worktree.c: add update_worktree_location() Nguyễn Thái Ngọc Duy
2016-04-13 13:15 ` [PATCH 18/25] worktree.c: add is_worktree_locked() Nguyễn Thái Ngọc Duy
2016-04-13 13:15 ` [PATCH 19/25] worktree: avoid 0{40}, too many zeroes, hard to read Nguyễn Thái Ngọc Duy
2016-04-13 13:15 ` [PATCH 20/25] worktree: simplify prefixing paths Nguyễn Thái Ngọc Duy
2016-04-13 13:15 ` [PATCH 21/25] worktree: add "lock" command Nguyễn Thái Ngọc Duy
2016-04-13 13:15 ` [PATCH 22/25] worktree: add "unlock" command Nguyễn Thái Ngọc Duy
2016-04-13 13:15 ` [PATCH 23/25] worktree: add "move" commmand Nguyễn Thái Ngọc Duy
2016-04-13 13:15 ` [PATCH 24/25] worktree move: accept destination as directory Nguyễn Thái Ngọc Duy
2016-05-11  4:43   ` Eric Sunshine
2016-05-11 13:34     ` Duy Nguyen
2016-05-11 17:32       ` Eric Sunshine
2016-05-11 18:32         ` Johannes Sixt
2016-05-11 21:34           ` Junio C Hamano [this message]
2016-05-12  5:58             ` Johannes Sixt
2016-04-13 13:15 ` [PATCH 25/25] worktree: add "remove" command Nguyễn Thái Ngọc Duy
2016-04-14 16:08 ` [PATCH 00/25] worktree lock, move, remove and unlock Junio C Hamano
2016-04-15  0:40   ` Duy Nguyen
2016-04-15  1:21     ` Junio C Hamano

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=xmqqbn4cjn2g.fsf@gitster.mtv.corp.google.com \
    --to=gitster@pobox.com \
    --cc=git@vger.kernel.org \
    --cc=j6t@kdbg.org \
    --cc=pclouds@gmail.com \
    --cc=sunshine@sunshineco.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.