All of lore.kernel.org
 help / color / mirror / Atom feed
From: Junio C Hamano <gitster@pobox.com>
To: Ed Maste <emaste@freebsd.org>
Cc: Eric Wong <e@80x24.org>, git mailing list <git@vger.kernel.org>,
	Derrick Stolee via GitGitGadget <gitgitgadget@gmail.com>
Subject: Re: [PATCH] sparse-checkout: improve OS ls compatibility
Date: Thu, 19 Dec 2019 14:01:09 -0800	[thread overview]
Message-ID: <xmqqtv5w9dqy.fsf@gitster-ct.c.googlers.com> (raw)
In-Reply-To: <CAPyFy2BubWbyq6tQmHYxquikn2+uHz+48VSfQ308BYiuE=SSWQ@mail.gmail.com> (Ed Maste's message of "Thu, 19 Dec 2019 15:56:39 -0500")

Ed Maste <emaste@freebsd.org> writes:

>> Note that the helper function's name no longer reflects what it does
>> with such a change, so it needs to be renamed.  Together with style
>> fix, perhaps
>>
>>         ls_no_dot () {
>>                 (cd "$1" && printf "%s\n *)
>>         }
>>
>> is what we want,
>
> I believe the tests should pass or be skipped when run as root, so I
> think we should either require (something like) SANITY for these
> tests, or make the change above. I'm happy with either option; I'll
> send a v2 based on the approach above for consideration.

OK, after thinking about it a bit more, I think "Your ls is broken"
was completely missing the point.  What we want in the callers of
this helper is to list the contents of a directory, and "ls" is one
possible (and easiest, if there were no "oops, sometimes -A is enabled
 implementation by default" complication) implementation.

And "ls_no_dot" is a misnomer from that point of view.  We are not
even using "ls", so perhaps we should just call it "list_files" or
something?

Thanks.

  reply	other threads:[~2019-12-19 22:01 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-12-19  1:58 [PATCH] sparse-checkout: improve OS ls compatibility Ed Maste
2019-12-19  2:07 ` Derrick Stolee
2019-12-19  2:18   ` Ed Maste
2019-12-19  2:22     ` Derrick Stolee
2019-12-19  2:45 ` Eric Wong
2019-12-19 13:56   ` Derrick Stolee
2019-12-19 16:15     ` Ed Maste
2019-12-19 16:34       ` Derrick Stolee
2019-12-19 18:11   ` Junio C Hamano
2019-12-19 20:56     ` Ed Maste
2019-12-19 22:01       ` Junio C Hamano [this message]
2019-12-19 21:45 ` [PATCH v2] " Ed Maste
2019-12-19 22:27   ` Denton Liu
2019-12-20 15:38 ` [PATCH v3] " Ed Maste
2019-12-20 16:05   ` Derrick Stolee
2019-12-20 17:55     ` Junio C Hamano
2019-12-20 17:55   ` Eric Sunshine
2019-12-20 18:15     ` Ed Maste
2019-12-20 18:21     ` Junio C Hamano
2019-12-20 18:34       ` Eric Sunshine
2019-12-20 18:34       ` Ed Maste
2019-12-20 19:23         ` Junio C Hamano
2019-12-20 19:33           ` Eric Sunshine
2019-12-20 19:41 ` [PATCH v4] " Ed Maste

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=xmqqtv5w9dqy.fsf@gitster-ct.c.googlers.com \
    --to=gitster@pobox.com \
    --cc=e@80x24.org \
    --cc=emaste@freebsd.org \
    --cc=git@vger.kernel.org \
    --cc=gitgitgadget@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.