alsa-devel.alsa-project.org archive mirror
 help / color / mirror / Atom feed
From: Hans de Goede <hdegoede@redhat.com>
To: Cezary Rojewski <cezary.rojewski@intel.com>,
	Pierre-Louis Bossart <pierre-louis.bossart@linux.intel.com>,
	Liam Girdwood <liam.r.girdwood@linux.intel.com>,
	Jie Yang <yang.jie@linux.intel.com>,
	Mark Brown <broonie@kernel.org>
Cc: Nariman Etemadi <narimantos@gmail.com>,
	alsa-devel@alsa-project.org, Jordy Ubink <jordyubink@hotmail.nl>,
	Hans de Goede <hdegoede@redhat.com>,
	Damian van Soelen <dj.vsoelen@gmail.com>,
	Erik Bussing <eabbussing@outlook.com>
Subject: [alsa-devel] [PATCH 2/4] ASoC: Intel: bytcr_rt5640: Remove unnecessary string buffers and snprintf calls
Date: Wed, 15 Jan 2020 17:46:17 +0100	[thread overview]
Message-ID: <20200115164619.101705-3-hdegoede@redhat.com> (raw)
In-Reply-To: <20200115164619.101705-1-hdegoede@redhat.com>

From: Nariman Etemadi <narimantos@gmail.com>

The snprintf calls filling byt_rt56*_codec_aif_name/byt_rt56*_cpu_dai_name
always fill them with the same string ("rt56*-aif2" resp. ssp0-port").
So instead of keeping these buffers around and making codecs->dai_name /
cpus->dai_name point to them, simply update the *->dai_name pointers to
directly point to a string constant containing the desired string.

Signed-off-by: Nariman Etemadi <narimantos@gmail.com>
Signed-off-by: Hans de Goede <hdegoede@redhat.com>
---
 sound/soc/intel/boards/bytcr_rt5640.c | 26 ++++----------------------
 1 file changed, 4 insertions(+), 22 deletions(-)

diff --git a/sound/soc/intel/boards/bytcr_rt5640.c b/sound/soc/intel/boards/bytcr_rt5640.c
index d1353d61c424..43fac2683cc1 100644
--- a/sound/soc/intel/boards/bytcr_rt5640.c
+++ b/sound/soc/intel/boards/bytcr_rt5640.c
@@ -1062,8 +1062,6 @@ static struct snd_soc_dai_link byt_rt5640_dais[] = {
 
 /* SoC card */
 static char byt_rt5640_codec_name[SND_ACPI_I2C_ID_LEN];
-static char byt_rt5640_codec_aif_name[12]; /*  = "rt5640-aif[1|2]" */
-static char byt_rt5640_cpu_dai_name[10]; /*  = "ssp[0|2]-port" */
 #if !IS_ENABLED(CONFIG_SND_SOC_INTEL_USER_FRIENDLY_LONG_NAMES)
 static char byt_rt5640_long_name[40]; /* = "bytcr-rt5640-*-spk-*-mic" */
 #endif
@@ -1247,28 +1245,12 @@ static int snd_byt_rt5640_mc_probe(struct platform_device *pdev)
 	log_quirks(&pdev->dev);
 
 	if ((byt_rt5640_quirk & BYT_RT5640_SSP2_AIF2) ||
-	    (byt_rt5640_quirk & BYT_RT5640_SSP0_AIF2)) {
-
-		/* fixup codec aif name */
-		snprintf(byt_rt5640_codec_aif_name,
-			sizeof(byt_rt5640_codec_aif_name),
-			"%s", "rt5640-aif2");
-
-		byt_rt5640_dais[dai_index].codecs->dai_name =
-			byt_rt5640_codec_aif_name;
-	}
+	    (byt_rt5640_quirk & BYT_RT5640_SSP0_AIF2))
+		byt_rt5640_dais[dai_index].codecs->dai_name = "rt5640-aif2";
 
 	if ((byt_rt5640_quirk & BYT_RT5640_SSP0_AIF1) ||
-	    (byt_rt5640_quirk & BYT_RT5640_SSP0_AIF2)) {
-
-		/* fixup cpu dai name name */
-		snprintf(byt_rt5640_cpu_dai_name,
-			sizeof(byt_rt5640_cpu_dai_name),
-			"%s", "ssp0-port");
-
-		byt_rt5640_dais[dai_index].cpus->dai_name =
-			byt_rt5640_cpu_dai_name;
-	}
+	    (byt_rt5640_quirk & BYT_RT5640_SSP0_AIF2))
+		byt_rt5640_dais[dai_index].cpus->dai_name = "ssp0-port";
 
 	if (byt_rt5640_quirk & BYT_RT5640_MCLK_EN) {
 		priv->mclk = devm_clk_get(&pdev->dev, "pmc_plt_clk_3");
-- 
2.24.1

_______________________________________________
Alsa-devel mailing list
Alsa-devel@alsa-project.org
https://mailman.alsa-project.org/mailman/listinfo/alsa-devel

  parent reply	other threads:[~2020-01-15 16:49 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-01-15 16:46 [alsa-devel] [PATCH 0/4] ASoC: Intel: 4 small cleanups Hans de Goede
2020-01-15 16:46 ` [alsa-devel] [PATCH 1/4] ASoC: Intel: bytcr_rt5640: Remove code duplication in byt_rt5640_codec_fixup Hans de Goede
2020-01-17 15:44   ` [alsa-devel] Applied "ASoC: Intel: bytcr_rt5640: Remove code duplication in byt_rt5640_codec_fixup" to the asoc tree Mark Brown
2020-01-15 16:46 ` Hans de Goede [this message]
2020-01-17 15:44   ` [alsa-devel] Applied "ASoC: Intel: bytcr_rt5640: Remove unnecessary string buffers and snprintf calls" " Mark Brown
2020-01-15 16:46 ` [alsa-devel] [PATCH 3/4] ASoC: Intel: bytcr_rt5651: Remove unnecessary string buffers and snprintf calls Hans de Goede
2020-01-17 15:44   ` [alsa-devel] Applied "ASoC: Intel: bytcr_rt5651: Remove unnecessary string buffers and snprintf calls" to the asoc tree Mark Brown
2020-01-15 16:46 ` [alsa-devel] [PATCH 4/4] ASoC: Intel: cht_bsw_rt5645: Remove unnecessary string buffers and snprintf calls Hans de Goede
2020-01-17 15:44   ` [alsa-devel] Applied "ASoC: Intel: cht_bsw_rt5645: Remove unnecessary string buffers and snprintf calls" to the asoc tree Mark Brown
2020-01-15 17:14 ` [alsa-devel] [PATCH 0/4] ASoC: Intel: 4 small cleanups Pierre-Louis Bossart

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200115164619.101705-3-hdegoede@redhat.com \
    --to=hdegoede@redhat.com \
    --cc=alsa-devel@alsa-project.org \
    --cc=broonie@kernel.org \
    --cc=cezary.rojewski@intel.com \
    --cc=dj.vsoelen@gmail.com \
    --cc=eabbussing@outlook.com \
    --cc=jordyubink@hotmail.nl \
    --cc=liam.r.girdwood@linux.intel.com \
    --cc=narimantos@gmail.com \
    --cc=pierre-louis.bossart@linux.intel.com \
    --cc=yang.jie@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).