alsa-devel.alsa-project.org archive mirror
 help / color / mirror / Atom feed
From: Pierre-Louis Bossart <pierre-louis.bossart@linux.intel.com>
To: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>,
	Mark Brown <broonie@kernel.org>
Cc: Linux-ALSA <alsa-devel@alsa-project.org>
Subject: Re: [alsa-devel] [PATCH 14/21] ASoC: soc-core: have legacy_dai_naming at snd_soc_register_dai()
Date: Thu, 10 Oct 2019 10:26:51 -0500	[thread overview]
Message-ID: <df9de456-a4c2-53c4-2143-edb4d4b2292f@linux.intel.com> (raw)
In-Reply-To: <878spuilqd.wl-kuninori.morimoto.gx@renesas.com>



On 10/8/19 11:30 PM, Kuninori Morimoto wrote:
> From: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>
> 
> ALSA SoC has 2 similar but diffarent implementation.

different

> snd_soc_register_dai()  is used from topology
> snd_soc_register_dais() is used from snd_soc_add_component()
> 
> Because of this kind of confusable naming, and duplicated

confusing

> implementation, code is very unreadale.

unreadable

> We shouldn't have duplicated and confusable implementation.

confusing

> snd_soc_register_dai() is now used from topology.
> But, to reduce duplicated code, it will be used from soc-core, too.
> To prepare for it, this patch adds missing parameter legacy_dai_naming
> to snd_soc_register_dai().

It doesn't look like this series reduces the confusion between 
snd_soc_register_dai() and snd_soc_register_dais() ?

maybe for the latter case since it's a static function we don't want the 
entire prefix then?

> 
> Signed-off-by: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>
> ---
>   include/sound/soc.h      | 3 ++-
>   sound/soc/soc-core.c     | 5 +++--
>   sound/soc/soc-topology.c | 2 +-
>   3 files changed, 6 insertions(+), 4 deletions(-)
> 
> diff --git a/include/sound/soc.h b/include/sound/soc.h
> index 320dcd4..827322a 100644
> --- a/include/sound/soc.h
> +++ b/include/sound/soc.h
> @@ -1327,7 +1327,8 @@ struct snd_soc_dai_link *snd_soc_find_dai_link(struct snd_soc_card *card,
>   					       const char *stream_name);
>   
>   int snd_soc_register_dai(struct snd_soc_component *component,
> -	struct snd_soc_dai_driver *dai_drv);
> +			 struct snd_soc_dai_driver *dai_drv,
> +			 bool legacy_dai_naming);
>   
>   struct snd_soc_dai *snd_soc_find_dai(
>   	const struct snd_soc_dai_link_component *dlc);
> diff --git a/sound/soc/soc-core.c b/sound/soc/soc-core.c
> index be4e1b5..3a16868 100644
> --- a/sound/soc/soc-core.c
> +++ b/sound/soc/soc-core.c
> @@ -2611,7 +2611,8 @@ static struct snd_soc_dai *soc_add_dai(struct snd_soc_component *component,
>    * will be freed in the component cleanup.
>    */
>   int snd_soc_register_dai(struct snd_soc_component *component,
> -			 struct snd_soc_dai_driver *dai_drv)
> +			 struct snd_soc_dai_driver *dai_drv,
> +			 bool legacy_dai_naming)
>   {
>   	struct snd_soc_dapm_context *dapm =
>   		snd_soc_component_get_dapm(component);
> @@ -2625,7 +2626,7 @@ int snd_soc_register_dai(struct snd_soc_component *component,
>   	}
>   
>   	lockdep_assert_held(&client_mutex);
> -	dai = soc_add_dai(component, dai_drv, false);
> +	dai = soc_add_dai(component, dai_drv, legacy_dai_naming);
>   	if (!dai)
>   		return -ENOMEM;
>   
> diff --git a/sound/soc/soc-topology.c b/sound/soc/soc-topology.c
> index 0fd0329..b6e1456 100644
> --- a/sound/soc/soc-topology.c
> +++ b/sound/soc/soc-topology.c
> @@ -1842,7 +1842,7 @@ static int soc_tplg_dai_create(struct soc_tplg *tplg,
>   	list_add(&dai_drv->dobj.list, &tplg->comp->dobj_list);
>   
>   	/* register the DAI to the component */
> -	return snd_soc_register_dai(tplg->comp, dai_drv);
> +	return snd_soc_register_dai(tplg->comp, dai_drv, false);
>   }
>   
>   static void set_link_flags(struct snd_soc_dai_link *link,
> 
_______________________________________________
Alsa-devel mailing list
Alsa-devel@alsa-project.org
https://mailman.alsa-project.org/mailman/listinfo/alsa-devel

  reply	other threads:[~2019-10-10 15:27 UTC|newest]

Thread overview: 42+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-10-09  4:29 [alsa-devel] [PATCH 00/21] ASoC: soc-core cleanup - step 4 Kuninori Morimoto
2019-10-09  4:29 ` [alsa-devel] [PATCH 01/21] ASoC: soc-core: remove for_each_rtdcom_safe() Kuninori Morimoto
2019-10-09  4:29 ` [alsa-devel] [PATCH 02/21] ASoC: soc-core: add for_each_rtd_components() and replace Kuninori Morimoto
2019-10-09  4:30 ` [alsa-devel] [PATCH 03/21] ASoC: soc-core: move soc_init_dai_link() Kuninori Morimoto
2019-10-09  4:30 ` [alsa-devel] [PATCH 04/21] ASoC: soc-core: rename soc_init_dai_link() to soc_dai_link_sanity_check() Kuninori Morimoto
2019-10-10 14:17   ` Pierre-Louis Bossart
2019-10-11  1:19     ` Kuninori Morimoto
2019-10-11 13:38       ` Pierre-Louis Bossart
2019-10-09  4:30 ` [alsa-devel] [PATCH 05/21] ASoC: soc-core: remove duplicated soc_is_dai_link_bound() Kuninori Morimoto
2019-10-10 15:09   ` Pierre-Louis Bossart
2019-10-09  4:30 ` [alsa-devel] [PATCH 06/21] ASoC: soc-core: call soc_bind_dai_link() under snd_soc_add_dai_link() Kuninori Morimoto
2019-10-09  4:30 ` [alsa-devel] [PATCH 07/21] ASoC: soc-core: add soc_unbind_dai_link() Kuninori Morimoto
2019-10-09  4:30 ` [alsa-devel] [PATCH 08/21] ASoC: soc-core: snd_soc_unbind_card() cleanup Kuninori Morimoto
2019-10-09  4:30 ` [alsa-devel] [PATCH 09/21] ASoC: soc-core: remove unneeded snd_soc_tplg_component_remove() Kuninori Morimoto
2019-10-10 15:09   ` Pierre-Louis Bossart
2019-10-11  1:30     ` Kuninori Morimoto
2019-10-11 13:40       ` Pierre-Louis Bossart
2019-10-09  4:30 ` [alsa-devel] [PATCH 10/21] ASoC: soc-core: move snd_soc_lookup_component() Kuninori Morimoto
2019-10-09  4:30 ` [alsa-devel] [PATCH 11/21] ASoC: soc-core: add snd_soc_del_component() Kuninori Morimoto
2019-10-10 15:16   ` Pierre-Louis Bossart
2019-10-11  1:35     ` Kuninori Morimoto
2019-10-09  4:30 ` [alsa-devel] [PATCH 12/21] ASoC: soc-core: use snd_soc_lookup_component() at snd_soc_unregister_component() Kuninori Morimoto
2019-10-10 15:19   ` Pierre-Louis Bossart
2019-10-11  1:38     ` Kuninori Morimoto
2019-10-09  4:30 ` [alsa-devel] [PATCH 13/21] ASoC: soc-core: move snd_soc_register_dai() Kuninori Morimoto
2019-10-09  4:30 ` [alsa-devel] [PATCH 14/21] ASoC: soc-core: have legacy_dai_naming at snd_soc_register_dai() Kuninori Morimoto
2019-10-10 15:26   ` Pierre-Louis Bossart [this message]
2019-10-11  1:07     ` Kuninori Morimoto
2019-10-11 13:43       ` Pierre-Louis Bossart
2019-10-09  4:30 ` [alsa-devel] [PATCH 15/21] ASoC: soc-core: move snd_soc_unregister_dais() Kuninori Morimoto
2019-10-09  4:31 ` [alsa-devel] [PATCH 16/21] ASoC: soc-core: add snd_soc_unregister_dai() Kuninori Morimoto
2019-10-09  4:31 ` [alsa-devel] [PATCH 17/21] ASoC: soc-core: don't call snd_soc_dapm_new_dai_widgets() at snd_soc_register_dai() Kuninori Morimoto
2019-10-09  4:31 ` [alsa-devel] [PATCH 18/21] ASoC: soc-core: use mutex_lock() at snd_soc_add_component() Kuninori Morimoto
2019-10-10 15:29   ` Pierre-Louis Bossart
2019-10-09  4:31 ` [alsa-devel] [PATCH 19/21] ASoC: soc-core: call snd_soc_register_dai() from snd_soc_register_dais() Kuninori Morimoto
2019-10-10 15:34   ` Pierre-Louis Bossart
2019-10-11  1:44     ` Kuninori Morimoto
2019-10-09  4:31 ` [alsa-devel] [PATCH 20/21] ASoC: soc-core: remove topology specific operation Kuninori Morimoto
2019-10-09  4:31 ` [alsa-devel] [PATCH 21/21] ASoC: soc.h: dobj is used only when SND_SOC_TOPOLOGY Kuninori Morimoto
2019-10-09 14:16 ` [alsa-devel] [PATCH 00/21] ASoC: soc-core cleanup - step 4 Pierre-Louis Bossart
2019-10-10 15:38 ` Pierre-Louis Bossart
2019-10-11  1:53   ` Kuninori Morimoto

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=df9de456-a4c2-53c4-2143-edb4d4b2292f@linux.intel.com \
    --to=pierre-louis.bossart@linux.intel.com \
    --cc=alsa-devel@alsa-project.org \
    --cc=broonie@kernel.org \
    --cc=kuninori.morimoto.gx@renesas.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).