ath10k.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v2 0/3] Add lockdep_assert_not_held()
@ 2021-02-26 17:52 Shuah Khan
  2021-02-26 17:52 ` [PATCH v2 1/3] lockdep: add lockdep_assert_not_held() Shuah Khan
                   ` (2 more replies)
  0 siblings, 3 replies; 9+ messages in thread
From: Shuah Khan @ 2021-02-26 17:52 UTC (permalink / raw)
  To: peterz, mingo, will, kvalo, davem, kuba
  Cc: netdev, linux-wireless, linux-kernel, ath10k, Shuah Khan

Some kernel functions must not be called holding a specific lock. Doing
so could lead to locking problems. Currently these routines call
lock_is_held() to check for lock hold followed by WARN_ON.

Adding a common lockdep interface will help reduce the duplication of this
logic in the rest of the kernel.

Add lockdep_assert_not_held() to be used in these functions to detect
incorrect calls while holding a lock.

lockdep_assert_not_held() provides the opposite functionality of
lockdep_assert_held() which is used to assert calls that require
holding a specific lock.

The need for lockdep_assert_not_held() came up in a discussion on
ath10k patch. ath10k_drain_tx() and i915_vma_pin_ww() are examples
of functions that can use lockdep_assert_not_held().

Link: https://lore.kernel.org/lkml/37a29c383bff2fb1605241ee6c7c9be3784fb3c6.1613171185.git.skhan@linuxfoundation.org/
Link: https://lore.kernel.org/linux-wireless/871rdmu9z9.fsf@codeaurora.org/

This patch series adds lockdep_assert_not_held() and uses it in the
second patch in ath10k_drain_tx() function.

Patch 1 incorporates suggestions from Peter Zijlstra on v1 series
to avoid misfires when lockdep_off() is employed.

Patch 2 Johannes Berg's suggestions as it make it easier to read and
maintain the lock states. These are defines and a enum to avoid changes
to lock_is_held_type() and lockdep_is_held() return types.

Patch 2 is a separate patch because it adds defines to lockdep.h and
kernel/locking/lockdep.c now includes lockdep.h - decided make this
a separate patch just in case issues related to header dependencies
pop up. I can combine Patches 1&2 if that is preferred.

Patch 3 uses the new interface in ath10k_drain_tx() function. Added
Kalle Valo's Ack from v1 for this change.

Tested on the mainline from yesterday.

Shuah Khan (3):
  lockdep: add lockdep_assert_not_held()
  lockdep: add lockdep lock state defines
  ath10k: detect conf_mutex held ath10k_drain_tx() calls

 drivers/net/wireless/ath/ath10k/mac.c |  2 ++
 include/linux/lockdep.h               | 18 +++++++++++++++---
 kernel/locking/lockdep.c              |  6 +++++-
 3 files changed, 22 insertions(+), 4 deletions(-)

-- 
2.27.0


_______________________________________________
ath10k mailing list
ath10k@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/ath10k

^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, other threads:[~2021-03-01  8:28 UTC | newest]

Thread overview: 9+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-02-26 17:52 [PATCH v2 0/3] Add lockdep_assert_not_held() Shuah Khan
2021-02-26 17:52 ` [PATCH v2 1/3] lockdep: add lockdep_assert_not_held() Shuah Khan
2021-02-26 21:07   ` Peter Zijlstra
2021-02-26 21:16     ` Shuah Khan
2021-03-01  8:28       ` Peter Zijlstra
2021-02-26 17:52 ` [PATCH v2 2/3] lockdep: add lockdep lock state defines Shuah Khan
2021-02-26 18:03   ` Johannes Berg
2021-02-26 18:16     ` Shuah Khan
2021-02-26 17:52 ` [PATCH v2 3/3] ath10k: detect conf_mutex held ath10k_drain_tx() calls Shuah Khan

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).