b.a.t.m.a.n.lists.open-mesh.org archive mirror
 help / color / mirror / Atom feed
From: "Linus Lüssing" <linus.luessing@saxnet.de>
To: b.a.t.m.a.n@lists.open-mesh.org
Subject: [B.A.T.M.A.N.] B.A.T.M.A.N.-Advanced Multicast Optimizations, v3
Date: Sun, 30 Jan 2011 05:39:08 +0100	[thread overview]
Message-ID: <1296362366-3852-1-git-send-email-linus.luessing@saxnet.de> (raw)

Hi everyone,

here's the third iteration of the multicast patches which is mainly some
bugfixing, smaller but also slightly larger restructuring.
Thanks for the feedback again!

Cheers, Linus

= Changelog v3 =

* rebasing to commit [8bb3d9422707a7814ac804acbc00569dd017288c]
* 4B-aligning for 'struct mcast_entry', adding __packed attribute [01/19]
* converted  mcast_forw_table and subsequent lists to hlists
  [10/19], [11/19], [12/19], [13/19]
* splitted mcast_forw_table_seq_print_text into several functions
  [11/19]
* shorter rcu-locking when printing to sysfs, only in seq_print_if_entry
  [11/19]
* add missing spin_lock initilization [10/19]
* fix logic for break_flag in tracker_packet_for_each() macro [07/19]
* compat.h, should be "#define MC_LIST struct netdev_hw_addr" instead [03/19]
* adding mcast duplicate check seqno lock [17/19]
* fixed rcu-locking in route_mcast_tracker_packet(),
  in fact, using refcounting there now [07/19]
* restructuring route_mcast_tracker_packet(), merging two loops
* also delete dest from tracker packet if unknown originator
  in zero_tracker_packet() [07/19]
* compactify check-code in zero_tracker_packet() [07/19]
* don't use index i like nexthop_tracker_packets[i] in skb sending loop in
  route_mcast_tracker_packet(), it has the wrong base [07/19]
* use hash_find() instead of own orig_node look-up in zero_tracker_packt()
  and add_router_of_dest() [07/19]
* reserve dest_entries on heap instead of stack, >4k is too much for the stack
  [07/19]
* rename dest_entries_list to dest_entries_buckets, trying to clarify its
  purpose [07/19]
* add comment for find_mca_match() [07/19]
* move comments for zero_tracker_packet() and shrink_tracker_packet()
to the correct patches [10/19]
* remove wrong comment for sync_orig() (duplicate of sync_table()) [10/19]
* remove variable name defines for net_device multicast lists [03/19]
* directly create & use SKBs for tracker_packets [07/19], [09/19]
* moving stuff from mcast_proact_tracker_prepare() to build_tracker_packet_skb()
  [07/19]
* only create methods / variables / defines / macros in patches that need them
  (this changed the BAT_MCAST/MCAST_TRACKER define numbers)
  -[01/19], -[03/19]
* use rcu-locking for mcast_forw_table, +[18]

             reply	other threads:[~2011-01-30  4:39 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-01-30  4:39 Linus Lüssing [this message]
2011-01-30  4:39 ` [B.A.T.M.A.N.] [PATCH 01/18] batman-adv: Adding configurable variables for multicast optimizations Linus Lüssing
2011-01-30  4:39 ` [B.A.T.M.A.N.] [PATCH 02/18] batman-adv: Attach local MCAs to OGMs Linus Lüssing
2011-01-30  4:39 ` [B.A.T.M.A.N.] [PATCH 03/18] batman-adv: Add periodic multicast tracker timer Linus Lüssing
2011-01-30  4:39 ` [B.A.T.M.A.N.] [PATCH 04/18] batman-adv: Buffer other originator's received MCA entries Linus Lüssing
2011-01-30  4:39 ` [B.A.T.M.A.N.] [PATCH 05/18] batman-adv: Prepare and send own multicast tracker packets Linus Lüssing
2011-01-30  4:39 ` [B.A.T.M.A.N.] [PATCH 06/18] batman-adv: Add length check for (received) " Linus Lüssing
2011-01-30  4:39 ` [B.A.T.M.A.N.] [PATCH 07/18] batman-adv: Route multicast " Linus Lüssing
2011-01-30  4:39 ` [B.A.T.M.A.N.] [PATCH 08/18] batman-adv: Add/refresh entries to/in mcast forwarding table Linus Lüssing
2011-01-30  4:39 ` [B.A.T.M.A.N.] [PATCH 09/18] batman-adv: Output mcast forw table in debugfs Linus Lüssing
2011-01-30  4:39 ` [B.A.T.M.A.N.] [PATCH 10/18] batman-adv: Purge timeouted entries in mcast forw table Linus Lüssing
2011-01-30  4:39 ` [B.A.T.M.A.N.] [PATCH 11/18] batman-adv: Send own BAT_MCAST packets in proact_tracking multicast mode Linus Lüssing
2011-01-30  4:39 ` [B.A.T.M.A.N.] [PATCH 12/18] batman-adv: Export broadcast packet ethernet header checks Linus Lüssing
2011-01-30  4:39 ` [B.A.T.M.A.N.] [PATCH 13/18] batman-adv: Receive multicast data packets BAT_MCAST Linus Lüssing
2011-01-30  4:39 ` [B.A.T.M.A.N.] [PATCH 14/18] batman-adv: Forward multicast data in proact_tracking mode Linus Lüssing
2011-01-30  4:39 ` [B.A.T.M.A.N.] [PATCH 15/18] batman-adv: Add duplicate checks for multicast data Linus Lüssing
2011-01-30  4:39 ` [B.A.T.M.A.N.] [PATCH 16/18] batman-adv: Still flood multicast packets we are not a receiver of Linus Lüssing
2011-01-30  4:39 ` [B.A.T.M.A.N.] [PATCH 17/18] batman-adv: Make number of (re)broadcasts configurable via sysfs Linus Lüssing
2011-01-30  4:39 ` [B.A.T.M.A.N.] [PATCH 18/18] batman-adv: Use rcu-locking for multicast forwarding table Linus Lüssing

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1296362366-3852-1-git-send-email-linus.luessing@saxnet.de \
    --to=linus.luessing@saxnet.de \
    --cc=b.a.t.m.a.n@lists.open-mesh.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).