b.a.t.m.a.n.lists.open-mesh.org archive mirror
 help / color / mirror / Atom feed
From: Antonio Quartulli <ordex@autistici.org>
To: davem@davemloft.net
Cc: netdev@vger.kernel.org, b.a.t.m.a.n@lists.open-mesh.org
Subject: [B.A.T.M.A.N.] pull request: batman-adv 2012-05-01
Date: Tue,  1 May 2012 10:00:59 +0200	[thread overview]
Message-ID: <1335859266-7546-1-git-send-email-ordex@autistici.org> (raw)

Hello David,

this is the new version of my previous pull request (issued on 2012-04-29).
I'd like to see this changesin net-next/linux-3.5.

In this pull request I entirely removed the D.A.T. code, that as we were
discussing in the previous thread, needs some rewriting to avoid directly
dealing with the neigh table.

This patchset only contains fixes and cleanups.

Letme know if there is any problem!

Thank you,
	Antonio

The following changes since commit 7a2a66a0ac1cf93d30869c4ecbfc71a2fda19397:

  Add linux-next specific files for 20120423 (2012-04-23 16:58:43 +1000)

are available in the git repository at:

  git://git.open-mesh.org/linux-merge.git tags/batman-adv-for-davem

for you to fetch changes up to 969e62ad00763fed9ea28700ef7a7d97fdbfddf3:

  batman-adv: split neigh_new function into generic and batman iv specific parts (2012-05-01 00:37:58 +0200)

----------------------------------------------------------------
Included changes:

* minor fixes and cleanups
* minor routing protocol API cleanups

----------------------------------------------------------------
Antonio Quartulli (1):
      batman-adv: fix wrong dhcp option list browsing

Marek Lindner (6):
      batman-adv: introduce is_single_hop_neigh variable to increase readability
      batman-adv: introduce packet type handler array for incoming packets
      batman-adv: register batman ogm receive function during protocol init
      batman-adv: rename last_valid to last_seen
      batman-adv: replace HZ calculations with jiffies_to_msecs()
      batman-adv: split neigh_new function into generic and batman iv specific parts

 net/batman-adv/bat_debugfs.c    |    4 +-
 net/batman-adv/bat_iv_ogm.c     |   95 +++++++++++++++++++++++-------
 net/batman-adv/gateway_client.c |    6 +-
 net/batman-adv/hard-interface.c |  113 ------------------------------------
 net/batman-adv/main.c           |  122 ++++++++++++++++++++++++++++++++++++++-
 net/batman-adv/main.h           |    6 ++
 net/batman-adv/originator.c     |   50 ++++++++--------
 net/batman-adv/originator.h     |    6 +-
 net/batman-adv/routing.c        |   22 ++++---
 net/batman-adv/routing.h        |    4 +-
 net/batman-adv/send.c           |    2 +-
 net/batman-adv/types.h          |   11 ++--
 12 files changed, 249 insertions(+), 192 deletions(-)

             reply	other threads:[~2012-05-01  8:00 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-05-01  8:00 Antonio Quartulli [this message]
2012-05-01  8:01 ` [B.A.T.M.A.N.] [PATCH 1/7] batman-adv: fix wrong dhcp option list browsing Antonio Quartulli
2012-05-01  8:01 ` [B.A.T.M.A.N.] [PATCH 2/7] batman-adv: introduce is_single_hop_neigh variable to increase readability Antonio Quartulli
2012-05-01  8:01 ` [B.A.T.M.A.N.] [PATCH 3/7] batman-adv: introduce packet type handler array for incoming packets Antonio Quartulli
2012-05-01  8:01 ` [B.A.T.M.A.N.] [PATCH 4/7] batman-adv: register batman ogm receive function during protocol init Antonio Quartulli
2012-05-01  8:01 ` [B.A.T.M.A.N.] [PATCH 5/7] batman-adv: rename last_valid to last_seen Antonio Quartulli
2012-05-01  8:01 ` [B.A.T.M.A.N.] [PATCH 6/7] batman-adv: replace HZ calculations with jiffies_to_msecs() Antonio Quartulli
2012-05-01  8:01 ` [B.A.T.M.A.N.] [PATCH 7/7] batman-adv: split neigh_new function into generic and batman iv specific parts Antonio Quartulli
2012-05-01 13:53 ` [B.A.T.M.A.N.] pull request: batman-adv 2012-05-01 David Miller
2012-05-01 13:56   ` David Miller
2012-05-01 14:12     ` Antonio Quartulli

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1335859266-7546-1-git-send-email-ordex@autistici.org \
    --to=ordex@autistici.org \
    --cc=b.a.t.m.a.n@lists.open-mesh.org \
    --cc=davem@davemloft.net \
    --cc=netdev@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).