b.a.t.m.a.n.lists.open-mesh.org archive mirror
 help / color / mirror / Atom feed
From: Antonio Quartulli <ordex@autistici.org>
To: davem@davemloft.net
Cc: netdev@vger.kernel.org, b.a.t.m.a.n@lists.open-mesh.org
Subject: [B.A.T.M.A.N.] [PATCH 01/14] batman-adv: fix wrong dhcp option list browsing
Date: Wed,  9 May 2012 13:12:43 +0200	[thread overview]
Message-ID: <1336561976-16088-2-git-send-email-ordex@autistici.org> (raw)
In-Reply-To: <1336561976-16088-1-git-send-email-ordex@autistici.org>

In is_type_dhcprequest(), while parsing a DHCP message, if the entry we found in
the option list is neither a padding nor the dhcp-type, we have to ignore it and
jump as many bytes as its length + 1. The "+ 1" byte is given by the subtype
field itself that has to be jumped too.

Reported-by: Marek Lindner <lindner_marek@yahoo.de>
Signed-off-by: Antonio Quartulli <ordex@autistici.org>
---
 net/batman-adv/gateway_client.c |    6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/net/batman-adv/gateway_client.c b/net/batman-adv/gateway_client.c
index 6f9b9b7..47f7186 100644
--- a/net/batman-adv/gateway_client.c
+++ b/net/batman-adv/gateway_client.c
@@ -558,10 +558,10 @@ static bool is_type_dhcprequest(struct sk_buff *skb, int header_len)
 			p++;
 
 			/* ...and then we jump over the data */
-			if (pkt_len < *p)
+			if (pkt_len < 1 + (*p))
 				goto out;
-			pkt_len -= *p;
-			p += (*p);
+			pkt_len -= 1 + (*p);
+			p += 1 + (*p);
 		}
 	}
 out:
-- 
1.7.9.4


  reply	other threads:[~2012-05-09 11:12 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-05-09 11:12 [B.A.T.M.A.N.] pull request: batman-adv 2012-05-09 Antonio Quartulli
2012-05-09 11:12 ` Antonio Quartulli [this message]
2012-05-09 11:12 ` [B.A.T.M.A.N.] [PATCH 02/14] batman-adv: introduce is_single_hop_neigh variable to increase readability Antonio Quartulli
2012-05-09 11:12 ` [B.A.T.M.A.N.] [PATCH 03/14] batman-adv: introduce packet type handler array for incoming packets Antonio Quartulli
2012-05-09 11:12 ` [B.A.T.M.A.N.] [PATCH 04/14] batman-adv: register batman ogm receive function during protocol init Antonio Quartulli
2012-05-09 11:12 ` [B.A.T.M.A.N.] [PATCH 05/14] batman-adv: rename last_valid to last_seen Antonio Quartulli
2012-05-09 11:12 ` [B.A.T.M.A.N.] [PATCH 06/14] batman-adv: replace HZ calculations with jiffies_to_msecs() Antonio Quartulli
2012-05-09 11:12 ` [B.A.T.M.A.N.] [PATCH 07/14] batman-adv: split neigh_new function into generic and batman iv specific parts Antonio Quartulli
2012-05-10  0:41   ` David Miller
2012-05-10  6:08     ` Marek Lindner
2012-05-10  7:34     ` Sven Eckelmann
2012-05-10 16:07       ` David Miller
2012-05-09 11:12 ` [B.A.T.M.A.N.] [PATCH 08/14] batman-adv: ignore protocol packets if the interface did not enable this protocol Antonio Quartulli
2012-05-10  0:41   ` David Miller
2012-05-09 11:12 ` [B.A.T.M.A.N.] [PATCH 09/14] batman-adv: refactoring API: find generalized name for bat_ogm_update_mac callback Antonio Quartulli
2012-05-10  0:42   ` David Miller
2012-05-09 11:12 ` [B.A.T.M.A.N.] [PATCH 10/14] batman-adv: rename sysfs macros to reflect the soft-interface dependency Antonio Quartulli
2012-05-09 11:12 ` [B.A.T.M.A.N.] [PATCH 11/14] batman-adv: Adding hard_iface specific sysfs wrapper macros for UINT Antonio Quartulli
2012-05-10  0:43   ` David Miller
2012-05-10  4:49   ` Marek Lindner
2012-05-10  7:35     ` Antonio Quartulli
2012-05-09 11:12 ` [B.A.T.M.A.N.] [PATCH 12/14] batman-adv: fix checkpatch string complaint Antonio Quartulli
2012-05-09 11:12 ` [B.A.T.M.A.N.] [PATCH 13/14] batman-adv: update copyright years Antonio Quartulli
2012-05-09 11:12 ` [B.A.T.M.A.N.] [PATCH 14/14] batman-adv: add contributor name Antonio Quartulli

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1336561976-16088-2-git-send-email-ordex@autistici.org \
    --to=ordex@autistici.org \
    --cc=b.a.t.m.a.n@lists.open-mesh.org \
    --cc=davem@davemloft.net \
    --cc=netdev@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).