b.a.t.m.a.n.lists.open-mesh.org archive mirror
 help / color / mirror / Atom feed
From: Markus Pargmann <mpa@pengutronix.de>
To: Marek Lindner <mareklindner@neomailbox.ch>,
	Simon Wunderlich <sw@simonwunderlich.de>,
	Antonio Quartulli <antonio@meshcoding.com>
Cc: b.a.t.m.a.n@lists.open-mesh.org
Subject: [B.A.T.M.A.N.] [PATCH 00/31] batman-adv: Cleanups
Date: Tue,  2 Dec 2014 12:16:18 +0100	[thread overview]
Message-ID: <1417519009-20699-1-git-send-email-mpa@pengutronix.de> (raw)

Hi,

this series contains some major cleanup patches (at the beginning of the
series) and some minor cleanups at the end of the series. The behavior of
batman should not be influenced by this series as these patches are only
transformations to make the code more readable and maintainable. If it does
influence behavior something is wrong with this series. The series was tested
on ARM SoC with mwifiex driver.

Major changes (Patch 1-12):
 - Compiling debugfs.c only when CONFIG_DEBUG_FS is selected. This reduces the
   amount of unnecessary code that is executed. At the moment all calls to
   debugfs functions will result in NOOPs. However there is some more code that
   we simply don't need without DEBUG_FS.
 - tvlv is separated from the large main.c file into its own tvlv.c. I don't
   see a reason to have this set of functions for tvlv inside the main.c file.
 - The hashtable implementation now has accessor functions to avoid direct
   access on the private hashtable structure. This should improve the hashtable
   interface and create proper encapsulation.

Minor changes (Patch 13-31):
 - Removing unnecessary return value variables
 - Fixing some comments
 - Reordering functions to increase readability
 - Coding style fixes
 - Declare boolean return types as bool
 - Add missing includes

Best Regards,

Markus


Markus Pargmann (31):
  batman-adv: debugfs, avoid compiling for !DEBUG_FS
  batman-adv: Separate logging header
  batman-adv: iv_ogm, Reduce code duplication
  batman-adv: iv_ogm, divide and round for ring buffer avg
  batman-adv: init, Add some error handling
  batman-adv: tvlv realloc, move error handling into if block
  batman-adv: split tvlv into a seperate file
  batman-adv: hash, remove function implementations from header
  batman-adv: hash, Add helper functions
  batman-adv: hash, replace direct hash structure accesses
  batman-adv: hash, make struct hashtable private
  batman-adv: hash, add used linux headers
  batman-adv: Makefile, Sort alphabetically
  batman-adv: iv_ogm_iface_enable, direct return values
  batman-adv: iv_ogm_aggr_packet, bool return value
  batman-adv: iv_ogm_send_to_if, declare char* as const
  batman-adv: iv_ogm_can_aggregate, code readability
  batman-adv: iv_ogm_orig_update, remove unnecessary brackets
  batman-adv: iv_ogm_aggregate_new, simplify error handling
  batman-adv: iv_ogm_queue_add, Simplify expressions
  batman-adv: iv_ogm_orig_update, style, add missin brackets
  batman-adv: iv_ogm, Fix dup_status comment
  batman-adv: iv_ogm, fix coding style
  batman-adv: iv_ogm, fix comment function name
  batman-adv: types, Fix comment on bcast_own
  batman-adv: main, Convert is_my_mac() to bool
  batman-adv: main, batadv_compare_eth return bool
  batman-adv: Remove unnecessary ret variable
  batman-adv: Remove unnecessary ret variable in algo_register
  batman-adv: packet.h, add some missing includes
  batman-adv: types.h, add missing include

 Makefile.kbuild         |   5 +-
 bat_iv_ogm.c            | 247 +++++++++----------
 bitarray.c              |   1 +
 bridge_loop_avoidance.c |  58 +++--
 debugfs.c               |   9 +-
 debugfs.h               |  39 +++
 distributed-arp-table.c |  28 ++-
 gateway_client.c        |   1 +
 gateway_common.c        |   2 +
 hard-interface.c        |   1 +
 hash.c                  | 163 +++++++++++++
 hash.h                  | 164 ++-----------
 icmp_socket.c           |   1 +
 log.h                   |  82 +++++++
 main.c                  | 626 +++---------------------------------------------
 main.h                  | 101 +-------
 multicast.c             |   1 +
 network-coding.c        |  38 +--
 originator.c            |  29 +--
 originator.h            |   4 +-
 packet.h                |   3 +
 routing.c               |   2 +
 send.c                  |   1 +
 sysfs.c                 |   1 +
 translation-table.c     |  90 ++++---
 tvlv.c                  | 592 +++++++++++++++++++++++++++++++++++++++++++++
 tvlv.h                  |  62 +++++
 types.h                 |   8 +-
 28 files changed, 1266 insertions(+), 1093 deletions(-)
 create mode 100644 log.h
 create mode 100644 tvlv.c
 create mode 100644 tvlv.h

-- 
2.1.3


             reply	other threads:[~2014-12-02 11:16 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-12-02 11:16 Markus Pargmann [this message]
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 01/31] batman-adv: debugfs, avoid compiling for !DEBUG_FS Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 02/31] batman-adv: Separate logging header Markus Pargmann
2014-12-02 15:59   ` Martin Hundebøll
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 03/31] batman-adv: iv_ogm, Reduce code duplication Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 04/31] batman-adv: iv_ogm, divide and round for ring buffer avg Markus Pargmann
2015-01-12 15:52   ` Simon Wunderlich
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 05/31] batman-adv: init, Add some error handling Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 06/31] batman-adv: tvlv realloc, move error handling into if block Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 07/31] batman-adv: split tvlv into a seperate file Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 08/31] batman-adv: hash, remove function implementations from header Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 09/31] batman-adv: hash, Add helper functions Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 10/31] batman-adv: hash, replace direct hash structure accesses Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 11/31] batman-adv: hash, make struct hashtable private Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 12/31] batman-adv: hash, add used linux headers Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 13/31] batman-adv: Makefile, Sort alphabetically Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 14/31] batman-adv: iv_ogm_iface_enable, direct return values Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 15/31] batman-adv: iv_ogm_aggr_packet, bool return value Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 16/31] batman-adv: iv_ogm_send_to_if, declare char* as const Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 17/31] batman-adv: iv_ogm_can_aggregate, code readability Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 18/31] batman-adv: iv_ogm_orig_update, remove unnecessary brackets Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 19/31] batman-adv: iv_ogm_aggregate_new, simplify error handling Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 20/31] batman-adv: iv_ogm_queue_add, Simplify expressions Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 21/31] batman-adv: iv_ogm_orig_update, style, add missin brackets Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 22/31] batman-adv: iv_ogm, Fix dup_status comment Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 23/31] batman-adv: iv_ogm, fix coding style Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 24/31] batman-adv: iv_ogm, fix comment function name Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 25/31] batman-adv: types, Fix comment on bcast_own Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 26/31] batman-adv: main, Convert is_my_mac() to bool Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 27/31] batman-adv: main, batadv_compare_eth return bool Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 28/31] batman-adv: Remove unnecessary ret variable Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 29/31] batman-adv: Remove unnecessary ret variable in algo_register Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 30/31] batman-adv: packet.h, add some missing includes Markus Pargmann
2014-12-02 11:16 ` [B.A.T.M.A.N.] [PATCH 31/31] batman-adv: types.h, add missing include Markus Pargmann

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1417519009-20699-1-git-send-email-mpa@pengutronix.de \
    --to=mpa@pengutronix.de \
    --cc=antonio@meshcoding.com \
    --cc=b.a.t.m.a.n@lists.open-mesh.org \
    --cc=mareklindner@neomailbox.ch \
    --cc=sw@simonwunderlich.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).