b.a.t.m.a.n.lists.open-mesh.org archive mirror
 help / color / mirror / Atom feed
From: Marek Lindner <lindner_marek@yahoo.de>
To: The list for a Better Approach To Mobile Ad-hoc Networking
	<b.a.t.m.a.n@lists.open-mesh.org>
Subject: Re: [B.A.T.M.A.N.] [PATCH 3/8] batman-adv: randomize initial seqno to avoid collision
Date: Tue, 7 Feb 2012 19:50:50 +0800	[thread overview]
Message-ID: <201202071950.51417.lindner_marek@yahoo.de> (raw)
In-Reply-To: <4F310757.7030801@hundeboll.net>

On Tuesday, February 07, 2012 19:13:27 Martin Hundebøll wrote:
> On 2012-02-07 12:10, Marek Lindner wrote:
> >>> +	unsigned long random_seqno;
> >>> 
> >>> >  >  +
> >>> >  >  +	/* randomize initial seqno to avoid collision */
> >>> >  >  +	get_random_bytes(&random_seqno, sizeof(unsigned long));
> >>> >  >  +	atomic_set(&hard_iface->seqno, (uint32_t)random_seqno);
> >> >  
> >> >  Wouldn't it be better to cast "unsigned long" in the call to
> >> >  atomic_set()?
> > 
> > Why should it better ?
> 
> Maybe not better, but at least it is consistent with the type of
> random_seqno, which is unsigned long. I know the two types are identical,
> but nevertheless, I like to use the same type of type :)

You lost me somewhere. Yes, random_seqno is unsigned long. If we wanted to 
store unsigned long we would not need a cast. 
However, in my kernel the second argument for atomic_set() is "int" and not 
"unsigned long" which why we have a cast there.

Regards,
Marek

  reply	other threads:[~2012-02-07 11:50 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-02-07  9:19 [B.A.T.M.A.N.] B.A.T.M.A.N. V - the next steps Marek Lindner
2012-02-07  9:19 ` [B.A.T.M.A.N.] [PATCH 1/8] batman-adv: move ogm initialization into the proper function Marek Lindner
2012-02-12 14:57   ` Marek Lindner
2012-02-07  9:20 ` [B.A.T.M.A.N.] [PATCH 2/8] batman-adv: refactoring API: find generalized name for bat_ogm_init callback Marek Lindner
2012-02-07  9:20   ` [B.A.T.M.A.N.] [PATCH 3/8] batman-adv: randomize initial seqno to avoid collision Marek Lindner
2012-02-07  9:33     ` Martin Hundebøll
2012-02-07 11:10       ` Marek Lindner
2012-02-07 11:13         ` Martin Hundebøll
2012-02-07 11:50           ` Marek Lindner [this message]
2012-02-07 12:12     ` Andrew Lunn
2012-02-07 12:21       ` Marek Lindner
2012-02-07 12:46         ` Andrew Lunn
2012-02-12 15:01     ` Marek Lindner
2012-02-07  9:20   ` [B.A.T.M.A.N.] [PATCH 4/8] batman-adv: add iface_disable() callback to routing API Marek Lindner
2012-02-12 15:02     ` Marek Lindner
2012-02-07  9:20   ` [B.A.T.M.A.N.] [PATCH 5/8] batman-adv: handle routing code initialization properly Marek Lindner
2012-02-12 15:04     ` Marek Lindner
2012-02-07  9:20   ` [B.A.T.M.A.N.] [PATCH 6/8] batman-adv: refactoring API: find generalized name for bat_ogm_init_primary callback Marek Lindner
2012-02-12 15:08     ` Marek Lindner
2012-02-07  9:20   ` [B.A.T.M.A.N.] [PATCH 7/8] batman-adv: rename BATMAN_OGM_LEN to BATMAN_OGM_HLEN Marek Lindner
2012-02-12 15:09     ` Marek Lindner
2012-02-07  9:20   ` [B.A.T.M.A.N.] [PATCH 8/8] batman-adv: mark existing ogm variables as batman iv Marek Lindner
2012-02-12 15:11     ` Marek Lindner
2012-02-12 14:58   ` [B.A.T.M.A.N.] [PATCH 2/8] batman-adv: refactoring API: find generalized name for bat_ogm_init callback Marek Lindner

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=201202071950.51417.lindner_marek@yahoo.de \
    --to=lindner_marek@yahoo.de \
    --cc=b.a.t.m.a.n@lists.open-mesh.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).