bpf.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] virtio_net: reduce raw_smp_processor_id() calling in virtnet_xdp_get_sq
@ 2021-08-26  8:21 Li RongQing
  2021-08-30 21:10 ` Michael S. Tsirkin
  0 siblings, 1 reply; 5+ messages in thread
From: Li RongQing @ 2021-08-26  8:21 UTC (permalink / raw)
  To: netdev, bpf, virtualization

smp_processor_id()/raw* will be called once each when not
more queues in virtnet_xdp_get_sq() which is called in
non-preemptible context, so it's safe to call the function
smp_processor_id() once.

Signed-off-by: Li RongQing <lirongqing@baidu.com>
---
 drivers/net/virtio_net.c | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/drivers/net/virtio_net.c b/drivers/net/virtio_net.c
index 2e42210a6503..2a7b368c1da2 100644
--- a/drivers/net/virtio_net.c
+++ b/drivers/net/virtio_net.c
@@ -528,19 +528,20 @@ static int __virtnet_xdp_xmit_one(struct virtnet_info *vi,
  * functions to perfectly solve these three problems at the same time.
  */
 #define virtnet_xdp_get_sq(vi) ({                                       \
+	int cpu = smp_processor_id();                                   \
 	struct netdev_queue *txq;                                       \
 	typeof(vi) v = (vi);                                            \
 	unsigned int qp;                                                \
 									\
 	if (v->curr_queue_pairs > nr_cpu_ids) {                         \
 		qp = v->curr_queue_pairs - v->xdp_queue_pairs;          \
-		qp += smp_processor_id();                               \
+		qp += cpu;                                              \
 		txq = netdev_get_tx_queue(v->dev, qp);                  \
 		__netif_tx_acquire(txq);                                \
 	} else {                                                        \
-		qp = smp_processor_id() % v->curr_queue_pairs;          \
+		qp = cpu % v->curr_queue_pairs;                         \
 		txq = netdev_get_tx_queue(v->dev, qp);                  \
-		__netif_tx_lock(txq, raw_smp_processor_id());           \
+		__netif_tx_lock(txq, cpu);                              \
 	}                                                               \
 	v->sq + qp;                                                     \
 })
-- 
2.33.0.69.gc420321.dirty


^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [PATCH] virtio_net: reduce raw_smp_processor_id() calling in virtnet_xdp_get_sq
  2021-08-26  8:21 [PATCH] virtio_net: reduce raw_smp_processor_id() calling in virtnet_xdp_get_sq Li RongQing
@ 2021-08-30 21:10 ` Michael S. Tsirkin
  2021-08-31  2:09   ` 答复: " Li,Rongqing
  0 siblings, 1 reply; 5+ messages in thread
From: Michael S. Tsirkin @ 2021-08-30 21:10 UTC (permalink / raw)
  To: Li RongQing; +Cc: netdev, bpf, virtualization

On Thu, Aug 26, 2021 at 04:21:35PM +0800, Li RongQing wrote:
> smp_processor_id()/raw* will be called once each when not
> more queues in virtnet_xdp_get_sq() which is called in
> non-preemptible context, so it's safe to call the function
> smp_processor_id() once.
> 
> Signed-off-by: Li RongQing <lirongqing@baidu.com>

commit log should probably explain why it's a good idea
to replace raw_smp_processor_id with smp_processor_id
in the case of curr_queue_pairs <= nr_cpu_ids.

> ---
>  drivers/net/virtio_net.c | 7 ++++---
>  1 file changed, 4 insertions(+), 3 deletions(-)
> 
> diff --git a/drivers/net/virtio_net.c b/drivers/net/virtio_net.c
> index 2e42210a6503..2a7b368c1da2 100644
> --- a/drivers/net/virtio_net.c
> +++ b/drivers/net/virtio_net.c
> @@ -528,19 +528,20 @@ static int __virtnet_xdp_xmit_one(struct virtnet_info *vi,
>   * functions to perfectly solve these three problems at the same time.
>   */
>  #define virtnet_xdp_get_sq(vi) ({                                       \
> +	int cpu = smp_processor_id();                                   \
>  	struct netdev_queue *txq;                                       \
>  	typeof(vi) v = (vi);                                            \
>  	unsigned int qp;                                                \
>  									\
>  	if (v->curr_queue_pairs > nr_cpu_ids) {                         \
>  		qp = v->curr_queue_pairs - v->xdp_queue_pairs;          \
> -		qp += smp_processor_id();                               \
> +		qp += cpu;                                              \
>  		txq = netdev_get_tx_queue(v->dev, qp);                  \
>  		__netif_tx_acquire(txq);                                \
>  	} else {                                                        \
> -		qp = smp_processor_id() % v->curr_queue_pairs;          \
> +		qp = cpu % v->curr_queue_pairs;                         \
>  		txq = netdev_get_tx_queue(v->dev, qp);                  \
> -		__netif_tx_lock(txq, raw_smp_processor_id());           \
> +		__netif_tx_lock(txq, cpu);                              \
>  	}                                                               \
>  	v->sq + qp;                                                     \
>  })
> -- 
> 2.33.0.69.gc420321.dirty
> 
> 


^ permalink raw reply	[flat|nested] 5+ messages in thread

* 答复: [PATCH] virtio_net: reduce raw_smp_processor_id() calling in virtnet_xdp_get_sq
  2021-08-30 21:10 ` Michael S. Tsirkin
@ 2021-08-31  2:09   ` Li,Rongqing
  2021-08-31 14:33     ` Michael S. Tsirkin
  0 siblings, 1 reply; 5+ messages in thread
From: Li,Rongqing @ 2021-08-31  2:09 UTC (permalink / raw)
  To: Michael S. Tsirkin; +Cc: netdev, bpf, virtualization

> -----邮件原件-----
> 发件人: Michael S. Tsirkin <mst@redhat.com>
> 发送时间: 2021年8月31日 5:10
> 收件人: Li,Rongqing <lirongqing@baidu.com>
> 抄送: netdev@vger.kernel.org; bpf@vger.kernel.org;
> virtualization@lists.linux-foundation.org
> 主题: Re: [PATCH] virtio_net: reduce raw_smp_processor_id() calling in
> virtnet_xdp_get_sq
> 
> On Thu, Aug 26, 2021 at 04:21:35PM +0800, Li RongQing wrote:
> > smp_processor_id()/raw* will be called once each when not more queues
> > in virtnet_xdp_get_sq() which is called in non-preemptible context, so
> > it's safe to call the function
> > smp_processor_id() once.
> >
> > Signed-off-by: Li RongQing <lirongqing@baidu.com>
> 
> commit log should probably explain why it's a good idea to replace
> raw_smp_processor_id with smp_processor_id in the case of curr_queue_pairs
> <= nr_cpu_ids.
> 


I change it as below, is it ok?

    virtio_net: reduce raw_smp_processor_id() calling in virtnet_xdp_get_sq

    smp_processor_id() and raw_smp_processor_id() are called once
    each in virtnet_xdp_get_sq(), when curr_queue_pairs <= nr_cpu_ids,
    should be merged

    virtnet_xdp_get_sq() is called in non-preemptible context, so
    it's safe to call the function smp_processor_id(), and keep
    smp_processor_id(), and remove the calling of raw_smp_processor_id(),
    avoid the wrong use virtnet_xdp_get_sq to preemptible context
    in the future

-Li

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: 答复: [PATCH] virtio_net: reduce raw_smp_processor_id() calling in virtnet_xdp_get_sq
  2021-08-31  2:09   ` 答复: " Li,Rongqing
@ 2021-08-31 14:33     ` Michael S. Tsirkin
  2021-09-03  4:00       ` 答复: " Li,Rongqing
  0 siblings, 1 reply; 5+ messages in thread
From: Michael S. Tsirkin @ 2021-08-31 14:33 UTC (permalink / raw)
  To: Li,Rongqing; +Cc: netdev, bpf, virtualization

On Tue, Aug 31, 2021 at 02:09:36AM +0000, Li,Rongqing wrote:
> > -----邮件原件-----
> > 发件人: Michael S. Tsirkin <mst@redhat.com>
> > 发送时间: 2021年8月31日 5:10
> > 收件人: Li,Rongqing <lirongqing@baidu.com>
> > 抄送: netdev@vger.kernel.org; bpf@vger.kernel.org;
> > virtualization@lists.linux-foundation.org
> > 主题: Re: [PATCH] virtio_net: reduce raw_smp_processor_id() calling in
> > virtnet_xdp_get_sq
> > 
> > On Thu, Aug 26, 2021 at 04:21:35PM +0800, Li RongQing wrote:
> > > smp_processor_id()/raw* will be called once each when not more queues
> > > in virtnet_xdp_get_sq() which is called in non-preemptible context, so
> > > it's safe to call the function
> > > smp_processor_id() once.
> > >
> > > Signed-off-by: Li RongQing <lirongqing@baidu.com>
> > 
> > commit log should probably explain why it's a good idea to replace
> > raw_smp_processor_id with smp_processor_id in the case of curr_queue_pairs
> > <= nr_cpu_ids.
> > 
> 
> 
> I change it as below, is it ok?
> 
>     virtio_net: reduce raw_smp_processor_id() calling in virtnet_xdp_get_sq

shorter:

virtio_net: s/raw_smp_processor_id/smp_processor_id/ in virtnet_xdp_get_sq


> 
>     smp_processor_id() and raw_smp_processor_id() are called once
>     each in virtnet_xdp_get_sq(), when curr_queue_pairs <= nr_cpu_ids,
>     should be merged

I'd just drop this part.

> 
>     virtnet_xdp_get_sq() is called in non-preemptible context, so
>     it's safe to call the function smp_processor_id(), and keep
>     smp_processor_id(), and remove the calling of raw_smp_processor_id(),
>     avoid the wrong use virtnet_xdp_get_sq to preemptible context
>     in the future

s/avoid.*/this way we'll get a warning if this is ever called in a preemptible context/


> 
> -Li


^ permalink raw reply	[flat|nested] 5+ messages in thread

* 答复: 答复: [PATCH] virtio_net: reduce raw_smp_processor_id() calling in virtnet_xdp_get_sq
  2021-08-31 14:33     ` Michael S. Tsirkin
@ 2021-09-03  4:00       ` Li,Rongqing
  0 siblings, 0 replies; 5+ messages in thread
From: Li,Rongqing @ 2021-09-03  4:00 UTC (permalink / raw)
  To: Michael S. Tsirkin; +Cc: netdev, bpf, virtualization



> -----邮件原件-----
> 发件人: Michael S. Tsirkin <mst@redhat.com>
> 发送时间: 2021年8月31日 22:34
> 收件人: Li,Rongqing <lirongqing@baidu.com>
> 抄送: netdev@vger.kernel.org; bpf@vger.kernel.org;
> virtualization@lists.linux-foundation.org
> 主题: Re: 答复: [PATCH] virtio_net: reduce raw_smp_processor_id() calling in
> virtnet_xdp_get_sq
> 
> On Tue, Aug 31, 2021 at 02:09:36AM +0000, Li,Rongqing wrote:
> > > -----邮件原件-----
> > > 发件人: Michael S. Tsirkin <mst@redhat.com>
> > > 发送时间: 2021年8月31日 5:10
> > > 收件人: Li,Rongqing <lirongqing@baidu.com>
> > > 抄送: netdev@vger.kernel.org; bpf@vger.kernel.org;
> > > virtualization@lists.linux-foundation.org
> > > 主题: Re: [PATCH] virtio_net: reduce raw_smp_processor_id() calling in
> > > virtnet_xdp_get_sq
> > >
> > > On Thu, Aug 26, 2021 at 04:21:35PM +0800, Li RongQing wrote:
> > > > smp_processor_id()/raw* will be called once each when not more
> > > > queues in virtnet_xdp_get_sq() which is called in non-preemptible
> > > > context, so it's safe to call the function
> > > > smp_processor_id() once.
> > > >
> > > > Signed-off-by: Li RongQing <lirongqing@baidu.com>
> > >
> > > commit log should probably explain why it's a good idea to replace
> > > raw_smp_processor_id with smp_processor_id in the case of
> > > curr_queue_pairs <= nr_cpu_ids.
> > >
> >
> >
> > I change it as below, is it ok?
> >
> >     virtio_net: reduce raw_smp_processor_id() calling in
> > virtnet_xdp_get_sq
> 
> shorter:
> 
> virtio_net: s/raw_smp_processor_id/smp_processor_id/ in virtnet_xdp_get_sq
> 
> 
> >
> >     smp_processor_id() and raw_smp_processor_id() are called once
> >     each in virtnet_xdp_get_sq(), when curr_queue_pairs <= nr_cpu_ids,
> >     should be merged
> 
> I'd just drop this part.
> 
> >
> >     virtnet_xdp_get_sq() is called in non-preemptible context, so
> >     it's safe to call the function smp_processor_id(), and keep
> >     smp_processor_id(), and remove the calling of raw_smp_processor_id(),
> >     avoid the wrong use virtnet_xdp_get_sq to preemptible context
> >     in the future
> 
> s/avoid.*/this way we'll get a warning if this is ever called in a preemptible
> context/
> 


Thanks, should I resend it

-Li


> 
> >
> > -Li


^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2021-09-03  4:00 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-08-26  8:21 [PATCH] virtio_net: reduce raw_smp_processor_id() calling in virtnet_xdp_get_sq Li RongQing
2021-08-30 21:10 ` Michael S. Tsirkin
2021-08-31  2:09   ` 答复: " Li,Rongqing
2021-08-31 14:33     ` Michael S. Tsirkin
2021-09-03  4:00       ` 答复: " Li,Rongqing

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).