bpf.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v3 0/9] sections: Unify kernel sections range check and use
@ 2021-09-26  7:20 Kefeng Wang
  2021-09-26  7:20 ` [PATCH v3 1/9] kallsyms: Remove arch specific text and data check Kefeng Wang
                   ` (8 more replies)
  0 siblings, 9 replies; 12+ messages in thread
From: Kefeng Wang @ 2021-09-26  7:20 UTC (permalink / raw)
  To: arnd, linux-arch, linux-kernel, linuxppc-dev, rostedt, mingo,
	davem, ast, ryabinin.a.a, akpm
  Cc: mpe, benh, paulus, bpf, Kefeng Wang

There are three head files(kallsyms.h, kernel.h and sections.h) which
include the kernel sections range check, let's make some cleanup and
unify them.

1. cleanup arch specific text/data check and fix address boundary check
   in kallsyms.h
2. make all the basic/core kernel range check function into sections.h
3. update all the callers, and use the helper in sections.h to simplify
   the code

After this series, we have 5 APIs about kernel sections range check in
sections.h

 * is_kernel_rodata()		--- already in sections.h
 * is_kernel_core_data()	--- come from core_kernel_data() in kernel.h
 * is_kernel_inittext()		--- come from kernel.h and kallsyms.h
 * __is_kernel_text()		--- add new internal helper
 * __is_kernel()		--- add new internal helper

Note: For the last two helpers, people should not use directly, consider to
      use corresponding function in kallsyms.h.

v3:
- Add Steven's RB to patch2
- Introduce two internal helper, then use is_kernel_text() in core_kernel_text()
  and is_kernel() in kernel_or_module_addr() suggested by Steven

v2:
https://lore.kernel.org/linux-arch/20210728081320.20394-1-wangkefeng.wang@huawei.com/
- add ACK/RW to patch2, and drop inappropriate fix tag
- keep 'core' to check kernel data, suggestted by Steven Rostedt
  <rostedt@goodmis.org>, rename is_kernel_data() to is_kernel_core_data()
- drop patch8 which is merged
- drop patch9 which is resend independently

v1:
https://lore.kernel.org/linux-arch/20210626073439.150586-1-wangkefeng.wang@huawei.com

Cc: linuxppc-dev@lists.ozlabs.org
Cc: linux-arch@vger.kernel.org 
Cc: bpf@vger.kernel.org 

Kefeng Wang (9):
  kallsyms: Remove arch specific text and data check
  kallsyms: Fix address-checks for kernel related range
  sections: Move and rename core_kernel_data() to is_kernel_core_data()
  sections: Move is_kernel_inittext() into sections.h
  x86: mm: Rename __is_kernel_text() to is_x86_32_kernel_text()
  sections: Provide internal __is_kernel() and __is_kernel_text() helper
  mm: kasan: Use is_kernel() helper
  extable: Use is_kernel_text() helper
  powerpc/mm: Use is_kernel_text() and is_kernel_inittext() helper

 arch/powerpc/mm/pgtable_32.c   |  7 +---
 arch/x86/kernel/unwind_orc.c   |  2 +-
 arch/x86/mm/init_32.c          | 14 +++----
 include/asm-generic/sections.h | 75 ++++++++++++++++++++++++++--------
 include/linux/kallsyms.h       | 13 +-----
 include/linux/kernel.h         |  2 -
 kernel/extable.c               | 33 ++-------------
 kernel/locking/lockdep.c       |  3 --
 kernel/trace/ftrace.c          |  2 +-
 mm/kasan/report.c              |  2 +-
 net/sysctl_net.c               |  2 +-
 11 files changed, 75 insertions(+), 80 deletions(-)

-- 
2.26.2


^ permalink raw reply	[flat|nested] 12+ messages in thread

end of thread, other threads:[~2021-09-29  1:14 UTC | newest]

Thread overview: 12+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-09-26  7:20 [PATCH v3 0/9] sections: Unify kernel sections range check and use Kefeng Wang
2021-09-26  7:20 ` [PATCH v3 1/9] kallsyms: Remove arch specific text and data check Kefeng Wang
2021-09-26  7:20 ` [PATCH v3 2/9] kallsyms: Fix address-checks for kernel related range Kefeng Wang
2021-09-26  7:20 ` [PATCH v3 3/9] sections: Move and rename core_kernel_data() to is_kernel_core_data() Kefeng Wang
2021-09-26  7:20 ` [PATCH v3 4/9] sections: Move is_kernel_inittext() into sections.h Kefeng Wang
2021-09-26  7:20 ` [PATCH v3 5/9] x86: mm: Rename __is_kernel_text() to is_x86_32_kernel_text() Kefeng Wang
2021-09-26  7:20 ` [PATCH v3 6/9] sections: Provide internal __is_kernel() and __is_kernel_text() helper Kefeng Wang
2021-09-26  7:20 ` [PATCH v3 7/9] mm: kasan: Use is_kernel() helper Kefeng Wang
2021-09-26  7:20 ` [PATCH v3 8/9] extable: Use is_kernel_text() helper Kefeng Wang
2021-09-26  7:20 ` [PATCH v3 9/9] powerpc/mm: Use is_kernel_text() and is_kernel_inittext() helper Kefeng Wang
2021-09-28 17:51   ` Christophe Leroy
2021-09-29  1:14     ` Kefeng Wang

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).