bpf.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-05-19 19:30:11 to 2020-05-22 00:34:35 UTC [more...]

[PATCH v2 bpf-next 0/7] BPF ring buffer
 2020-05-22  0:34 UTC  (6+ messages)
` [PATCH v2 bpf-next 1/7] bpf: implement BPF ring buffer and verifier support for it
` [PATCH v2 bpf-next 2/7] tools/memory-model: add BPF ringbuf MPSC litmus tests

clean up and streamline probe_kernel_* and friends v4
 2020-05-22  0:22 UTC  (30+ messages)
` [PATCH 01/23] maccess: unexport probe_kernel_write and probe_user_write
` [PATCH 02/23] maccess: remove various unused weak aliases
` [PATCH 03/23] maccess: remove duplicate kerneldoc comments
` [PATCH 04/23] maccess: clarify "
` [PATCH 05/23] maccess: update the top of file comment
` [PATCH 06/23] maccess: rename strncpy_from_unsafe_user to strncpy_from_user_nofault
` [PATCH 07/23] maccess: rename strncpy_from_unsafe_strict to strncpy_from_kernel_nofault
` [PATCH 08/23] maccess: rename strnlen_unsafe_user to strnlen_user_nofault
` [PATCH 09/23] maccess: remove probe_read_common and probe_write_common
` [PATCH 10/23] maccess: unify the probe kernel arch hooks
` [PATCH 11/23] bpf: factor out a bpf_trace_copy_string helper
` [PATCH 12/23] bpf: handle the compat string in bpf_trace_copy_string better
` [PATCH 13/23] bpf: rework the compat kernel probe handling
` [PATCH 14/23] tracing/kprobes: handle mixed kernel/userspace probes better
` [PATCH 15/23] maccess: remove strncpy_from_unsafe
` [PATCH 16/23] maccess: always use strict semantics for probe_kernel_read
` [PATCH 17/23] maccess: move user access routines together
` [PATCH 18/23] maccess: allow architectures to provide kernel probing directly
` [PATCH 19/23] x86: use non-set_fs based maccess routines
` [PATCH 20/23] maccess: rename probe_kernel_{read,write} to copy_{from,to}_kernel_nofault
` [PATCH 21/23] maccess: rename probe_user_{read,write} to copy_{from,to}_user_nofault
` [PATCH 22/23] maccess: rename probe_kernel_address to get_kernel_nofault
` [PATCH 23/23] maccess: return -ERANGE when copy_from_kernel_nofault_allowed fails

[PATCH bpf-next 0/3] bpf: Allow inner map with different max_entries
 2020-05-22  0:06 UTC  (9+ messages)
` [PATCH bpf-next 1/3] bpf: Clean up inner map type check
` [PATCH bpf-next 2/3] bpf: Relax the max_entries check for inner map
` [PATCH bpf-next 3/3] bpf: selftests: Add test for different inner map size

[bpf-next PATCH v2 0/4] ] verifier, improve ptr is_branch_taken logic
 2020-05-21 22:21 UTC  (6+ messages)
` [bpf-next PATCH v2 1/4] bpf: verifier track null pointer branch_taken with JNE and JEQ
` [bpf-next PATCH v2 2/4] bpf: selftests, verifier case for non null pointer check branch taken
` [bpf-next PATCH v2 3/4] bpf: selftests, verifier case for non null pointer map value branch
` [bpf-next PATCH v2 4/4] bpf: selftests, add printk to test_sk_lookup_kern to encode null ptr check

[PATCH net-next] Extending bpf_setsockopt with SO_BINDTODEVICE sockopt
 2020-05-21 21:55 UTC  (4+ messages)

[bpf-next PATCH v3 0/5] bpf: Add sk_msg and networking helpers
 2020-05-21 19:12 UTC  (15+ messages)
` [bpf-next PATCH v3 1/5] bpf: sk_msg add some generic helpers that may be useful from sk_msg
` [bpf-next PATCH v3 2/5] bpf: extend bpf_base_func_proto helpers with probe_* and *current_task*
` [bpf-next PATCH v3 3/5] bpf: sk_msg add get socket storage helpers
` [bpf-next PATCH v3 4/5] bpf: selftests, add sk_msg helpers load and attach test
` [bpf-next PATCH v3 5/5] bpf: selftests, test probe_* helpers from SCHED_CLS

[PATCH bpf] flow_dissector: Drop BPF flow dissector prog ref on netns cleanup
 2020-05-21 19:08 UTC  (5+ messages)

accessing global and per-cpu vars
 2020-05-21 18:58 UTC  (2+ messages)

[PATCH bpf v2] flow_dissector: Drop BPF flow dissector prog ref on netns cleanup
 2020-05-21 18:14 UTC  (3+ messages)

[PATCH bpf-next v4 00/15] Introduce AF_XDP buffer allocation API
 2020-05-21 18:06 UTC  (27+ messages)
` [PATCH bpf-next v4 01/15] xsk: fix xsk_umem_xdp_frame_sz()
` [PATCH bpf-next v4 02/15] xsk: move xskmap.c to net/xdp/
` [PATCH bpf-next v4 03/15] xsk: move driver interface to xdp_sock_drv.h
` [PATCH bpf-next v4 04/15] xsk: move defines only used by AF_XDP internals to xsk.h
` [PATCH bpf-next v4 05/15] xsk: introduce AF_XDP buffer allocation API
` [PATCH bpf-next v4 06/15] i40e: refactor rx_bi accesses
` [PATCH bpf-next v4 07/15] i40e: separate kernel allocated rx_bi rings from AF_XDP rings
` [PATCH bpf-next v4 08/15] i40e, xsk: migrate to new MEM_TYPE_XSK_BUFF_POOL
` [PATCH bpf-next v4 09/15] ice, "
` [PATCH bpf-next v4 10/15] ixgbe, "
` [PATCH bpf-next v4 11/15] mlx5, "
` [PATCH bpf-next v4 12/15] xsk: remove MEM_TYPE_ZERO_COPY and corresponding code
` [PATCH bpf-next v4 13/15] xdp: simplify xdp_return_{frame,frame_rx_napi,buff}
` [PATCH bpf-next v4 14/15] xsk: explicitly inline functions and move definitions
` [PATCH bpf-next v4 15/15] MAINTAINERS, xsk: update AF_XDP section after moves/adds

[PATCH 0/7] Share events between metrics
 2020-05-21 17:28 UTC  (23+ messages)
` [PATCH 1/7] perf metricgroup: Change evlist_used to a bitmap
` [PATCH 2/7] perf metricgroup: Always place duration_time last
` [PATCH 3/7] perf metricgroup: Delay events string creation
` [PATCH 4/7] perf metricgroup: Order event groups by size
` [PATCH 5/7] perf metricgroup: Remove duped metric group events
` [PATCH 6/7] perf metricgroup: Add options to not group or merge
` [PATCH 7/7] perf metricgroup: Remove unnecessary ',' from events

[PATCH v2 0/7] Share events between metrics
 2020-05-21 17:22 UTC  (10+ messages)
` [PATCH v2 1/7] perf metricgroup: Always place duration_time last
` [PATCH v2 2/7] perf metricgroup: Use early return in add_metric
` [PATCH v2 3/7] perf metricgroup: Delay events string creation
` [PATCH v2 4/7] perf metricgroup: Order event groups by size
` [PATCH v2 5/7] perf metricgroup: Remove duped metric group events
` [PATCH v2 6/7] perf metricgroup: Add options to not group or merge
` [PATCH v2 7/7] perf metricgroup: Remove unnecessary ',' from events

[RFC PATCH v3 00/14] Share events between metrics
 2020-05-21 17:07 UTC  (8+ messages)
` [RFC PATCH v3 09/14] perf metricgroup: free metric_events on error
` [RFC PATCH v3 12/14] perf metricgroup: order event groups by size

[PATCH] files: Use rcu lock to get the file structures for better performance
 2020-05-21 16:47 UTC  (5+ messages)
  ` [External] "

[RFC PATCH bpf-next 0/1] bpf, x64: optimize JIT prologue/epilogue generation
 2020-05-21  4:05 UTC  (7+ messages)
      ` getting bpf_tail_call to work with bpf function calls. Was: "

[PATCH bpf] bpf: prevent mmap()'ing read-only maps as writable
 2020-05-21  3:29 UTC  (3+ messages)

[PATCH bpf] security: Fix hook iteration for secid_to_secctx
 2020-05-21  3:12 UTC  (5+ messages)

[Ksummit-discuss] [TECH TOPIC] seccomp feature development
 2020-05-21  0:43 UTC  (3+ messages)

[PATCH] selftests/bpf: install btf .c files
 2020-05-20 21:45 UTC  (4+ messages)

[PATCH bpf-next v5 00/15] Introduce AF_XDP buffer allocation API
 2020-05-20 19:21 UTC  (16+ messages)
` [PATCH bpf-next v5 01/15] xsk: fix xsk_umem_xdp_frame_sz()
` [PATCH bpf-next v5 02/15] xsk: move xskmap.c to net/xdp/
` [PATCH bpf-next v5 03/15] xsk: move driver interface to xdp_sock_drv.h
` [PATCH bpf-next v5 04/15] xsk: move defines only used by AF_XDP internals to xsk.h
` [PATCH bpf-next v5 05/15] xsk: introduce AF_XDP buffer allocation API
` [PATCH bpf-next v5 06/15] i40e: refactor rx_bi accesses
` [PATCH bpf-next v5 07/15] i40e: separate kernel allocated rx_bi rings from AF_XDP rings
` [PATCH bpf-next v5 08/15] i40e, xsk: migrate to new MEM_TYPE_XSK_BUFF_POOL
` [PATCH bpf-next v5 09/15] ice, "
` [PATCH bpf-next v5 10/15] ixgbe, "
` [PATCH bpf-next v5 11/15] mlx5, "
` [PATCH bpf-next v5 12/15] xsk: remove MEM_TYPE_ZERO_COPY and corresponding code
` [PATCH bpf-next v5 13/15] xdp: simplify xdp_return_{frame,frame_rx_napi,buff}
` [PATCH bpf-next v5 14/15] xsk: explicitly inline functions and move definitions
` [PATCH bpf-next v5 15/15] MAINTAINERS, xsk: update AF_XDP section after moves/adds

clean up and streamline probe_kernel_* and friends v3
 2020-05-20 16:16 UTC  (7+ messages)
` [PATCH 13/20] maccess: always use strict semantics for probe_kernel_read
` [PATCH 20/20] maccess: return -ERANGE when copy_from_kernel_nofault_allowed fails

XDP socket DOS bug
 2020-05-20 15:16 UTC 

[PATCH] perf bpf-loader: Add missing '*' for key_scan_pos
 2020-05-20 14:30 UTC  (5+ messages)

seccomp feature development
 2020-05-20  6:18 UTC  (5+ messages)

[PATCH bpf-next] selftests/bpf: add general instructions for test execution
 2020-05-20  5:26 UTC  (4+ messages)

BPF for hash calculation
 2020-05-20  2:35 UTC 

[PATCH v3 0/7] Copy hashmap to tools/perf/util, use in perf expr
 2020-05-20  2:34 UTC  (6+ messages)
` [PATCH v3 6/7] perf test: Improve pmu event metric testing

UBSAN: array-index-out-of-bounds in kernel/bpf/arraymap.c:177
 2020-05-20  1:55 UTC  (9+ messages)

[RFC PATCH bpf-next 0/2] xdp: add dev map multicast support
 2020-05-20  1:24 UTC  (7+ messages)
` [RFC PATCHv2 "
  ` [RFC PATCHv2 bpf-next 1/2] xdp: add a new helper for "

[PATCH bpf-next] selftests/bpf: convert bpf_iter_test_kern{3,4}.c to define own bpf_iter_meta
 2020-05-19 21:11 UTC  (3+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).