bpf.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-07-13 05:13:07 to 2020-07-15 19:26:59 UTC [more...]

[PATCH bpf] bpf: Shift and mask loads narrower than context field size
 2020-07-15 19:26 UTC  (3+ messages)

[PATCH] tools/bpftool: Fix error return code in do_skeleton()
 2020-07-15 19:23 UTC  (3+ messages)

[PATCH bpf-next 0/6] bpf: Support multi-attach for freplace programs
 2020-07-15 19:02 UTC  (17+ messages)
` [PATCH bpf-next 1/6] bpf: change logging calls from verbose() to bpf_log() and use log pointer
` [PATCH bpf-next 2/6] bpf: verifier: refactor check_attach_btf_id()
` [PATCH bpf-next 3/6] bpf: support attaching freplace programs to multiple attach points
` [PATCH bpf-next 4/6] tools: add new members to bpf_attr.raw_tracepoint in bpf.h
  ` BPF logging infrastructure. Was: "
` [PATCH bpf-next 5/6] libbpf: add support for supplying target to bpf_raw_tracepoint_open()
` [PATCH bpf-next 6/6] selftests: add test for multiple attachments of freplace program

[RFC PATCH bpf-next 0/3] bpf, riscv: Add compressed instructions to rv64 JIT
 2020-07-15 18:12 UTC  (8+ messages)
` [RFC PATCH bpf-next 1/3] bpf, riscv: Modify JIT ctx to support compressed instructions
` [RFC PATCH bpf-next 2/3] bpf, riscv: Add encodings for "
` [RFC PATCH bpf-next 3/3] bpf, riscv: Use compressed instructions in the rv64 JIT

[PATCH bpf-next 00/13] bpf: implement bpf iterator for map elements
 2020-07-15 17:52 UTC  (18+ messages)
` [PATCH bpf-next 01/13] bpf: refactor bpf_iter_reg to have separate seq_info member
` [PATCH bpf-next 02/13] bpf: refactor to provide aux info to bpf_iter_init_seq_priv_t
` [PATCH bpf-next 03/13] bpf: support readonly buffer in verifier
` [PATCH bpf-next 04/13] bpf: implement bpf iterator for map elements
` [PATCH bpf-next 05/13] bpf: implement bpf iterator for hash maps
` [PATCH bpf-next 06/13] bpf: implement bpf iterator for array maps
` [PATCH bpf-next 07/13] bpf: implement bpf iterator for sock local storage map
` [PATCH bpf-next 08/13] tools/libbpf: add support for bpf map element iterator
` [PATCH bpf-next 09/13] tools/bpftool: add bpftool "
` [PATCH bpf-next 10/13] selftests/bpf: add test for bpf hash map iterators
` [PATCH bpf-next 11/13] selftests/bpf: add test for bpf array "
` [PATCH bpf-next 12/13] selftests/bpf: add a test for bpf sk_storage_map iterator
` [PATCH bpf-next 13/13] selftests/bpf: add a test for out of bound rdonly buf access

[PATCH bpf-next] bpftool: use only nftw for file tree parsing
 2020-07-15 17:35 UTC  (2+ messages)

[PATCH bpf-next 2/7] bpf, xdp: add bpf_link-based XDP attachment API
 2020-07-15 15:48 UTC  (11+ messages)
  ` [PATCH bpf-next 4/7] bpf: implement BPF XDP link-specific introspection APIs

[PATCH bpf-next v2 0/6] bpf: Support multi-attach for freplace programs
 2020-07-15 13:09 UTC  (7+ messages)
` [PATCH bpf-next v2 1/6] bpf: change logging calls from verbose() to bpf_log() and use log pointer
` [PATCH bpf-next v2 2/6] bpf: verifier: refactor check_attach_btf_id()
` [PATCH bpf-next v2 3/6] bpf: support attaching freplace programs to multiple attach points
` [PATCH bpf-next v2 4/6] tools: add new members to bpf_attr.raw_tracepoint in bpf.h
` [PATCH bpf-next v2 5/6] libbpf: add support for supplying target to bpf_raw_tracepoint_open()
` [PATCH bpf-next v2 6/6] selftests: add test for multiple attachments of freplace program

[PATCHv6 bpf-next 0/3] xdp: add a new helper for dev map multicast support
 2020-07-15 13:08 UTC  (16+ messages)
` [PATCHv7 "
  ` [PATCHv7 bpf-next 1/3] "
  ` [PATCHv7 bpf-next 2/3] sample/bpf: add xdp_redirect_map_multicast test
  ` [PATCHv7 bpf-next 3/3] selftests/bpf: add xdp_redirect_multi test
  ` [PATCHv8 bpf-next 0/3] xdp: add a new helper for dev map multicast support
    ` [PATCHv8 bpf-next 1/3] "
    ` [PATCHv8 bpf-next 2/3] sample/bpf: add xdp_redirect_map_multicast test
    ` [PATCHv8 bpf-next 3/3] selftests/bpf: add xdp_redirect_multi test

[PATCH 0/4] s390/bpf: implement BPF_PROBE_MEM
 2020-07-15 12:32 UTC  (5+ messages)
` [PATCH 1/4] s390/kernel: unify EX_TABLE* implementations
` [PATCH 2/4] s390/kernel: expand the exception table logic to allow new handling options
` [PATCH 3/4] s390/bpf: implement BPF_PROBE_MEM
` [PATCH 4/4] selftests/bpf: add exception handling test

[PATCH bpf-next v2 00/14] xsk: support shared umems between devices and queues
 2020-07-15  9:09 UTC  (5+ messages)
` [PATCH bpf-next v2 04/14] xsk: move fill and completion rings to buffer pool
` [PATCH bpf-next v2 11/14] xsk: add shared umem support between devices

[PATCH bpf-next v4 0/4] Generalizing bpf_local_storage
 2020-07-15  8:57 UTC  (4+ messages)
` [PATCH bpf-next v4 1/4] bpf: Generalize bpf_sk_storage

[PATCH bpf-next] bpf: add a new bpf argument type ARG_CONST_MAP_PTR_OR_NULL
 2020-07-15  7:00 UTC 

[PATCH v2 bpf-next 0/2] bpf: fix stackmap on perf_events with PEBS
 2020-07-15  5:26 UTC  (3+ messages)
` [PATCH v2 bpf-next 1/2] bpf: separate bpf_get_[stack|stackid] for perf events BPF
` [PATCH v2 bpf-next 2/2] selftests/bpf: add callchain_stackid

[PATCH bpf-next v2 0/4] bpf: cgroup skb improvements for bpf_prog_test_run
 2020-07-15  4:54 UTC  (7+ messages)
` [PATCH bpf-next v2 1/4] bpf: setup socket family and addresses in bpf_prog_test_run_skb
` [PATCH bpf-next v2 2/4] bpf: allow to specify ifindex for skb "
` [PATCH bpf-next v2 3/4] bpf: export some cgroup storages allocation helpers for reusing
` [PATCH bpf-next v2 4/4] bpf: try to use existing cgroup storage in bpf_prog_test_run_skb

pull-request: bpf-next 2020-07-14
 2020-07-15  0:02 UTC  (2+ messages)

[PATCH v2 bpf-next 0/5] Make BPF CGROUP_STORAGE map usable by different programs at once
 2020-07-14 23:53 UTC  (3+ messages)
` [PATCH v2 bpf-next 3/5] bpf: Make cgroup storages shared across attaches on the same cgroup

[RFC PATCH bpf-next 0/5] bpf: tailcalls in BPF subprograms
 2020-07-14 22:34 UTC  (11+ messages)
` [RFC PATCH bpf-next 4/5] bpf, x64: rework pro/epilogue and tailcall handling in JIT

[RFC][PATCH] net/bpfilter: Remove this broken and apparently unmantained
 2020-07-14 19:42 UTC  (11+ messages)
        ` [PATCH 00/14] Make the user mode driver code a better citizen
            ` [PATCH v2 00/15] "
              ` [PATCH v3 00/16] "
                ` [merged][PATCH "

[PATCH] bpfilter: allow to build bpfilter_umh as a module without static library
 2020-07-14 19:39 UTC  (4+ messages)

[PATCH 5.7 132/166] bpf: Check correct cred for CAP_SYSLOG in bpf_dump_raw_ok()
 2020-07-14 18:44 UTC 

[PATCH 5.4 091/109] bpf: Check correct cred for CAP_SYSLOG in bpf_dump_raw_ok()
 2020-07-14 18:44 UTC 

[PATCH 4.19 51/58] bpf: Check correct cred for CAP_SYSLOG in bpf_dump_raw_ok()
 2020-07-14 18:44 UTC 

[PATCH v2 bpf-next 0/8] BPF XDP link
 2020-07-14 18:39 UTC  (13+ messages)
` [PATCH v2 bpf-next 1/8] bpf, xdp: maintain info on attached XDP BPF programs in net_device
` [PATCH v2 bpf-next 2/8] bpf, xdp: extract commong XDP program attachment logic
` [PATCH v2 bpf-next 3/8] bpf, xdp: add bpf_link-based XDP attachment API
` [PATCH v2 bpf-next 4/8] bpf, xdp: implement LINK_UPDATE for BPF XDP link
` [PATCH v2 bpf-next 5/8] bpf: implement BPF XDP link-specific introspection APIs
` [PATCH v2 bpf-next 6/8] libbpf: add support for BPF XDP link
` [PATCH v2 bpf-next 7/8] selftests/bpf: add BPF XDP link selftests
` [PATCH v2 bpf-next 8/8] bpf, xdp: remove XDP_QUERY_PROG and XDP_QUERY_PROG_HW XDP commands

[Linux-kernel-mentees] [PATCH] bpf: Fix NULL pointer dereference in __btf_resolve_helper_id()
 2020-07-14 18:09 UTC  (6+ messages)
  ` [Linux-kernel-mentees] [PATCH v2] "
        ` [Linux-kernel-mentees] [PATCH v3] "

[PATCH bpf-next] bpf: allow loading instructions from a fd
 2020-07-14 17:31 UTC  (2+ messages)

[PATCH 1/2] bpf: Fix build for disabled CONFIG_DEBUG_INFO_BTF option
 2020-07-14 17:26 UTC  (3+ messages)
` [PATCH 2/2] bpf: Fix cross build for "

[PATCH v7 bpf-next 0/9] introduce support for XDP programs in CPUMAP
 2020-07-14 15:35 UTC  (12+ messages)
` [PATCH v7 bpf-next 1/9] cpumap: use non-locked version __ptr_ring_consume_batched
` [PATCH v7 bpf-next 2/9] net: refactor xdp_convert_buff_to_frame
` [PATCH v7 bpf-next 3/9] samples/bpf: xdp_redirect_cpu_user: do not update bpf maps in option loop
` [PATCH v7 bpf-next 4/9] cpumap: formalize map value as a named struct
` [PATCH v7 bpf-next 5/9] bpf: cpumap: add the possibility to attach an eBPF program to cpumap
` [PATCH v7 bpf-next 6/9] bpf: cpumap: implement XDP_REDIRECT for eBPF programs attached to map entries
` [PATCH v7 bpf-next 7/9] libbpf: add SEC name for xdp programs attached to CPUMAP
` [PATCH v7 bpf-next 8/9] samples/bpf: xdp_redirect_cpu: load a eBPF program on cpumap
` [PATCH v7 bpf-next 9/9] selftest: add tests for XDP programs in CPUMAP entries

[PATCH AUTOSEL 5.7 05/19] bpf: Set the number of exception entries properly for subprograms
 2020-07-14 14:38 UTC 

[PATCH v6 bpf-next 0/9] introduce support for XDP programs in CPUMAP
 2020-07-14 13:34 UTC  (2+ messages)

[PATCH 13/17] dma: nbpfaxi: Provide some missing attribute docs and split out slave info
 2020-07-14 11:15 UTC 

[PATCH bpf-next 0/4] bpf: cgroup skb improvements for bpf_prog_test_run
 2020-07-14  7:09 UTC  (11+ messages)
` [PATCH bpf-next 1/4] bpf: setup socket family and addresses in bpf_prog_test_run_skb
` [PATCH bpf-next 2/4] bpf: allow to specify ifindex for skb "
` [PATCH bpf-next 3/4] bpf: export some cgroup storages allocation helpers for reusing
` [PATCH bpf-next 4/4] bpf: try to use existing cgroup storage in bpf_prog_test_run_skb

pull-request: bpf-next 2020-07-13
 2020-07-14  1:04 UTC  (2+ messages)

[PATCH v2 bpf-next 0/2] Strip away modifiers from BPF skeleton global variables
 2020-07-14  0:11 UTC  (4+ messages)
` [PATCH v2 bpf-next 1/2] libbpf: support stripping modifiers for btf_dump
` [PATCH v2 bpf-next 2/2] tools/bpftool: strip away modifiers from global variables

[PATCH v3 bpf-next 0/2] bpf: fix use of trace_printk() in BPF
 2020-07-14  0:01 UTC  (4+ messages)
` [PATCH v3 bpf-next 1/2] bpf: use dedicated bpf_trace_printk event instead of trace_printk()
` [PATCH v3 bpf-next 2/2] selftests/bpf: add selftests verifying bpf_trace_printk() behaviour

[PATCH bpf-next] tools/bpftool: remove warning about PID iterator support
 2020-07-13 22:43 UTC  (3+ messages)

[PATCH bpf-next 0/3] xsk: add new statistics
 2020-07-13 22:36 UTC  (3+ messages)

[PATCH v7 bpf-next 0/9] bpf: Add d_path helper - preparation changes
 2020-07-13 22:07 UTC  (2+ messages)

[PATCH bpf-next v4 00/16] Run a BPF program on socket lookup
 2020-07-13 17:46 UTC  (17+ messages)
` [PATCH bpf-next v4 01/16] bpf, netns: Handle multiple link attachments
` [PATCH bpf-next v4 02/16] bpf: Introduce SK_LOOKUP program type with a dedicated attach point
` [PATCH bpf-next v4 03/16] inet: Extract helper for selecting socket from reuseport group
` [PATCH bpf-next v4 04/16] inet: Run SK_LOOKUP BPF program on socket lookup
` [PATCH bpf-next v4 05/16] inet6: Extract helper for selecting socket from reuseport group
` [PATCH bpf-next v4 06/16] inet6: Run SK_LOOKUP BPF program on socket lookup
` [PATCH bpf-next v4 07/16] udp: Extract helper for selecting socket from reuseport group
` [PATCH bpf-next v4 08/16] udp: Run SK_LOOKUP BPF program on socket lookup
` [PATCH bpf-next v4 09/16] udp6: Extract helper for selecting socket from reuseport group
` [PATCH bpf-next v4 10/16] udp6: Run SK_LOOKUP BPF program on socket lookup
` [PATCH bpf-next v4 11/16] bpf: Sync linux/bpf.h to tools/
` [PATCH bpf-next v4 12/16] libbpf: Add support for SK_LOOKUP program type
` [PATCH bpf-next v4 13/16] tools/bpftool: Add name mappings for SK_LOOKUP prog and attach type
` [PATCH bpf-next v4 14/16] selftests/bpf: Add verifier tests for bpf_sk_lookup context access
` [PATCH bpf-next v4 15/16] selftests/bpf: Rename test_sk_lookup_kern.c to test_ref_track_kern.c
` [PATCH bpf-next v4 16/16] selftests/bpf: Tests for BPF_SK_LOOKUP attach point

WARNING in submit_bio_checks
 2020-07-13 16:16 UTC  (3+ messages)

[PATCH bpf-next 0/7] BPF XDP link
 2020-07-13  5:12 UTC  (3+ messages)
` [PATCH bpf-next 3/7] bpf, xdp: implement LINK_UPDATE for "
` [PATCH bpf-next 5/7] libbpf: add support "


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).