All of lore.kernel.org
 help / color / mirror / Atom feed
From: Bart Van Assche <bvanassche@acm.org>
To: Damien Le Moal <Damien.LeMoal@wdc.com>,
	"Martin K . Petersen" <martin.petersen@oracle.com>
Cc: "James E . J . Bottomley" <jejb@linux.vnet.ibm.com>,
	Jaegeuk Kim <jaegeuk@kernel.org>,
	"linux-scsi@vger.kernel.org" <linux-scsi@vger.kernel.org>,
	Nilesh Javali <njavali@marvell.com>
Subject: Re: [PATCH v3 6/8] qla2xxx: Use scsi_get_sector() instead of scsi_get_lba()
Date: Thu, 13 May 2021 20:01:38 -0700	[thread overview]
Message-ID: <cee55aed-acd0-04da-5c31-95b6bcc20dd9@acm.org> (raw)
In-Reply-To: <DM6PR04MB70817364801262A63932A55EE7509@DM6PR04MB7081.namprd04.prod.outlook.com>

On 5/13/21 7:02 PM, Damien Le Moal wrote:
> On 2021/05/14 7:38, Bart Van Assche wrote:
>> @@ -2677,7 +2677,7 @@ qla2x00_handle_dif_error(srb_t *sp, struct sts_entry_24xx *sts24)
>>  			if (k != blocks_done) {
>>  				ql_log(ql_log_warn, vha, 0x302f,
>>  				    "unexpected tag values tag:lba=%x:%llx)\n",
>> -				    e_ref_tag, (unsigned long long)lba_s);
>> +				    e_ref_tag, (u64)sector);
>>  				return 1;
>>  			}
>>  
>>
> 
> Not entirely convinced the casts are needed for the log calls...
> Apart from that, looks good.
> 
> Reviewed-by: Damien Le Moal <damien.lemoal@wdc.com>

Hi Damien,

I will remove the cast from the ql_log() call.

Thanks,

Bart.

  reply	other threads:[~2021-05-14  3:01 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-05-13 22:37 [PATCH v3 0/8] Rename scsi_get_lba() into scsi_get_sector() Bart Van Assche
2021-05-13 22:37 ` [PATCH v3 1/8] core: Introduce scsi_get_sector() Bart Van Assche
2021-05-14  1:57   ` Damien Le Moal
2021-05-14  6:20   ` Christoph Hellwig
2021-05-14 16:06     ` Bart Van Assche
2021-05-14 17:10       ` Martin K. Petersen
2021-05-13 22:37 ` [PATCH v3 2/8] iser: Use scsi_get_sector() instead of scsi_get_lba() Bart Van Assche
2021-05-14  1:57   ` Damien Le Moal
2021-05-13 22:37 ` [PATCH v3 3/8] zfcp: " Bart Van Assche
2021-05-14  1:58   ` Damien Le Moal
2021-05-17 17:23   ` Benjamin Block
2021-05-13 22:37 ` [PATCH v3 4/8] isci: " Bart Van Assche
2021-05-14  1:58   ` Damien Le Moal
2021-05-13 22:37 ` [PATCH v3 5/8] lpfc: " Bart Van Assche
2021-05-14  2:00   ` Damien Le Moal
2021-05-14  2:58     ` Bart Van Assche
2021-05-13 22:37 ` [PATCH v3 6/8] qla2xxx: " Bart Van Assche
2021-05-14  2:02   ` Damien Le Moal
2021-05-14  3:01     ` Bart Van Assche [this message]
2021-05-13 22:37 ` [PATCH v3 7/8] ufs: Fix the tracing code Bart Van Assche
2021-05-14  2:05   ` Damien Le Moal
2021-05-13 22:37 ` [PATCH v3 8/8] core: Remove scsi_get_lba() Bart Van Assche
2021-05-14  2:06   ` Damien Le Moal

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=cee55aed-acd0-04da-5c31-95b6bcc20dd9@acm.org \
    --to=bvanassche@acm.org \
    --cc=Damien.LeMoal@wdc.com \
    --cc=jaegeuk@kernel.org \
    --cc=jejb@linux.vnet.ibm.com \
    --cc=linux-scsi@vger.kernel.org \
    --cc=martin.petersen@oracle.com \
    --cc=njavali@marvell.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.