ceph-devel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v3 0/5] ceph: new mount device syntax
@ 2021-07-08  8:42 Venky Shankar
  2021-07-08  8:42 ` [PATCH v3 1/5] ceph: generalize addr/ip parsing based on delimiter Venky Shankar
                   ` (4 more replies)
  0 siblings, 5 replies; 7+ messages in thread
From: Venky Shankar @ 2021-07-08  8:42 UTC (permalink / raw)
  To: jlayton, idryomov, lhenriques; +Cc: pdonnell, ceph-devel, Venky Shankar

v3:
 - generalize addr parsing based on delimiter
 - use __func__ is ceph_parse_fsid()
 - fail mount on conflicting mds_namespaces
 - mention `ceph fsid` in doc

This series introduces changes Ceph File System mount device string.
Old mount device syntax (source) has the following problems:

mounts to the same cluster but with different fsnames
and/or creds have identical device string which can
confuse xfstests.

Userspace mount helper tool resolves monitor addresses
and fill in mon addrs automatically, but that means the
device shown in /proc/mounts is different than what was
used for mounting.

New device syntax is as follows:

  cephuser@fsid.mycephfs2=/path

Note, there is no "monitor address" in the device string.
That gets passed in as mount option. This keeps the device
string same when monitor addresses change (on remounts).

Also note that the userspace mount helper tool is backward
compatible. I.e., the mount helper will fallback to using
old syntax after trying to mount with the new syntax.

Venky Shankar (5):
  ceph: generalize addr/ip parsing based on delimiter
  ceph: rename parse_fsid() to ceph_parse_fsid() and export
  ceph: new device mount syntax
  ceph: record updated mon_addr on remount
  doc: document new CephFS mount device syntax

 Documentation/filesystems/ceph.rst |  25 ++++-
 drivers/block/rbd.c                |   3 +-
 fs/ceph/super.c                    | 148 +++++++++++++++++++++++++++--
 fs/ceph/super.h                    |   3 +
 include/linux/ceph/libceph.h       |   5 +-
 include/linux/ceph/messenger.h     |   2 +-
 net/ceph/ceph_common.c             |  17 ++--
 net/ceph/messenger.c               |   4 +-
 8 files changed, 182 insertions(+), 25 deletions(-)

-- 
2.27.0


^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2021-07-12 11:18 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-07-08  8:42 [PATCH v3 0/5] ceph: new mount device syntax Venky Shankar
2021-07-08  8:42 ` [PATCH v3 1/5] ceph: generalize addr/ip parsing based on delimiter Venky Shankar
2021-07-12 11:16   ` Jeff Layton
2021-07-08  8:42 ` [PATCH v3 2/5] ceph: rename parse_fsid() to ceph_parse_fsid() and export Venky Shankar
2021-07-08  8:42 ` [PATCH v3 3/5] ceph: new device mount syntax Venky Shankar
2021-07-08  8:42 ` [PATCH v3 4/5] ceph: record updated mon_addr on remount Venky Shankar
2021-07-08  8:42 ` [PATCH v3 5/5] doc: document new CephFS mount device syntax Venky Shankar

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).