damon.lists.linux.dev archive mirror
 help / color / mirror / Atom feed
* [PATCH] mm/daemon: describe NR_DAMON_OPS in damon_ops_id
@ 2022-05-23 20:53 Khalid Masum
  2022-05-23 21:12 ` SeongJae Park
  0 siblings, 1 reply; 2+ messages in thread
From: Khalid Masum @ 2022-05-23 20:53 UTC (permalink / raw)
  To: linux-kernel-mentees, Shuah Khan, SeongJae Park
  Cc: damon, linux-mm, linux-kernel, Khalid Masum

NR_DAMON_OPS in the enum damon_ops_id is not described. Describe it for
better readability and also to fix a warning generated by make docs.

"NR" is described as "Total Number" and "DAMON_OPS" is described as
"Monitoring operations" in the same file. Hence describe NR_DAMON_OPS
as "Total number of damon operations".

Signed-off-by: Khalid Masum <khalid.masum.92@gmail.com>
---
 include/linux/damon.h | 1 +
 1 file changed, 1 insertion(+)

diff --git a/include/linux/damon.h b/include/linux/damon.h
index f23cbfa42..9e9fb4d78 100644
--- a/include/linux/damon.h
+++ b/include/linux/damon.h
@@ -262,6 +262,7 @@ struct damos {
  *
  * @DAMON_OPS_VADDR:	Monitoring operations for virtual address spaces
  * @DAMON_OPS_PADDR:	Monitoring operations for the physical address space
+ * @NR_DAMON_OPS:	Total number of monitoring operations
  */
 enum damon_ops_id {
 	DAMON_OPS_VADDR,
-- 
2.25.1


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] mm/daemon: describe NR_DAMON_OPS in damon_ops_id
  2022-05-23 20:53 [PATCH] mm/daemon: describe NR_DAMON_OPS in damon_ops_id Khalid Masum
@ 2022-05-23 21:12 ` SeongJae Park
  0 siblings, 0 replies; 2+ messages in thread
From: SeongJae Park @ 2022-05-23 21:12 UTC (permalink / raw)
  To: Khalid Masum
  Cc: linux-kernel-mentees, Shuah Khan, SeongJae Park, damon, linux-mm,
	linux-kernel

Hi Khalid,

On Tue, 24 May 2022 02:53:36 +0600 Khalid Masum <khalid.masum.92@gmail.com> wrote:

> NR_DAMON_OPS in the enum damon_ops_id is not described. Describe it for
> better readability and also to fix a warning generated by make docs.
> 
> "NR" is described as "Total Number" and "DAMON_OPS" is described as
> "Monitoring operations" in the same file. Hence describe NR_DAMON_OPS
> as "Total number of damon operations".

Thank you for this patch!  However, same patch has already posted by other and
merged in mm-stable[1], sorry.  Looking forward to your next patches, though!

[1] https://git.kernel.org/pub/scm/linux/kernel/git/akpm/mm.git/commit/?h=mm-stable&id=d4a157f5a26fbf1f1fd5da47a4772a738306348f


Thanks,
SJ

> 
> Signed-off-by: Khalid Masum <khalid.masum.92@gmail.com>
> ---
>  include/linux/damon.h | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/include/linux/damon.h b/include/linux/damon.h
> index f23cbfa42..9e9fb4d78 100644
> --- a/include/linux/damon.h
> +++ b/include/linux/damon.h
> @@ -262,6 +262,7 @@ struct damos {
>   *
>   * @DAMON_OPS_VADDR:	Monitoring operations for virtual address spaces
>   * @DAMON_OPS_PADDR:	Monitoring operations for the physical address space
> + * @NR_DAMON_OPS:	Total number of monitoring operations
>   */
>  enum damon_ops_id {
>  	DAMON_OPS_VADDR,
> -- 
> 2.25.1
> 

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2022-05-23 21:12 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-05-23 20:53 [PATCH] mm/daemon: describe NR_DAMON_OPS in damon_ops_id Khalid Masum
2022-05-23 21:12 ` SeongJae Park

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).