All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jiri Slaby <jirislaby@kernel.org>
To: Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	linux-serial@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 1/3] serial: 8250_pci: Refactor the loop in pci_ite887x_init()
Date: Tue, 26 Oct 2021 07:26:18 +0200	[thread overview]
Message-ID: <db3f31f4-46ed-0b6b-89a5-b3cb447e0fa7@kernel.org> (raw)
In-Reply-To: <20211022135147.70965-1-andriy.shevchenko@linux.intel.com>

On 22. 10. 21, 15:51, Andy Shevchenko wrote:
> The loop can be refactored by using ARRAY_SIZE() instead of NULL terminator.
> This reduces code base and makes it easier to read and understand.

Why don't we have array_for_each() BTW?

> Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>

Reviewed-by: Jiri Slaby <jslaby@kernel.org>

> --- a/drivers/tty/serial/8250/8250_pci.c
> +++ b/drivers/tty/serial/8250/8250_pci.c
> @@ -897,18 +897,16 @@ static int pci_netmos_init(struct pci_dev *dev)
>   /* enable IO_Space bit */
>   #define ITE_887x_POSIO_ENABLE		(1 << 31)
>   
> +/* inta_addr are the configuration addresses of the ITE */
> +static const short inta_addr[] = { 0x2a0, 0x2c0, 0x220, 0x240, 0x1e0, 0x200, 0x280 };

/me thinks about 'unsigned'.

-- 
js
suse labs

  parent reply	other threads:[~2021-10-26  5:26 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-10-22 13:51 [PATCH v2 1/3] serial: 8250_pci: Refactor the loop in pci_ite887x_init() Andy Shevchenko
2021-10-22 13:51 ` [PATCH v2 2/3] serial: 8250_pci: Get rid of redundant 'else' keyword Andy Shevchenko
2021-10-26  5:21   ` Jiri Slaby
2021-10-22 13:51 ` [PATCH v2 3/3] serial: 8250_pci: Replace dev_*() by pci_*() macros Andy Shevchenko
2021-10-26  5:20   ` Jiri Slaby
2021-10-26  5:26 ` Jiri Slaby [this message]
2021-10-26  6:44   ` [PATCH v2 1/3] serial: 8250_pci: Refactor the loop in pci_ite887x_init() Greg Kroah-Hartman
2021-10-26  6:51     ` Jiri Slaby

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=db3f31f4-46ed-0b6b-89a5-b3cb447e0fa7@kernel.org \
    --to=jirislaby@kernel.org \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-serial@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.